Lost my m-2 boot drive installed on endeavour z97-a board

It booted fine from the m-2 after initial install of endeavour 8/27.Customized it many times;updated system, adding timeshift, Blender, etc. with many successful reboots too. Then it developed a problem in the Bios where it wanted boot from my cddvd drive no matter how many times I corrected it manually. So I tried a cmos reset now it does not see the m-2 drive at a install option at all. I tried removing it and reinstalling it but still no m-2in the bios boot priority, boot menu or boot override. It does however show in the Dram status. Any ideas or am I looking at a complete reinstall .I hope not.

on which is it set ? raid ahci in bios ? does it sees in bios ?

Right now I removed the raid array so I don’t get that option. Should I reinstall the raid?

was curius it was in sata or ahci … missed some name i gues :slight_smile:

3 Likes

SATA is set to all devices. Can’t find ahci. I see Intel xHci set to smart auto and EHCI which is set to disabled.

xhci is for usb i gues …

but is there also a option disable sata ?

curius… but as it worked before, it should be fine.

you updated, the bios ? … if you cmos reset doesnt do a ‘big reset’ and set some defaults… mayby you over looked something

Usb is fully enabled. Set up a raid 10 four ssds. Didn’t update the bios just reset the cmos; pulled the battery and changed it. Changed the jumper pins then changed them back.Still no m-2 available even doing live version installation. when it asks about partitioning or where you would want the OS; it doesn’t list the m-2. I’m still trying to figure out what I’m missing.

if its installed, just try in bios disable sata… dont do anything excessive… just if you find some feedback… normal bios has always sort sata a ahci or intel-rst … but if you pull out the battery it reset the bios also… if i do that here or update my bios i have to put some changes back in my bios like secureboot etc… raid stuf i dont know really;. only weird if its worked before why not after…

Which Board?
Which BIOS?
Which M.2 device?
Are you booting legacy BIOS or UEFI?

Board is a z97-a Bios ver.2801x64 (is there a newer one? I can’t find it on the Asus site. The m-2 is a Kingston SA2000M8250G and booting from UEFI. Does not show the Kingston m-2 in boot priority. Lists it last in boot override.

inxi -Faz --no-host | eos-sendlog

bobcapp@ASUSZ97-A ~]$ inxi Faz --no-host | eos-sendlog
It seems my Bios 2801 does not retain the settings I change; even when I hit save. Doesn’t acknowledge my m-2 drive in boot menu only when I force a boot override.
Here is the output you asked for(I think)
[bobcapp@ASUSZ97-A ~]$ inxi Faz --no-host | eos-sendolg
bash: eos-sendolg: command not found
[bobcapp@ASUSZ97-A ~]$ inxi Faz --no-host | eos-sendlog
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 100 231 0 24 100 207 136 1173 --:–:-- --:–:-- --:–:-- 1305
https://clbin.com/g3edk

You missed a hyphen in the command syntax. You only need to post the link if you want.

inxi -Faz --no-host | eos-sendlog

Isn’t the drive you have EndeavourOS installed to listed under Boot Option Priorities right before Boot Override! That is where you need to set the first boot device.

no it is blank. how to set it to my correct m-2?

What are your other settings?

secure boot disabled
CSM set to disabled
Windows UEFI Mode

Key Management … I always clear secure boot keys before disabling secure boot.

Then maybe when it boots the entry will show?

secure boot wants to defer to windows always, I set it to other os.
CSM set to enabled . Should I disable it?
Key management all disabled as it comes up in order of all settings.
Windows UEFI mode? Under Boot from PCI-E PCI expansion mode or maybe Boot from storage devices. I set both to UEFI 1st

On my board it only has CSM or UEFI. I set it to UEFI as CSM just gives the ability for legacy Bios which I’m not doing. On yours the setup is a bit different according to the manual.

Under CSM when it’s disabled a lot of those entries in the menu disappear. As you say secure boot is tied to the Windows UEFI setting i guess.

Edit: I guess try CSM disabled and see.

Edit: My board is quite a bit newer. It’s an x570 amd board.

You never did post the hardware link it has a typo in it.

Maybe you could post

efibootmgr