Lost my m-2 boot drive installed on endeavour z97-a board

I’ll try right now.
I don’t use legacy either.

Calamares confuse csm it can instzll with mbr lol

Yes that’s why i turn it off and go UEFI only!

Disabling the CSM the secure Windows secure update:
(the Drivers?) reverts to disabling all SATA and m-2 devices

Oops! I will try again.

[bobcapp@ASUSZ97-A ~]$ inxi -Faz --no-host | eos-sendlog
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 100 5235 0 24 100 5211 93 20320 --:–:-- --:–:-- --:–:-- 20449
https://clbin.com/MRiIL
[bobcapp@ASUSZ97-A ~]$

Hmmm I’LL check ti out.

I don’t want to mess up your install if something goes south changing settings.

If you not install do alwys with right settibgs but some pc uses ahci but this board idk…should always see m2.

Thank you for that.

Okay i found the issue i think

ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston
    model: SA2000M8250G size: 232.89 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: S5Z42105 temp: 31.9 C scheme: MBR

Is this the drive EndeavourOS is installed to? It’s MBR not UEFI.

Yes this is the drive; MBR? How can I check?

test -d /sys/firmware/efi && echo efi || echo bios

I see a bunch of other drives or partitions but i can’t tell if it’s one drive or multiple drives or partitions and i don’t see partition scheme for those?

sudo fdisk -l

So does it show Bios with the command i gave you?

Edit: It will show either UEFI or Bios.

Are you still there? I’m waiting for you to reply to the posts?

Edit: When you install it should show UEFI (EFI) or MBR in the top left of the installer window here. This depends on your settings in the UEFI Bios.

So the efibootmgr command won’t work if it’s installed in MBR mode. The command i gave you will show UEFI or Bios (MBR)

I can’t say for sure this is the reason your drive isn’t showing up in the boot order. But it looks like it is installed in MBR mode not UEFI? Your board is a little older and the settings are a bit weird. It looks as though the setting has to be on other OS in order to turn off secure boot which it does automatically then. In that case i would set CSM on auto.

It’s not a problem that it’s installed in MBR as far as working but that’s what it looks like to me. I’d like to see the output of the other disks?

Edit: Does the command show it’s Bios?

[bobcapp@ASUSZ97-A ~]$ efibootmgr
EFI variables are not supported on this system.
[bobcapp@ASUSZ97-A ~]$ -d /sys/firmware/efi && echo efi || echo bios
bash: -d: command not found
bios
[bobcapp@ASUSZ97-A ~]$ -d /sys/firmware/efi && echo efi || echo bios
bash: -d: command not found
bios
[bobcapp@ASUSZ97-A ~]$ -d /sys/firmware/efi && echo efi || echo bios
bash: -d: command not found
bios
[bobcapp@ASUSZ97-A ~]$

[quote=“ricklinux, post:34, topic:21332”]
sudo fdisk -l
Kinston is the one i wa.nt to boot from
the the d,c,d,e Samsungs SSDs are a raid 10
the sda is only one partion

Aha I have to check that now.