Login freezes on Keyboard or mouse use

I just installed EndeavourOS Atlantis-neo 21.5 with KDE Plasma (online), and it went off without a hitch. I rebooted, and as soon as I entered the first password character, the computer freezes up completely :cold_face:.

At first the mouse (USB) moves fine, the login/power buttons light up on hover… and it takes a key stroke to trigger, but once it froze after just moving the mouse for a few seconds! :cry:

The mouse and keyboard work in BIOS, and of course they did throughout the install, so a hardware issue is less likely. :thinking:

I am going to chown in and check out the logs, but don’t expect me to recognize anything unless it is blatantly obvious.

Meanwhile: Did anyone else have, and fix this problem, or for that matter, know where and what to look for in order to help me fix the problem :smiling_face_with_three_hearts:?

Did you not try the latest ISO?

Edit: Just wondering is this a different system you are installing to?

1 Like

Try the latest release here:

2 Likes

Daaaaang are you quick! :smile: I thought that was the latest!

Why? Is there a newer one already? Is the ISO I used problematic in that regard? It’s predecessor worked just fine, and every version prior to it, including Antergos…

No i just wondered? A new ISO was put out yesterday. I just wondered if you were reinstalling a different desktop or this is on different hardware which might explain it.

Yeah, that’s the puzzling part, no changes to the machine at all, besides a few months in the closet.

I am on my main machine now. I finally got a network switch/router, and wanted to make a small office/rendering server with it. It served me well for over a decade without any problems. It’s an Athlon Phenom II, copper core from Dresden Germany (Tough as nails), and if it doesn’t want to give up, I won’t force it to, but use it for all it’s worth, which is still quite a bit thanks to Linux! :penguin: :penguin: :penguin:

For a rolling release distro like Endeavour (Arch) a few months is a long time

1 Like

Did you try starting it again?

Edit: Hard to say why it froze?

Of course I restarted a few times.

I just downloaded the Apollo ISO, and will give it a try :slightly_smiling_face:.

It’s not the first time I installed an OS, and something didn’t install right, where reinstalling fixed it, but it being a rolling release, had it not this problem, bringing it up to date would have been one of my first tasks after install. Last time I installed EOS on this box, was like 3 ISO’s ago, and I am on Kernel 5.17.1 now.

BTW, just in case: There’s no NVIDIA in the sick computer: AMD APU.

1 Like

Well, The new Apollo ISO (sha512 verified) won’t boot at all:

Failed to load ldlinux.c32  Boot failed...

:frowning_face:
It’s on the same Ventoy disk with the previous ISO which still works (I just booted to it).

Supposedly this is a known bug that is caused sometimes by tools used to create USB boot drives. I’m not a fan of ventoy i will just tell you that much. If you can create the live usb on your main machine on linux I would suggest installing popsicle and use that to create the live usb.

This is something new that i haven’t run across before.

The Arch wiki has some information on it. Supposedly it is file system related on the creation of live usb?

https://wiki.archlinux.org/title/syslinux#Failed_to_load_ldlinux

I haven’t seen this issue before but it is noted in the arch wiki and i see info about it on various other distros.

Edit: There are a number of issues and errors reported.

Well, with Ventoy, you make the drive a Ventoy system, and just put whole ISO’s on it, and it reads the ISO’s stored on it directly, so if one works (I have 5 OS ISO’s on it), they all should, and Apollo is the first one that doesn’t.

I never used Atlantis, or Apollo before this install. Last one I used was EOS 2021.08.27, without problems, on that very computer, and I am going to try that now, just to see if it works.

1 Like

I understand how ventoy works. I’m just saying i have run across many examples where it was the issue. Not saying it is in this case but you have to try other options in order to see what works. It can be updated files on the Clamaraes installer or syslinux or something. So far you are the only one reporting an issue.

There is nothing wrong with installing EOS from the other ISO. It will have all the latest as everything installs from the Arch repos unless you are doing an offline install and then it would have to be updated.

I’ll have to report this one to @joekamprad and maybe he has some idea why. :thinking:

If and when you get the ISO to boot (I’m sure it is a tool issue as you verified the ISO checksum), I suggest you install the linux-lts package with the headers package as well.
The original problem could be a kernel issue with your hardware.

I always install the LTS too, but I haven’t even tried to login to the LTS, so let me try that now:

Nope: It too freezes as soon as I use the mouse or keyboard (USB). :face_with_diagonal_mouth:

Could be a problem with some driver. Or a kernel parameter.

You could give us some logs after booting with the USB installer, e.g.

inxi -Faz | eos-sendlog
journalctl -b -0 | eos-sendlog

and show the returned addresses here.

I can furbish the logs, but if I installed the OS via the live USB online, and it runs without a hitch, and then the new OS gets all the way to the logon screen where the freeze happens, then how can the logs of an installer prior to it even being launched be of any help?

You never know. Without more information it is just guessing.