Live Boot + install EndavourOS: Can't get graphical Desktop

This is from my installed EndavourOS
Here is from: journal -k -b -0
Here is from: inxi -Fxxc0z

I can’t even reach graphical desktop, on your lates live boot iso.
I have made it via the gnome-disk-utility (from my install of “real” arch, on other nvme)
I can get tty, but are greeting with login:
And … I don’t have either user nor pass, so I can’t go futher and make same logfiles as above.

Wierd thing is:

  1. I have NO problem, booting a live usb this archlinux-2022.12.01-x86_64.iso and make a desktop install of KDE, like I would doing with EndeavourOS

I have read page up and down, read on wiki, read on intel, read on forum, I have try out several things, but nope. I can’t get your great EndavourOS to work anymore.

So LAST question from me:
Can I install archlinux, and then add YOUR repo, and get/gain like a “real” endeavour system that way?
Since, I got no problem with that methode at all.

IF there is any other info you need, just ask.

Ohhh I forgot:
My PC is as follow:

AMD Ryzen 9 5900X
32GB memory
3 x NVME ssd + some ‘normal’ 3.5" disk
Intel Arch A770 16GB Limited Edition. (I need to have Rebar endabled, and but also CMS turned off)
Logitech Keyboard and mice
32" LG, 2560x1440

(I struggle with health, + I got autism + ADHD) so please take that into your thoughts…

Greeting from Denmark, Per

Which EndeavourOS ISO are you using?

  Device-1: Intel DG2 [Arc A770] driver: N/A arch: Gen-12.7 pcie: speed: 2.5 GT/s lanes: 1
    bus-ID: 3f:00.0 chip-ID: 8086:56a0

Remove xf86-video-intel and restart xorg it does not actively support a GPU this new

That is also possible. Simply add the repo to /etc/pacman.conf, receive our GPG keys, and install a few packages like endeavouros-keyring and whatever you want or need.

As per Phoronix article.

Lates iso from this site…

I don’t have those driver installed ??? I do have looked careful around.
But of course I will have a look again.

Sir … I have read that page also.
Still, it do not tell me why I can’t make a NEW fresh install with the new cassini iso.

Then I will do that… Away more easy for me.

If you do that, please share the information about settings and drivers here. This is a new GPU, and others facing the same issue may benefit from your work.

  Device-1: Intel DG2 [Arc A770] driver: N/A arch: Gen-12.7 pcie: speed: 2.5 GT/s lanes: 1
    bus-ID: 3f:00.0 chip-ID: 8086:56a0

Since it’s not showing the driver loaded i would use the kernel parameter to force load it.

Add the following to the default grub command line in /etc/default/grub


The PCI ID is the output of:

lspci -nn | grep VGA | sed -n "s/^.\+\[8086:\([[:alnum:]]\{4\}\)\].\+$/\1/p"

Then update grub with

sudo grub-mkconfig -o /boot/grub/grub.cfg

Also set your driver in



Section “Device”
Identifier “Intel Graphics”
Driver “modesetting”

Save the file and then reboot. Hopefully the driver loads for the Arc A770 card.

Been there done that … not working …

The 6.1 kernel just installed. Have you tried that?

the command to get the pci is what i have used… to get: 56a0 … and all those settings have been tested.

I have now DELETED my previous install. I totally gave up on it.

Problem is still, I can’t even get into tty2 on LIVE USB Cassini, and make a error report from there.
There is no user/pass … so how you want me to inter tty2 - terminal ?

Becourse, same problem here, it won’t give me ANY desktop so I can install.

I guess that’s your choice. I don’t have the hardware so i can’t really help any further than suggestions of things to try. I only know from the log you posted the driver isn’t loaded.

It probably needs the latest firmware and or there is some other reason.

Edit: If you want i could pm you with a link to another ISO i have with newer firmware?

This have been tested:
endeavouros_cassini_22_12.iso ← NOT Working, won’t give me desktop, even if i remove all blacklist, and also do the i915.force.probe=0x56a0 (have also tested: 56a0) same problem. I have try out many different things with this iso. No luck at all.

archlinux-2022.12.01-x86_64.iso <— I can boot this, and install via: archinstall (the new script they have maked)

ubuntu-22.04.1-desktop.iso ← Can boot and install, but is very unstable doing to wayland

fedora-workstation-live-x86_64-37-1.7.iso ← Can boot, but got some wierd errors, might be me that have make something wrong. Not tested again.

cachyos-kde-linux-221119.iso ← Got it up and running, but was also here to unstable doing to wayland.

Going to test: ezarcher-kde-221210-x86_64.iso
ezNix is a youtuber and in my eyes very very skilled. He know what he is talking about.
I got the iso from here:

So that is my status so far…
All this mess, just becourse I REALLY want to enjoy EndeavourOS AGAIN…
(I encode lots of bluray to mkv… and AV1 Hardware encoder on that intel arc a770 is a DREAM!)
(Sadly it’s only work like 100% on windows 11… and I HATE that OS so much, that’s the reason I really want be able to use linux fulltime … and never go back to winBLOWS ever more.)

Dr. Pain aka Per, from Denmark, (I don’t use same nick everywhere, on telegram, I got another nick etc.)

Just a question: did you already tried (is it possible to try?) both with and without package

EDIT: not sure if you have read this:

Thanks for giving it a shot. I am curious to know if it works any differently or any better or worse than the others you have already tried. Thanks.

Yes I’m interested too.