`linux-odroid` is in the AUR

A little bit of news which may be of interest.

I’ve been following N2+ development and getting to grips with the differences between ARM-based SBCs and “standard” x86-based systems.

Anyhow, I’ve been building a 5.10.* kernel with patches from tobetter (one of the HardKernel developers) for my own use for the past couple of months and I think it works well enough for sharing:


This is also available prebuilt in my experimental odroid repo.

Big shout-out to jgmdev who did a lot of the initial work on these packages, and who is continuing to develop interesting tools over on the ODroid forum. (I did suggest he get in contact as I’m sure there’s good potential for collaboration, if not him maintaining an N2 image… :grin:)


I do have conversation with him already on odroid forum, and as you know having the same device, sitting here without being used, because of two issues, first exactly the kernel and second is that it will not connect to my network over wired lan… i need to use wifi what is hard to do from the archarm image :wink:

But does the newer kernel do not need another uboot image also?


Great news! Thanks!

I’m not sure - my device has such a mish-mash of packages now…

I should really create an Arch base image from scratch and see what’s still necessary…

1 Like

just try to boot with the kernel but it fails… i do not remember exactly, but i was thinking it needs another boot image… when i do last time tried out a newer kernel…

1 Like

I updated for 5.10.10 and have started moving the PKGBUILD back into line with the standard Arch kernel PKGBUILDs. Currently, all ALARM kernel packages conflict because it is assumed you can only have one installed at a time, but given the work being done by HardKernel’s @tobetter on petitboot this might not be true for long. That should mean at some point the facility to install multiple kernels and select which one to use at boot time - just like a normal PC… :grin:


i would love such!

1 Like

Yes indeed!

The PKGBUILD is slowly getting closer to allowing multiple kernels to be installed, but it looks like it also needs support from uboot. It also looks like chewitt has a mainline uboot working so next time I have a chance I’ll try that and see how it works (newer uboots can use GRUB!)

I also got distracted from this by rebasing on zen-kernel (and gaining all of the Zen kernel sauce, ClearLinux patches, etc.)… it seems snappier, but there’s no easy way to do a benchmark. :thinking:

1 Like

i am ready for testing, the odroid waiting for it…

I have uploaded linux-odroid-zen 5.10.13 to my odroid repo for testing. If this is confirmed working on other systems I’ll update the linux-odroid AUR PKGBUILD in line.

Also, interesting…


linux-odroid is up to 5.10.14 in both AUR and my repo, and linux-odroid-zen is at 5.10.14 in my repo for testing.

Both seem to have reduced screen artifacts with panfrost than 5.10.13 - it’s getting better all the time.

1 Like

What is the odds this will work with Wayland? Slim to none?
I imagine wayland is pretty far down on the list of priorities.
Just wishful thinking.


High. Alyssa Rosenzweig’s work on panfrost targeted Wayland first, and is only now moving (backwards?) onto X support.

I haven’t personally tried it (I mainly use MATE with picom, and it’s continually getting better), but GNOME is supposed to run very fluidly.

1 Like

First off, Thank You for providing the new Odroid N2 kernel packages on your server. :sunglasses:

I think I am missing something. I downloaded linux-odroid and linux-odtroid-headers and used pacman -U to install them, which also un-installed the old kernel.

Reboot and nothing. It didn’t even acknowledge there was a valid uSD card present.

What is the process to install the new kernel and get a bootable product?
Thank you in advance for any help you can give me.


Not sure. I also have jgmdev’s repo installed so it’s quite possible I have a different uboot version that supports the mainline kernel…

My next “free time task” is to see if I can build the mainline uboot and get it working for the N2+; ALARM has uboot-odroid-c4-mainline so I’m hoping a uboot-odroid-n2-mainline is also possible. If this works it will drag uboot forwards six years from its current version stuck in 2015…

1 Like

A different uboot makes sense.
Thanks for pointing me down a different path to follow. Will keep you advised.

As you probably know, a couple of forum members have come up with a themed sway WM that the theming is very close to @joekamprad 's i3 WM theming. I have already got the installer script to install EndeavourOS base and Sway WM on the Raspberry Pi 4 series. Works well.

I am now trying to get Sway to do the same on Odroid N2+. It also doesn’t work on the Odroid XU4 (32 bit). On the XU4 after login in LightDM, it tries to load Sway, gives an arrow cursor in the middle of the screen, then goes back to LightDM.

Is is possible for me to edit your package build to include armv7h in the Architecture statement, then run makepkg on a Odrid XU4 and have any chance of success?

forgot to say what I got sway working on, which is the Raspberry Pi 4 series. The RPi 4b 4 GB RAM, RPi 4b 8GB RAM, and the RPi 400.

1 Like

I’m not sure about chances of success, but you can definitely give it a go. I rebased 5.10.15 onto the Zen kernel source so there shouldn’t be anything N2-only in there, and tobetter’s patches target all ODROID SBCs.

1 Like

Thanks for all the advice. We are supposed to be on the cusp of an Arctic Blast of cold air for the next 2 or 3 days. This will give me something to do as at my age I don’t venture out in really cold anymore.


1 Like

as far as i remember the odroid n2+ have an issue with gpu drivers that make it fail to run wayland, this is caused by the fact that archarm has no kernel package including stuff needed for the odroidn2+.
I had a talk with jgmdev some time ago when I tried to get GNOME on wayland working on this device.

1 Like

I suspect things have changed recently with the latest Mesa 20.3 releases - the GPU is working (mostly) fine with the mainline kernel (see also https://forum.odroid.com/viewtopic.php?t=40013)