LightDM issues

I am having a strange problem where LightDM refuses to work after I have logged out. To be clear, at boot, it rolls into LightDM just fine, I can see what user to choose, and have the option of choosing the DE, do so, then work, then log out, and then I just have a black screen. Switching to VT2 I can login at CLI and sudo reboot, but restarting the lightdm service doesn’t help at this point. I’d prefer to stick with lightdm because it works best with deepin/cinnamon/xfce that I use.
I have googled the issue, but not found anything similar. Ideas?

EDIT: I tried LXDM, and that wouldn’t even show at boot, although according to systemd it was running.
I have tried with the standard kernel and the -zen kernel, no difference. I am thinking it must be something to do with the optimus graphics on this laptop, where it is failing to switch modes.

Ok, so answering myself here, but for the benefit of those who also trip over this issue; it is due to the bbswitch system of an optimus laptop.
What I did to solve it was reinstall as per the post here: