LibreWolf Browser Laggy

Whenever I use a browser that is (based on) Firefox, it always seems to be very laggy. Everything seems to be going at 30 fps (scrolling for example).

The same cannot be said however for browsers that are (based on) Chromium.

Is there any solution to this issue? I use a laptop with Nvidia optimus.

EDIT: When I play videos, however, it just goes smoothly at 60 fps?

EDIT 2: Okay, so I have concluded that it couldn’t be my GPU either, so it’s probably WebGL being disabled that causes this?

LibreWolf by default is hardened for security / privacy, you can make it work visually faster by re-enabling webgl which is tech that allows to fully use GPU for browser UI and some content (3D for example), however it will leak your ip then.

P.S. Requires browser reboot to take full effect


I use Firefox and it isn’t laggy. :wink:

Wait, then why wasn’t LibreWolf laggy when I used it on Windows? Is WebGL enabled for some weird reason on it?

Well if you’ll turn off WebGL for hardening it will be!


1 Like

No idea, newer used it on Windowz…I forgot what it is :rofl:
Perhaps they have different configs, since Windows is spyware anyway.

1 Like

30 FPS is as fast as the human eye-brain-connection can digest. As in a movie… just sayin’.


Don’t tell that to gamers :shushing_face:


Why do you need more than 30 fps to display text and images on (static) web pages?

You’re not using a web browser to watch videos, are you? Come on, it’s the current year, who does that any more? :rofl:

Most people use web browsers to watch videos.

No, that can’t be. The human kind has not yet degenerated that much! I refuse to believe it!

I’m sure most people are smart enough to use mpv or yt-dlp


:rofl: :rofl:

They didn’t advance at all in the first place!!

1 Like

Most people on Windows. :laughing:

Windoze has long become endemic. No mask-wearing, nor inocculation needed!

The whole computer-world seems to be satisified, relying on MS-Exchange, MS-ActiveDirectory, and MS-Office!

If anything goes wrong, it is a “Software problem, nothing you can do about it!”

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.