Lexer nm610 ssd wont be detected[only endavour artemis_22_6]

[this issue seems to be only with endavour os, tried arch, artix , pop os , debian so far] I have 2 ssds in my pc, i tried to install endavour os artemis on my system, but it wont pick up my lexar ssd no matter what, i opened the pc case, swapped the ssd position, it wont detect that, all other distros do detect and work fine with it, the bug seems to be with the lattest endavour os iso, previous ones do detect and work normally with the ssd, it is probably lexar nm610, please fix the bug

Welcome aboard! :smile:

Does the Artemis ISO recognize this ssd?
Please show the output of command

inxi -Faz | eos-sendlog

when booting the USB installer.

Is this an nvme ssd or a standard ssd drive? As @manuel asked above we need the output of the hardware booting on the live usb.

By searching it looks like an nvme ssd.

Yes and i think it could be that the OP needs to check the Bios settings and disable Raid and set SATA mode to ahci for the drives. It may have RST Intel Optane which needs to be turned off.

the boot log (from ISO) could show something… but a BUGF report needs more info to possibly investigate.

sorry it isn’t detected in largest arch iso too, I think problem derives from there, btw guyz sorry for late late response

@manuel here https://clbin.com/o0Cwc

other older isos detect it fine
installed endavour from older iso, ran into kernel panic upon updating, with disk was not found error

i installed it on hdd, and cant access my ssd
the logs are from my install

  Local Storage: total: 1.17 TiB used: 73.14 GiB (6.1%)
  ID-1: /dev/nvme0n1 vendor: Maxsun model: 256GB NM6-2280 size: 238.47 GiB
  ID-2: /dev/sda vendor: Toshiba model: HDWD110 size: 931.51 GiB
  ID-3: /dev/sdb type: USB vendor: A-Data model: USB Flash Drive
    size: 28.91 GiB

I see an nvme drive and an ssd drive along with your usb drive. Is there another drive that you say isn’t being detected? Is it also another nvme drive?

So you had this installed before on the lexer nm610 drive that is not being detected now since this error?

Please check your installation also.




yep i thought it wouldnt detect that slot, so moved the nvme around, still detected by older isos, but newer arch/endavour iso do not detect it

yes, the lexar one isnt getting detected, (detected in older isos) i have 2 nvme ssds

What does
hwinfo --disk
say about the Lexar ssd and other drives?

@manuel https://clbin.com/uAmDp

Is the nvme drive the lexar drive?
Did you use the USB installer for the command?

i installed endavour on my hard disk
it from from the install

i have 2 nvme ssds 1 is picked up other one is not
i switched the position too, the lexar one wont get picked up no matter what