Lenovo P1 Gen3 - Intel AX201 - when connecting to home Wi-Fi it says configuring interface

Hello everybody,

How are you doing? I have made the jump from Win11 to Endeavour OS and so far is has been a smooth ride however there is only one thing. Wi-Fi. I think my driver is correctly initiated since I can see all the Wi-Fi networks in my surroundings and I can connect to my phones hotspot, however when I connect to my home network it keeps saying configuring interface and then after couple of min. it fails and tries it again, and again and again.

With my phones hotspot there is no issue at all, my other devices do not display any issue with my home Wi-Fi at all. My P1 gen3 has worked perfectly with my home Wi-Fi when I was on Win11. Have tried to search the web for answers but it was a) not the same problem b) Issue was already solved a few kernels ago or c) The things i tried to not result in the solution to my problem.

Looking through the forums I could not find the solution for my problem, I think it has to do with Network Manager and iwd but I am not sure.

Hopefully anyone of you guys can help me out.

Hello @LittleBigPrime
Check this out
It’s worth trying to switch out power saving in power management.

Hello Eso,

I do not have Windows installed on my Lenovo anymore. I just find it strange how I can connect to my phone hotspot but not with my home network… And the link you’ve provided me with seems to be talking about dual boot system that still has Windows installed which I do not have anymore.

how do you see the mac address of the AX201? Is there a way to check this? I can’t find it in at the Info Centre under Network Interfaces

[Index» Kernel & Hardware» [SOLVED]Intel WIFI 6 AX201 Driver Issues](https://Index» Kernel & Hardware» [SOLVED]Intel WIFI 6 AX201 Driver Issues)

I found something in the wiki that maybe a fix, well it worked for me any ways. (Had a similar problem)

ifconfig -a
(re MAC addreess)

I have solved my issue regarding the Wi-Fi. The chip is working fine, it was the MAC address that was not registered… Which I find strange since I had the MAC address registered when I still used Windows. Anyhow it is fixed.

Check if you need to register your MAC address in your ISP or own router.

This sounds like a very ISP specific issue. I’m glad you solved it. You can mark your own answer as solution (there’s a checkmark you can click underneath each reply in a thread; clicking it will mark that reply as solution and change the thread status to solved), which will help others with a similar problem quickly identify the solution.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.