Latest Update to Grub has an error with grub-mkconfig (when using grub-customizer)

I tried to report this on Arch but I think I’ll need to log in from my Arch machine to create an account.

In the meantime, Grub2 updated today and, when I went to use grub-customizer (don’t judge :wink: ) to reset the list to what I wanted, it wouldn’t launch (or launched with an error message) Running grub-mkconfig from the command line shows it aborts with this error message"

BEGIN /etc/grub.d/LS_linux

/etc/grub.d/proxifiedScripts/linux: line 204: version_find_latest: command not found

So, at this point, I can’t manually change the list either (or use grub-set-default since grub-mkconfig isn’t working at the moment).

Works fine here


Odd, I’m still getting that error…looks like you’re running the same grub as well. I’ll try reinstalling.

Still getting the error…

Where did the proxifiedScripts directory come from? It doesn’t exist here (updated this morning):

$ lsd -Al /etc/grub.d/
Permissions User Group Size  INode     Date Modified           Name        
.rwxr-xr-x  root root  8.7K 1437181 2022-08-17 05:45:19 00_header*
.rwxr-xr-x  root root   12K 1536942 2022-08-19 12:31:41 10_linux*
.rw-r--r--  root root   12K 1536941 2022-08-17 05:45:19 10_linux.bak
.rwxr-xr-x  root root   14K 1437183 2022-08-17 05:45:19 20_linux_xen*
.rwxr-xr-x  root root   12K 1536940 2022-08-19 12:31:40 30_os-prober*
.rw-r--r--  root root   12K 1536939 2022-08-17 05:45:19 30_os-prober.bak
.rwxr-xr-x  root root  1.3K 1437185 2022-08-17 05:45:19 30_uefi-firmware*
.rwxr-xr-x  root root  2.4K 742657  2022-07-08 15:56:08 40_custom*
.rwxr-xr-x  root root  215B 1437187 2022-08-17 05:45:19 41_custom*
.rw-r--r--  root root  483B 1437188 2022-08-17 05:45:19 README
1 Like

Looks like that’s a grub-customizer thing. It also appears they’ve provided a RESTORE-INSTRUCTIONS file for when it borks. Logging off for now but, it appears they’ve anticipated this…

While I understand what Grub Customizer tries to do, I don’t like that fact that it’s basically circumventing the entire set of original Grub scripts. I only mess with (2): /etc/default/grub and /etc/grub.d/40_custom.

There was a time when I was tinkering with boot screens/themes and grub-customizer was an easy way to try them out. I guess I can probably get rid of it at this point.


Ok, after following restore instructions from the grub-customizer install, then (after confirming boot was still working) uninstalling grub-customizer and purging the old files. It boots and there are no more errors on grub-mkconfig. Although, I did need to re-install grub to get things like setting default boot working again.

LSS: grub-customizer is purged and grub is working normally again.



I see it is a nice playground to tinker grub… but grub … itself I mean this old lady… we need to avoid stressing her :wink:

True, and it’s not normal that I would do my “tinkering” on my main machine. I just went through phase of playing around with boot animations. The box I do have for tinkering with has the same issue but, since it still boots, I’m kinda curious to see if grub-customizer will address the issue over the next few days. If not, I’ll purge it from that box as well.

UPDATE: Went to report the bug to the grub-customizer developers but I first have to {shudder} create an UbuntuOne account. Maybe somebody else will find it…

Hi, I’m facing the exact same issue, since updating today.

I can run update-grub just fine, & boot just fine, though it has messed up ordering & what options are displayed.
After looking around, though grub-customizer does not seem to have the best… image, I do quite like it, making my life a bit easier & I want to continue using it.

Could you please elaborate a bit (in simpler terms :sweat_smile:) on what you did, or point my in the right direction?

I think this issue with Grub-customizer is known with the project and I think the best way is to keep your head cool and sit and wait until the fix is available, if you still want to use it.


If I recall, there was a “backup” folder in /etc/grub.d. Within that folder is a text file, “RESTORE-INSTRUCTIONS”. That gives you information on how to revert back.
That being said, you do need to be careful following the instructions. Borking Grub is no fun. I chose to remove it because I don’t think I really need it anymore. If you’re planning to keep it, I’d recommend going with the other advice on this thread and give it a few days to see if grub-customizer updates to fix the issue.

A couple additions: I did find that the backup files had the older EndeavourOS boot theme so I had to grab that one from the current setup.

I also found that I needed to reinstall grub after I was done to get everything working properly again.

used grub-customizer for several years and had a number of issues.
quite a few negative comments are found from internet searches about GC

switched to rEFInd and have had a much better experience.

1 Like

Never heard of it before but, I’ll give it a look :slight_smile:

Yes rEFInd is awesome. Triple boot here.

1 Like

I went poking around on like @JKMooney probably tried/did. He mentioned he tried but gave up.

I’m not confident the project knows about this issue. Yet. I see no recent issues, and nothing on proxifiedScripts.

grub-customizer 5.2.2 arrived on 7-31-2022. grub 2:2.06.r297* is dated 8-19-2022. grub-customizer is older. Last commit as of today was 7-30.

I’ve seen several telegram channel issues related to this proxifiedScript error. While not widespread, maybe we’ll be seeing more in the coming days due to grub’s newness as users update.

it looks like the issue is with the latest grub update affecting grub-customizer to have this issue…
It is a BUG on grub-customizer and it is way to complicated to report BUGS on their report system…

To validate one could downgrade grub to the version before… but i would say removing grub-customizer will be the best workaround :wink:

Everyone can ask on how not setup grub itself without the need of a GUI tool that includes a framework added in ADDITION to grub to candy it up…

sudo pacman -R grub-customizer
sudo mv /etc/default/grub  /etc/default/grub.bak
sudo rm -rf /etc/default/grub
sudo rm -rf /etc/grub.d
sudo pacman -S grub

I had the same issue with grub-cutomizer, but I solve it removing the whole directory /etc/grub.d/proxifiedScripts/ also you need to remove a file than invokes the script: /etc/grub.d/LS_Linux. If you don’t want to remove them, just copy them in your home directory as a backup. Start your grup-customizer again and this regerates the proxifiedScripts without the error.

1 Like