Latest update broke webcam

Good morning everyone! I use a MacBook air with EOS kde.

Is there something I can easily to to get my webcams working again? I had a tough time getting working in the first place, and wish I wrote down what I did.

Any help would be greatly appreciated. For reference, when I open Google meet it says webcam not found, but the mic does work.

Thanks again and stay safe!

as i do not know what device you are talking about:

could you post journal?

lspci > log.txt && lsusb >> log.txt && journalctl -b -0 >> log.txt && cat log.txt | curl -F 'f:1=<-'

Hi there, I appreciate your help… when I paste the log file here I get: Body is limited to 32000 characters; you entered 215247

Is there only a certain section you need? Is this even normal?

EDIT: here is a downloadable version

So, I tried reinstalling it… with yay -S bcwc-pcie-git.

At the end I get:
==> dkms install bcwc-pcie/r242.ea832ac -k 5.6.2-arch1-2
Error! Bad return status for module build on kernel: 5.6.2-arch1-2 (x86_64)
Consult /var/lib/dkms/bcwc-pcie/r242.ea832ac/build/make.log for more information.

That log file includes:
GNU nano 4.9.1 /var/lib/dkms/bcwc-pcie/r242.ea832ac/build/make.log
DKMS make.log for bcwc-pcie-r242.ea832ac for kernel 5.6.2-arch1-2 (x86_64)
Wed 08 Apr 2020 12:19:41 PM EDT
make: Entering directory ‘/usr/lib/modules/5.6.2-arch1-2/build’
AR /var/lib/dkms/bcwc-pcie/r242.ea832ac/build/built-in.a
CC [M] /var/lib/dkms/bcwc-pcie/r242.ea832ac/build/fthd_hw.o
CC [M] /var/lib/dkms/bcwc-pcie/r242.ea832ac/build/fthd_ddr.o
CC [M] /var/lib/dkms/bcwc-pcie/r242.ea832ac/build/fthd_drv.o
CC [M] /var/lib/dkms/bcwc-pcie/r242.ea832ac/build/fthd_ringbuf.o
/var/lib/dkms/bcwc-pcie/r242.ea832ac/build/fthd_drv.c: In function ‘fthd_pci_reserve_mem’:
/var/lib/dkms/bcwc-pcie/r242.ea832ac/build/fthd_drv.c:73:20: error: implicit declaration of function ‘ioremap_nocache’>
73 | dev_priv->s2_io = ioremap_nocache(start, len);
| ^~~~~~~~~~~~~~~
| ioremap_cache
/var/lib/dkms/bcwc-pcie/r242.ea832ac/build/fthd_drv.c:73:18: warning: assignment to ‘void *’ from ‘int’ makes pointer >
73 | dev_priv->s2_io = ioremap_nocache(start, len);
| ^
/var/lib/dkms/bcwc-pcie/r242.ea832ac/build/fthd_drv.c:79:19: warning: assignment to ‘void *’ from ‘int’ makes pointer >
79 | dev_priv->s2_mem = ioremap_nocache(start, len);
| ^
/var/lib/dkms/bcwc-pcie/r242.ea832ac/build/fthd_drv.c:85:19: warning: assignment to ‘void *’ from ‘int’ makes pointer >
85 | dev_priv->isp_io = ioremap_nocache(start, len);
| ^
CC [M] /var/lib/dkms/bcwc-pcie/r242.ea832ac/build/fthd_isp.o
cc1: some warnings being treated as errors
make[1]: *** [scripts/ /var/lib/dkms/bcwc-pcie/r242.ea832ac/build/fthd_drv.o] Error 1
make[1]: *** Waiting for unfinished jobs…
make: *** [Makefile:1683: /var/lib/dkms/bcwc-pcie/r242.ea832ac/build] Error 2
make: Leaving directory ‘/usr/lib/modules/5.6.2-arch1-2/build’

Maybe try installing the facetimehd-firmware package, and see if that makes any difference?

I had trouble with sound being broken in kde on the most recent kernel update. I dropped back to the LTS kernel, and everything worked correctly. Have you tried this?

1 Like

I haven’t, and don’t know how to do that.

After installing the facetimhd-firmware, I rand sudo modprobe facetimhd and got FATAL: module facetimhd not found in directory /lib/modules/5.6.2-arch1-2

In a terminal do:

sudo pacman -S linux-lts linux-lts-headers


sudo grub-mkconfig -o /boot/grub/grub.cfg


systemctl reboot

After rebooting there will be a new entry in the grub menu “linux-lts” select it and boot in and test the webcam again.


Yes, this did work. Is there anything else I would need to do at some point? Get rid of the other kernel? Or just leave it?

It’s never a bad idea to have more than one kernel installed. The lts kernel is usually my back up kernel. I would leave the other there. This way you can check back after some more updates/fixes and see if it works then :+1:

1 Like

Ah - gotcha. Thank you for your help. Had to use OSX today and ugh…


Mark it solved by

please :slight_smile:

m-i-s-100 :wink:

1 Like