Last update broke something

I did yay -Syu and had lots to download since last week.

I rebooted as suggested, and now I can’t get back into my system.

It’s stuck on a message saying tocblock might be corrupted.

I tried arch-chroot, but there is nothing for me to update, and I have no clue as to what to try now.

Can you share a picture of the full error?

Is there a way to do this without taking a picture on the phone?

If it happens early in the boot process a picture is probably the easiest.

If it happens late in the boot process in might be in the logs and you can pull it from there.

Are you dual-booting? If so, are the OSes on the same hard drive?

Are you mounting an NTFS volume or do you have an external drive connected which is NTFS?

1 Like

I may be totally off base here, as I’m not very Linux proficient, but after getting hosed twice with Grub, recently did a clean install, and if I’m not mistaken, installed with SystemD instead. I am now given a fallback option during Boot. Thus far I’m loving it.

I’m dual booting with a win10. It’s on a different drive. I have multiple drives for both OSes.

How will clean installing and swapping to SystemD affect my dual boot?

You don’t need to do that.

Any suggestions on how to avoid it? :grimacing:

I am not sure that issue is even related to your booting problem or not.

Were you using optimus manager by nayt chance?

Yes, I did install it during this week, yes. Would removing it help, maybe?

Take a look at this topic:

Removing Optimus didn’t help much. Would I have to reinstall it again now?

So, if i clean install the OS, is there a way for me to get some of my files transferred to say Google drive before nuking it?

Yes. Reinstalling it so it builds against the latest python is the solution for most people.

You shouldn’t have to do this but if you want to you could boot off the ISO, mount your drive and copy the files off that way.

I’ll try rebuilding it when I get home. If that doesn’t work, I guess clean installing is the way to go?

No, as @dalto said several times, it is not.

I would go further and say that’s almost never a way to go, unless you really, really mess up.

Sure, if you reinstall, you will get a working system until you break it next time, but you’ll lose something of much greater value: the opportunity to learn about your system. So, you’ll be just as clueless the next time.

Nobody ever became an experienced Linux user by reinstalling the OS whenever there is a slightest problem. It’s the most pathetic way to solve problems.


I found this thread that seems very close to your issue, even if it is a completely different distro. Seems to be fixed through GRUB advanced options. See the “Update #1” section of the marked answer.

No, you are right about this. It is, however, an easy step in case of “messy operating system”.

So. I left my computer at the tocblock error when removing optimus didn’t work. When I came back now 2 hours later, the system had somehow rebooted and started fine. I don’t even know what caused it, nor what fixed it.