Users of optimus-manager, beware the python update!

There was a large amount of python updates. Now optimus-manager does not work.

I got to the login screen and the monitor turned black, then flashed a bit with the cursor and then black to black and repeat.

After arch-chroot and some thinking I removed Optimus-manager and now it works again.

Just a heads up!


Hi, new user to endeavour here. I’m facing the same issue and I’m not familiar with chroot or what I can do to remove Optimus-manager at this point. Could you detail a bit on what you did? Thank you!

Thank you very much.
I was trying to troubleshoot my unbootable system for more than an hour and then i found your post.
I edited my grub to boot and login in text based and then simply removed the optimus-manager package.


Here is the wiki for Chroot.

If you can get to the terminal in another way that works as well.

you need to rebuild optimus-manager against the new python before reboot after the update…

aur/optimus-manager 1.4-4 (+120 0.13) 
    Management utility to handle GPU switching for Optimus laptops

yay -Syu optimus-manager

You will get informed on updating about the need to rebuild also:

(5/5) Checking which packages need to be rebuilt
foreign  optimus-manager
foreign  tlpui

foreign means it is not a repo package so it is from the AUR… there is no blinking warning about but it does inform you :wink:

this comes with the default installed package:

Like always: Those who can read have a clear advantage! (only as a joke :clown_face:)


I have changed the title, so it is more clear which update is related to the issue.


Thanks for this post. Did update optimus-manager and it worked now. Much appreciated.


Echoing the thanks, managed to chroot and remove the package! Cheers :smile:


I had access to TTY, and that made the procedure easier.
Just pressed ctrl+alt+F4 (for example), made the loggin, and typed the command.

1 Like

So if I understand that correctly, if Optimus Manager was not installed by now, I can install it without an issue after the Python Update?

I’ve just done the update and rebooted, and I just read the post… and too late.
What should the affected users now do?

effected users :wink:
optimus-manager is an AUR build you need to keep it updated you can try if you can reach TTY Ctrl+Alt+F3 and rebuild optimus-manager
yay -S optimus-manager or boot without X : and do the same…


Yup, worked.
Thank you! :heart:

1 Like

I installed today and everything is fine, but it was a clean install, right after updating everything.

yes only if tool would have been build and installed befor ethe python upgrade it would cause issue if you build now it will build against installed python

1 Like

This has been my case and it has saved me. Already solved. thank you.

1 Like

This got me a few days ago also. But it was the second time this has happened. Surely there’s some way of triggering a rebuild of an AUR package when a dependent library, like python, is upgraded?