Laptop heating up on KDE

Very strange behavior. I just changed my lenovo carbon x1 from gnome to a new install of EOS cassini KDE plasma. The laptop keeps heating and the fans spinning a lot. I didn’t have this with gnome. I also installed i3wm, logging out of KDE and into i3wm confirms the heat goes down and fans stop spinning all the time.

Anyone else having issues like that with KDE plasma? Any idea what could cause this, I mean it must be DE related, or some qt packages. Strange.

In KDE Plasma, baloo is a search indexing service running in the background. In a new install, baloo uses a lot of resources trying to index everything on your disk(s).

Try turning baloo off and see if this helps.

balooctl suspend
balooctl disable
balooctl purge
balooctl status

[edit} You might want to also reboot after the above commands [/edit}

If this helps, then you must decide how badly do your need search indexing.
If this helps, then you will know what at least part of the problem is.
If you need search indexing, the longer baloo runs and gets everything indexed,
the load on the OS becomes less.



thanks for that, that could be the culprit! Will try tomorrow at work.

What is the hardware on this laptop? If it is ryzen don’t forget to add this kernel parameter to the default grub command line and update grub.


1 Like

It’s my “older” lenovo carbon x1 with intel Xe. Here is my hardware, sorry currently logged in i3wm, but I also have most recent KDE.

I will keep that in mind for my other AMD laptop! thanks.

I think there is another Bios update for that laptop?

Edit: If I’m looking at the correct one it is version 1.58?

Not sure why this would be happening?

I would have to check. I dont have windows installed on this one anymore for the bios update. But strangely it does use the fan and heat a lot only on plasma. I think baloo indexing could be the problem. I will have to try Pudge’s suggestion.

Edit: I know there maybe a possibility to upload the bios update on a stick, and boot into it.

That’s strange as i have never had any issues with baloo but most turn it off. Mine is not but i think I’ll turn it off too. I forgot about this since i reinstalled with Cassini.

1 Like

Baloo is cool, but with the default configuration and lots of files in your home directory it might quickly become a resource hog. If you tweak it appropriately to your need it’s useful and efficient:

I don’t have hardly any files. I’m not the typical user. I don’t keep anything. I just roll. :laughing: