Laptop "freezes" randomly

Hey all!

It seems like my newly installed EndeavourOS is “freezing”. Interestingly, when it “freezes”, if I was typing right before that I can continue using my keyboard and type things into my text editor/ browser, etc. Additionally, if there’s music playing it will continue playing just fine. However if I try to use my mouse to click on something, or to change my window (I’m using i3), nothing happens.

Here is my inxi -Faz: pastebin

I tried looking around and found the advice here: Sporadic Hard Freezes Requiring Full Power Cycle but that’s not particularly relevant. I also found advice saying I should try downgrading to a LTS kernel, but that still led to freezing.

Somehow I stumbled onto: Temporarily freezing randomly? and the solution there seemed to work in that it no longer hard-freezes (needs a restart), but it will occasionally freeze for a second or two. I was wondering if anyone has run into something similar or knows how I might be able to fix this? The fact that it’s now usable even with the freezing is already a huge relief, but still, it’s rather annoying.

EDIT: Hmm, I just noticed that the error pops up whenever I press one of my function keys (e.g the BRIGHTNESS_DOWN, BRIGHTNESS_UP, buttons on my laptop. For some reason they were working fine earlier but now they’re not. Does this give any insight :confused: ?

do a
sudo dmesg -T
also? There maybe SD bus errors obvious there?

The next time it happens, reboot with [Tip] Enable Magic SysRq Key (REISUB) if you haven’t already set it up. NEVER hard reboot. Then provide journallog from the previous boot so we can see why it froze.


The pastebin is here! What should I be looking out for?

1 Like

Yeap! I only found out about that recently… I’ve been doing hard reboots a TON… Anyways, here’s the result of running

journalctl -b-1

Part1 and Part2

The word ERROR would have been a start as to what to look for. As there is none in that list, it would appear that the software side is fine. The Thinkpads are supposed to be the best for Linux.
How long has it been since the thermal paste was inspected ( grasping at straws, but it wouldn’t be the first time that had been the issue! ) ??

It has not been the first time since I’ve run into this issue, no. I’ve been running into it since I upgraded from my old manjaro around 3 weeks ago. I’ve tried reinstalling it and other various fixes including kernel changing, etc. but no dice. I installed Endeavour today hoping that this would have been the solution, but it’s not been.

(Have I effed my computer by doing the hard resets :/?)

Unlikely. What hard resets hurt the most is the old spinning platter drives.

How about a network? If you set up SSH server on this machine, can you access it when it “locks” from another machine, so you can inspect what’s going on at that point?

1 Like

Ooohh I’ll look into that! One other thing that came to mind is I’ve recently had issues with lightdm? I’ve had to disable the service as it was causing infinite login loops and the solutions online (stuff about Xsession and such) didn’t work

This behavior suggests it is not a system freeze, but possibly your DE breaks, or Xorg crashes.

It is not uncommon when playing games.

Inspect Xorg log and ~/.xsession-errors

Inspect Xorg log

The standard Xorg.0.log and the Xorg.0.log.old.

and ~/.xsession-errors

Seems to be empty :confused:

Check the .old one. No xsession…
Maybe an error in dotfiles breaks the session… :face_with_head_bandage:

My directory structure is

    | /xinit/
    |    | xinitrc
    |    | xinitrc.d
    |    |    |  
    |    |    |  
    |    |    |
    |    | xserverrc
    | /xorg.conf.d/
    |    | 00-keyboard.conf  
    |    | 20-intel.conf

What might I be looking for in terms of dotfiles? How might I validate if something IS breaking and where it is? :confused: Sorry, I’ve never dealt with this error before

Separately, from looking through the logs it seems like there are other errors? Might you know what’s up with those?

Ahead of my opening my ports, etc. What do you think I should be looking for?

Do you have the latest UEFI Firmware(Bios Update)

Nope, still hangs even after I did the update/upgrade :frowning:

I ran

sudo pacman -Syyu fwupd
fwupdmgr get-devices
fwupdmgr get-updates
fwupdmgr update

but no dice (there were a ton of updates though). Interestingly on a fresh install or on liveusb I don’t run into any issues at all…

Did you try the bottom one?

Power management/Throttling issues

A bug causes the CPU to consume less power than under Windows and throttle at 80°C instead of 97°.

Lenovo has confirmed the issue, explained the cause and published updates for the embedded controller and the BIOS to LVFS .

The alternative fix is to install throttled, then start/enable lenovo_fix.service.

Edit: The package is in the AUR and you just have to enable the service.

Hmm, it still seizes up every once in a while :confused: and still freezes whenever I press a brightness key even on linux-lts (not that I expected it to make a difference at this point)

Also, it seems like my temps are unusually high? They seem to hover around 60 for no good reason and will sometimes spike to 80 or 100. I’m going to get some thermal paste but I don’t think that’s the main issue here

IMHO, it’s about the DE, but not sure.
I would keep htop open to watch which tasks top up CPU and RAM.
Creating a new test user and using a different DE will help eliminate any suspicion on userspace.

HW issues could be CPU thermal paste and a blocked cooling fan.