Laptop "freezes" randomly

IMHO, it’s about the DE, but not sure.

Damn, I was hoping that because I’m using i3 that it would be pretty stable.

Creating a new test user and using a different DE will help eliminate any suspicion on userspace.

Gotcha! I’ll create an xfce instance or smth and see how that goes.

HW issues could be CPU thermal paste and a blocked cooling fan.

I’ve got an old laptop I need to clean up anyways so I might as well do it for the current one anyways

Thanks! I’ll post updates as they come about

I would SSH into the machine, then run htop to see what is chewing on the processor.

Hmm, nothing out of the ordinary :confused: There’s basically no noticeable difference in the htop… I’m attaching the ps aux below

ps aux

Hmm, adding another user, some_tester, and another DE seems to have made it work? I can press the audio and brightness keys and they work as expected. But when I log in as my usual user, ian , when I press those buttons it just locks up.

I’m not sure what changed other than me adding some_tester to the sudoers group… I added my ian to the group too but still not working :confused:

NOTE: I wonder if it’s something I installed? Because initially my ian worked just fine too?

These are basically the packages I install between a fresh install that works as expected, and one that gives me trouble

sudo pacman -Su libxi  libxrender alsa-utils alsa-card-profiles alsa-firmware 
sudo pacman -Su libxrandr terminator texlive-fontsextra libxcursor pavucontrol 
sudo pacman -Su gparted beep texlive-formatsextra texlive-bibtexextra rofi zip 
sudo pacman -Su sof-firmware py3status texlive-latexextra libxcomposite 
sudo pacman -Su libxau libxtst alsa-lib libxss alsa-ucm-conf tmux libpqxx 
sudo pacman -Su redshift mesa-libgl libxdamage texlive-bin libglvnd 
sudo pacman -Su texlive-core texmaker jre8-openjdk alsa-tools alsa-plugins 
sudo pacman -Su unzip firefox python-pip chromium obsidian signal-desktop 
sudo pacman -Su openssh gnu-netcat postgresql timescaledb zsh

and then

yay google-chrome
yay dropbox 
yay cryptomator 
yay slack-desktop 
yay nvm 
yay snapd 
yay mullvad-vpn (after installing rustup)

Then I run

systemctl enable snapd 
systemctl start snapd
sudo ln -s /var/lib/snapd/snap /snap

to enable snapd and finally

sudo snap install code --classic
sudo snap install clion --classic
sudo snap install pycharm-professional --classic
sudo snap install authy
sudo snap install spotify
sudo snap install zotero-snap
sudo snap install zoom-client

All from my github init files because I can’t ever remember all the things I install

Not a system problem.

Compare the two users’ folders contents.


Check what you have configured into those buttons.
Maybe you have somehow changed their configuration for your first account?

Not a system problem.

What do you mean by this? Meaning it’s not something I installed?

Compare the two users’ folders contents.

You mean on the home folder?

Check what you have configured into those buttons. Maybe you have somehow changed their configuration for your first account?

Hmm, gotcha so output the keymaps and compare them? That’s a good idea. But it doesn’t explain why the ian user occasionally freezes for a second or so.


Each user has a folder at /home/$USER/. Those two.

I mean, IIRC i3 has own keybindings configuration in its config file (I don’t use i3…).
There might be a difference in those keybindings between the users’ config files. Or check however you think it does the job :person_shrugging:

First find the problem and fix it, and then you go to explanations. I guess… :person_shrugging:

I can guarantee it’s not spotify. Have you tried just installing i3 on its own and nothing else? I’m sure it’s something you have installed or configured because i3 works flawlessly.

Each user has a folder at /home/$USER/. Those two.

Right, but I’ve got probably hundreds of nested files and folders. I’m still not sure what to look for.

Have you tried just installing i3 on its own and nothing else?

Yeah, on fresh installs my i3 works just fine. It’s after installing all the programs that things go sideways. Do you think uninstalling everything then progressively installing them will help? Or do I have to start tabula rasa and then install as I go along. Even using binary search to find the package is going to be a nightmare

The error (pressing brightness key causes the system to seize up) happens on other DEs as well for the ian user. However, it doesn’t manifest when I’m on my test_user even though test_user has access to all the packages installed by ian

If you want answers for a problem you face on your system, nobody but you can give them.

What all the rest of us supposed to doing is looking in our personal Crystal Balls :crystal_ball: .
Only a few of those have a less foggy picture, but not even one can see inside your own PC. :wink:

Nevertheless, you may ask Meld, :mage: the Magician :rofl:

1 Like

Install each one at a time and check if each work and don’t cause any problem. Don’t install them all and then try to figure it out. Narrow it down to the culprit!

Should I just do a fresh install and walk through it 1-by-1 ? Or do you think I can do it in a VM? Basically what do you think would make this the least painful because this is really going to be painful as I have disk encryption sooooooo that’s gonna suck. Also, the problem only rears its head on power on, not in the moment :confused:

Try it in a vm…then if you can narrow it down?

1 Like

Use the Magician.
Meld can compare folders. There is a filter to show only files that exist on both folders you compare.
Create a folder in your broken usual system and open a terminal in that path. Then copy the 2nd user’s .config folder inside, recursivelly.

mkdir otheruser && cd otheruser
sudo cp -r /home/otheruser/.config .
cd ..
chown -hR ian:ian otheruser

Then run meld and create a folder comparison.
Can you take it from here? :stuck_out_tongue_winking_eye:

I didn’t realize you meant an actual command… I thought you were referencing a game :man_facepalming: I’m so embarrassed I didn’t realize it was a thing.

I’ll try it when I get access to my machine and I’ll share an update here

Hey all!

So unfortunately, I don’t have an actual answer for what happened. The best I can gather is that installing snap did something funky to my system and caused everything to SNAFU. After a fresh install and using the aur as opposed to snap, everything worked as expected.

Not satisfactory, but it addressed ALL the issues.

good take on it,
snap causes often problems with arch systems,
also a good alternative to aur are the chaotic-aur

Stupid question from my side. Why do you use snap? I used snap when I was on Ubuntu. But here in Arch Linux world I don’t see the necessity for using snap.