Laptop Discrete Graphics card (AMD) are not used

I think @petsam is asking you to read the archwiki article and try the options there.
Have you done so?

2 Likes

But we have some rules, in order to help you and mainly … keep ourselves calm…
Post exact commands, not from memory.
Post actual info, when needed. In text, output from terminal commands, including the input (command used).
And have patience. This is a forum, not social media. Wait for more people to read and respond.

2 Likes

Not yet, i dont have time to right now. Ill be sure to though

Edit: Im starting to sense the tension, let me ease that by saying I’m going to read the wiki and try more solutions before continuing in this thread :wink:

In all fairness to the OP i think he is trying and i may not be giving him the right info exactly either. I’m trying to help but I’m no expert on hybrid graphics setup.

1 Like

There is no tension here. Sorry if you felt that way. It is very hard to troubleshoot issues without proper logs and detailed descriptions of things tried and their outputs (for example, if you try a command what command you tried and what was the output in the terminal).
This helps people with knowledge about that stuff diagnose the problem and hopefully fix it.
We try to be a welcoming and friendly community here. :enos_flag:

2 Likes

This is the video i followed in mint and it worked fine. I enabled switching and then used the card with obs as shown in the video. Ill continue at a later time. Thanks

I was able to login through cli and empty the contents of the file after using ctrl + alt +f2. Thanks for that!

FWIW, you could copy/paste terminal output as text, highlight it and click on </> to format.

This is useful if someone need to quote a piece of it and also it makes it searchable by search engines.

Thanks!

:enos_flag:

2 Likes

That makes sense. Ill do that moving forward.

Edit: noting here that the laptop refuses to run strictly on the radeon card in its current configuration.

2 Likes

Hybrid graphics/AMD Dynamic Switchable Graphics

It is the technology used on recent laptops equiped with two GPUs, one power-efficent (generally Intel integrated card) and one more powerful and more power-hungry (generally Radeon or Nvidia). There are two ways to get it work:

  • If it is not required to run ‘GPU-hungry’ applications, it is possible to disable the discrete card (see Ubuntu wiki):

echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

  • PRIME: Is a proper way to use hybrid graphics on Linux, but still requires a bit of manual intervention from the user.

as @ricklinux already mentioned…

https://wiki.archlinux.org/title/PRIME#Open-source_drivers

read this first and ask if something in the procedure is unclear…

xrandr --listproviders > prime-check.txt && glxinfo | grep "OpenGL renderer" >> primecheck.txt && cat primecheck.txt | eos-sendlog

to give us the info about what is present…

basically switching should work if both drivers are installed and yur inxi output shows both GPUs j´have a driver loaded …

xrandr --setprovideroffloadsink radeon Intel

1 Like

Only for info.

[penguin@penguin ~]$ sudo pacman -S xf86-video-amdgpu
[sudo] password for penguin: 
warning: xf86-video-amdgpu-22.0.0-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Package (1)              Old Version  New Version  Net Change  Download Size

extra/xf86-video-amdgpu  22.0.0-1     22.0.0-1       0.00 MiB       0.07 MiB

Total Download Size:   0.07 MiB
Total Installed Size:  0.17 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] n
[penguin@penguin ~]$ xrandr --listproviders
Providers: number : 1
Provider 0: id: 0x47 cap: 0xb, Source Output, Sink Output, Sink Offload crtcs: 4 outputs: 5 associated providers: 0 name:Intel
[penguin@penguin ~]$ xrandr --setprovideroffloadsink radeon Intel
Could not find provider with name radeon
[penguin@penguin ~]$ xrandr --setprovideroffloadsink amdgpu Intel
Could not find provider with name amdgpu
[penguin@penguin ~]$ grep "No modes" ~/.local/share/xorg/Xorg.0.log
grep: /home/penguin/.local/share/xorg/Xorg.0.log: No such file or directory


this should show two providers…
Providers: number : 2

Thats my main problem here. The source of the problem is what im hoping to find with the help of the PRIME section in the wiki…

funny that inxi -Ga shows it … but anyway … try enable early boot load with this:
edit /etc/mkinitcpio.conf (as root/admin)

and add radeon to the modules line:
MODULES=(radeon) // edit this is the way it is inside original mkinitcpio.conf file from arch…
MODULES=" ... radeon ..." // this is how calamares sets the options in this file… both seem to work :wink:

save file and regenerate kernel images:
sudo mkinitcpio -P
reboot try again … to see if you got two providers… if boot fails …
revert…
remove it form the modules line and regenerate kernel images…
sudo nano /etc/mkinitcpio.conf

And as fgar as io can see you amd gpu is only working with radeon module… amdgpu is to new … but i am never sure on amd gpus and the naming… but radeon is shown as driver already … and it would use amdgpu automatically…

shows failed to work on arch :frowning_man:
but would need full pci-id to see about exactly your device … as it seems you are on a Samsung?

[penguin@penguin ~]$ sudo mkinitcpio -P
==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'default'
  -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts.img
==> Starting build: 5.15.39-1-lts
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
==> WARNING: consolefont: no font found in configuration
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
/usr/lib/initcpio/functions: Zeile 404: _addedmodules[]: Falscher Feldindex.
/usr/lib/initcpio/functions: Zeile 404: _addedmodules[]: Falscher Feldindex.
/usr/lib/initcpio/functions: Zeile 439: _addedmodules[]: Falscher Feldindex.
/usr/lib/initcpio/functions: Zeile 439: _addedmodules[]: Falscher Feldindex.
==> ERROR: module not found: `'
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-lts.img
bsdtar: Failed to set default locale
bsdtar: Failed to set default locale
==> WARNING: errors were encountered during the build. The image may not be complete.
==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'fallback'
  -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts-fallback.img -S autodetect
==> Starting build: 5.15.39-1-lts
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: bfa
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: qla2xxx
==> WARNING: Possibly missing firmware for module: qed
==> WARNING: Possibly missing firmware for module: qla1280
==> WARNING: Possibly missing firmware for module: wd719x
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
==> WARNING: consolefont: no font found in configuration
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
/usr/lib/initcpio/functions: Zeile 404: _addedmodules[]: Falscher Feldindex.
/usr/lib/initcpio/functions: Zeile 404: _addedmodules[]: Falscher Feldindex.
/usr/lib/initcpio/functions: Zeile 439: _addedmodules[]: Falscher Feldindex.
/usr/lib/initcpio/functions: Zeile 439: _addedmodules[]: Falscher Feldindex.
==> ERROR: module not found: `'
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-lts-fallback.img
bsdtar: Failed to set default locale
bsdtar: Failed to set default locale
==> WARNING: errors were encountered during the build. The image may not be complete.
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 5.17.7-arch1-1
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
==> WARNING: consolefont: no font found in configuration
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
/usr/lib/initcpio/functions: Zeile 404: _addedmodules[]: Falscher Feldindex.
/usr/lib/initcpio/functions: Zeile 404: _addedmodules[]: Falscher Feldindex.
/usr/lib/initcpio/functions: Zeile 439: _addedmodules[]: Falscher Feldindex.
/usr/lib/initcpio/functions: Zeile 439: _addedmodules[]: Falscher Feldindex.
==> ERROR: module not found: `'
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux.img
bsdtar: Failed to set default locale
bsdtar: Failed to set default locale
==> WARNING: errors were encountered during the build. The image may not be complete.
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
==> Starting build: 5.17.7-arch1-1
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: bfa
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: qla2xxx
==> WARNING: Possibly missing firmware for module: qed
==> WARNING: Possibly missing firmware for module: qla1280
==> WARNING: Possibly missing firmware for module: wd719x
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
==> WARNING: consolefont: no font found in configuration
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
/usr/lib/initcpio/functions: Zeile 404: _addedmodules[]: Falscher Feldindex.
/usr/lib/initcpio/functions: Zeile 404: _addedmodules[]: Falscher Feldindex.
/usr/lib/initcpio/functions: Zeile 439: _addedmodules[]: Falscher Feldindex.
/usr/lib/initcpio/functions: Zeile 439: _addedmodules[]: Falscher Feldindex.
==> ERROR: module not found: `'
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-fallback.img
bsdtar: Failed to set default locale
bsdtar: Failed to set default locale
==> WARNING: errors were encountered during the build. The image may not be complete.
==> Building image from preset: /etc/mkinitcpio.d/linux-zen.preset: 'default'
  -> -k /boot/vmlinuz-linux-zen -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-zen.img
==> Starting build: 5.17.7-zen1-1-zen
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
==> WARNING: consolefont: no font found in configuration
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
/usr/lib/initcpio/functions: Zeile 404: _addedmodules[]: Falscher Feldindex.
/usr/lib/initcpio/functions: Zeile 404: _addedmodules[]: Falscher Feldindex.
/usr/lib/initcpio/functions: Zeile 439: _addedmodules[]: Falscher Feldindex.
/usr/lib/initcpio/functions: Zeile 439: _addedmodules[]: Falscher Feldindex.
==> ERROR: module not found: `'
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-zen.img
bsdtar: Failed to set default locale
bsdtar: Failed to set default locale
==> WARNING: errors were encountered during the build. The image may not be complete.
==> Building image from preset: /etc/mkinitcpio.d/linux-zen.preset: 'fallback'
  -> -k /boot/vmlinuz-linux-zen -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-zen-fallback.img -S autodetect
==> Starting build: 5.17.7-zen1-1-zen
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: bfa
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: qla2xxx
==> WARNING: Possibly missing firmware for module: qed
==> WARNING: Possibly missing firmware for module: qla1280
==> WARNING: Possibly missing firmware for module: wd719x
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
==> WARNING: consolefont: no font found in configuration
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
/usr/lib/initcpio/functions: Zeile 404: _addedmodules[]: Falscher Feldindex.
/usr/lib/initcpio/functions: Zeile 404: _addedmodules[]: Falscher Feldindex.
/usr/lib/initcpio/functions: Zeile 439: _addedmodules[]: Falscher Feldindex.
/usr/lib/initcpio/functions: Zeile 439: _addedmodules[]: Falscher Feldindex.
==> ERROR: module not found: `'
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-zen-fallback.img
bsdtar: Failed to set default locale
bsdtar: Failed to set default locale
==> WARNING: errors were encountered during the build. The image may not be complete.

can you show the edited config?

cat /etc/mkinitcpio.conf | eos-sendlog

[joekamprad@slimshady64 ~]$ cat /etc/mkinitcpio.conf
# vim:set ft=sh
# MODULES
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES=(piix ide_disk reiserfs)
MODULES="crc32c"
....

it does need “” now i think :wink:

so use like so:

MODULES="crc32c radeon"

Contents of the edited file

# vim:set ft=sh
# MODULES
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES=(piix ide_disk reiserfs)
MODULES="radeon"

# BINARIES
# This setting includes any additional binaries a given user may
# wish into the CPIO image.  This is run last, so it may be used to
# override the actual binaries included by a given hook
# BINARIES are dependency parsed, so you may safely ignore libraries
BINARIES=()

# FILES
# This setting is similar to BINARIES above, however, files are added
# as-is and are not parsed in any way.  This is useful for config files.
FILES=""

# HOOKS
# This is the most important setting in this file.  The HOOKS control the
# modules and scripts added to the image, and what happens at boot time.
# Order is important, and it is recommended that you do not change the
# order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
# help on a given hook.
# 'base' is _required_ unless you know precisely what you are doing.
# 'udev' is _required_ in order to automatically load modules
# 'filesystems' is _required_ unless you specify your fs modules in MODULES
# Examples:
##   This setup specifies all modules in the MODULES setting above.
##   No raid, lvm2, or encrypted root is needed.
#    HOOKS=(base)
#
##   This setup will autodetect all modules for your system and should
##   work as a sane default
#    HOOKS=(base udev autodetect block filesystems)
#
##   This setup assembles a pata mdadm array with an encrypted root FS.
##   Note: See 'mkinitcpio -H mdadm' for more information on raid devices.
#    HOOKS=(base udev block mdadm encrypt filesystems)
#
##   This setup loads an lvm2 volume group on a usb device.
#    HOOKS=(base udev block lvm2 filesystems)
#
##   NOTE: If you have /usr on a separate partition, you MUST include the
#    usr, fsck and shutdown hooks.
HOOKS="base udev autodetect modconf block keyboard keymap consolefont filesystems fsck"

# COMPRESSION
# Use this to compress the initramfs image. By default, zstd compression
# is used. Use 'cat' to create an uncompressed image.
COMPRESSION="zstd"
#COMPRESSION="gzip"
#COMPRESSION="bzip2"
#COMPRESSION="lzma"
#COMPRESSION="xz"
#COMPRESSION="lzop"
#COMPRESSION="lz4"

# COMPRESSION_OPTIONS
# Additional options for the compressor
#COMPRESSION_OPTIONS=()


[penguin@penguin ~]$ cat /etc/mkinitcpio.conf | eos-sendlog
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  2700    0    24  100  2676     32   3659 --:--:-- --:--:-- --:--:--  3693
https://clbin.com/NDLN6

I edited the file again to use “radeon” instead of (radeon) and the output changed a bit

[penguin@penguin ~]$ sudo mkinitcpio -P
[sudo] password for penguin: 
==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'default'
  -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts.img
==> Starting build: 5.15.39-1-lts
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
==> WARNING: consolefont: no font found in configuration
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-lts.img
bsdtar: Failed to set default locale
bsdtar: Failed to set default locale
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'fallback'
  -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts-fallback.img -S autodetect
==> Starting build: 5.15.39-1-lts
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: bfa
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: qla2xxx
==> WARNING: Possibly missing firmware for module: qed
==> WARNING: Possibly missing firmware for module: qla1280
==> WARNING: Possibly missing firmware for module: wd719x
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
==> WARNING: consolefont: no font found in configuration
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-lts-fallback.img
bsdtar: Failed to set default locale
bsdtar: Failed to set default locale
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 5.17.7-arch1-1
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
==> WARNING: consolefont: no font found in configuration
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux.img
bsdtar: Failed to set default locale
bsdtar: Failed to set default locale
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
==> Starting build: 5.17.7-arch1-1
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: bfa
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: qla2xxx
==> WARNING: Possibly missing firmware for module: qed
==> WARNING: Possibly missing firmware for module: qla1280
==> WARNING: Possibly missing firmware for module: wd719x
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
==> WARNING: consolefont: no font found in configuration
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-fallback.img
bsdtar: Failed to set default locale
bsdtar: Failed to set default locale
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux-zen.preset: 'default'
  -> -k /boot/vmlinuz-linux-zen -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-zen.img
==> Starting build: 5.17.7-zen1-1-zen
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
==> WARNING: consolefont: no font found in configuration
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-zen.img
bsdtar: Failed to set default locale
bsdtar: Failed to set default locale
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux-zen.preset: 'fallback'
  -> -k /boot/vmlinuz-linux-zen -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-zen-fallback.img -S autodetect
==> Starting build: 5.17.7-zen1-1-zen
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: bfa
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: qla2xxx
==> WARNING: Possibly missing firmware for module: qed
==> WARNING: Possibly missing firmware for module: qla1280
==> WARNING: Possibly missing firmware for module: wd719x
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
==> WARNING: consolefont: no font found in configuration
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-zen-fallback.img
bsdtar: Failed to set default locale
bsdtar: Failed to set default locale
==> Image generation successful

you removed one module there?

crc32c

Before editing it the variable was empty

MODULES=" "

I would like to note that im using the zen kernel and i have 3 installed

Regular, LTS and zen

should be fine … not sure if it have to be in there in any case