Laptop Discrete Graphics card (AMD) are not used

I am relatively new to endeavouros arch (arch in general) and am trying to use the integrated Radeon card. The system identifies it but it doesn’t show up as a potential provider. It showed up as a provider in debian (ubuntu) based distros. Enabling the ability to switch was possible in mint and worked once. I am happy with my decision to switch to endeavouros because of the performance increase among other benefits and would like to solve this mystery. Any help would be greatly appreciated!

Maybe read this over first as it might help you understand more. EOS is an Arch based distro so you cannot compare it to Mint.

https://www.unixmen.com/using-hybrid-graphic-card-intel-amd-arch-linux/

Edit: https://wiki.archlinux.org/title/PRIME

1 Like

Don’t get me wrong, I’m not comparing the two. Im simply following the logic that if it works on mint that it should also work on arch, speaking on terms of hardware. Thanks for the link, ill dig through it when i have more time.

Currently it is booting and running off of the Intel graphics. It has amdgpu kernel driver. Can you show the output of this?

inxi -Ga

Not all things that work on Mint will automatically just work on Arch. It requires some manual intervention usually and or setup to achieve what you are wanting.

Edit: You have Hybrid graphics Intel & Radeon.

I understood going in that it is not the same and it is a different world, although the kernel base is the same. I am looking forward to learning from this.

Shows the current modules loaded for both graphics cards. Currently rendering with the Intel graphics.

My problem is enabling the radeon card and using it.

Are you are looking for switchable graphics? Or you just want it to always run on Radeon?

Enabling it for switching would be a great start, i dont have an answer for the 2nd question.

Well you could start with trying to have it run strictly on the Radeon first. Use a text editor such as nano. Since the file probably doesn’t exist you will create it when you open it and the add what is needed and when you save it the file will now exist.

sudo nano /etc/X11/xorg.conf.d/20-radeon.conf

add

Section "Device"
    Identifier "Radeon"
    Driver "radeon"
EndSection

To save the file use
ctrl + o and then enter

To exit nano
ctrl + x

Then reboot and see if it’s running on the Radeon card.

Edit: Then you can check the providers and try switching.

Its stuck on this screen. This is about to get interesting lol

Edit: when i pressed the power button to shut it down i saw something about ati commented. Looks like its activated but something isnt quite working right.

Hmm i guess it don’t like this as it’s probably trying to boot on Radeon. :thinking: Can you get into a tty? ctrl alt f2

Unfortunately, ive ran out of time for today. Can we pick up here tomorrow? In a worse case scenario i can use a live usb and remove the file or use cli

Yes that is what i was going to suggest to remove it for now and do some more reading … It has to be set up in the correct way or this is what happens. Is there no way to change the graphics to dedicated in the Bios?

Edit: BTW Welcome to EndeavourOS :grinning:

Tried that already. No way to force the card, its not even an option.

Edit: thanks! Looks like i should take a seat and open the book to page 1 :rofl:

How did it work on Mint? It must have some other kernel parameters in the boot to load radeon?

Not sure exactly, i captured an image of the drive before switching but it would be a big pain in the ass to re image the partitions to find out. To be honest i followed a youtube video and i could see the usage output with a cli tool. It took 3 or 4 commands to get it working.

How do you expect identifying the AMD card is working???
Please, read about PRIME at Archwiki. This is not Debian. This is Arch. We study first, we ask later. :wink:
And, … please… don’t post images for text data. Do I have to explain why? :angry:

Im new to this world so perhaps i do need a crash course on arch protocol. I used the prime=1 command but its not identified. I reached the end of the road on my knowledge, its the only reason i came to the forum :sweat_smile: