Laggy UI on Gnome X11 with External Monitor


  • I’ve got a fresh install of EndeavourOS with Gnome. Everything works great but the animation performance is just so bad that I have to disable it.
  • This only happens when I have my external monitor connected to the laptop and only happens if using X11. Does not happen on Wayland but I can’t use Wayland at this point.
  • I have uninstalled xf86-video-intel. If I leave it installed most applications are unusable with so many UI issues

Do you have any ideas on how to improve this or X11 is just too heavy for my integrated graphics card?

                     ./o.                  user@laptop 
                   ./sssso-                ---------------------- 
                 `:osssssss+-              OS: EndeavourOS Linux x86_64 
               `:+sssssssssso/.            Host: VivoBook_ASUSLaptop K3502ZA_K3502ZA 1.0 
             `-/ossssssssssssso/.          Kernel: 6.2.2-arch1-1 
           `-/+sssssssssssssssso+:`        Uptime: 4 hours, 36 mins 
         `-:/+sssssssssssssssssso+/.       Packages: 940 (pacman) 
       `.://osssssssssssssssssssso++-      Shell: zsh 5.9 
      .://+ssssssssssssssssssssssso++:     Resolution: 2880x1620, 3840x2160 
    .:///ossssssssssssssssssssssssso++:    DE: GNOME 43.3 
  `:////ssssssssssssssssssssssssssso+++.   WM: Mutter 
`-////+ssssssssssssssssssssssssssso++++-   WM Theme: Adwaita 
 `..-+oosssssssssssssssssssssssso+++++/`   Theme: Adwaita-dark [GTK2/3] 
   ./++++++++++++++++++++++++++++++/:.     Icons: Adwaita [GTK2/3] 
  `:::::::::::::::::::::::::------``       Terminal: terminator 
                                           CPU: 12th Gen Intel i7-12700H (20) @ 4.600GHz 
                                           GPU: Intel Alder Lake-P 
                                           Memory: 13244MiB / 15613MiB 

Welcome to the EndeavourOS forum. I hope you enjoy your time here.

I see in your neofetch that you have a 12th Gen Intel i7 CPU. There is a problem with CPUs that are 12th generation. See this Topic.

I have no idea if this is related to your exact issue, but it might be worth a try.


It was stated that this is a fresh install. Did you choose systemd-boot which is default in Cassini or did you use grub? What filesystem did you use, ext4 or btrfs ?

1 Like

Thank you @Pudge!

I gave that a try even though it is not a similar issue, with no success. My boot time is pretty fast and I don’t have a hybrid Nvidia GPU.

I am using systemd-boot but I had the same result with grub and I’m using ext4, never gave btrfs a try.

1 Like

Hello, I know some poor performance of X11 on older devices, very old > 10 years device need to adjust screen resolution and keep it low for good performance. On new hardware likely is driver issue cutting performance… if you want to understand how is the issue, you need to do many tests and try many Linux distro / different DE for get best performance and locate bad software “component” just don’t work on your device.

You get issue like monitor misconfiguration on X11, Yes, I read about on Arch Wiki, not all monitors can automatically get right configuration and bad monitor layouts ends to bad performance/glitches or stranger behavior, much many you can think.

Please read about X11 configuration
and and try to understanding if your screen configuration is really fine, this is what you do first of all.

So, next if you want, you will to make one spare partition on your drive and install on it another Linux distro or another DE, this is my guess cause I get more issue with Linux and new hardware running “generic” Linux drivers is hard to tune on really new devices…

1 Like

I did some more tests.

If I install xf86-video-intel, performance gets a lot better but the system is unusable since most apps have this weird behavior where I can’t click anywhere and content flickers all the time.
However, if I set DRI to 2 on /etc/X11/xorg.conf.d/20-intel.conf, this weird issue is fixed but performance is trash again.

# /etc/X11/xorg.conf.d/20-intel.conf
Section "Device"
  Identifier  "Intel Graphics"
  Driver      "intel"
  Option      "DRI"            "2"

I tried a lot of other options like NoAccel, TearFree, TripleBuffer and SwapbuffersWait with no success.

1 Like

Could you please run the below command and post the link here?

inxi -Fxxc0z | eos-sendlog

1 Like

Yep! Here it is

Well, you are connected display port monitor, then try to connect it with hdmi cable and see if working with all x server defaults (clear manual conf).
Better if you start from live usb system, and you can see among if display port or hdmi connection is fine under XFCE live user…

Tried disconnecting everything and using just the external monitor directly with HDMI, with no success.
Also tried using a Manjaro Live USB just to do some testing with a different distro, same result.

At this point, I’m just assuming X11 is too “heavy” for these integrated graphics. Will keep animations disabled and live with it until Wayland is compatible enough with everything I want. Or move away from Gnome, which I don’t really want since I’m using it for so many years and I’m not as productive with anything else :sweat_smile:

1 Like

Yes I agree with you.
Unluckly, this is i915 driver issue indeed.

If you try another one live distro, like Fedora or OpenSuse, or Ubuntu, maybe some graphical things is more “stable”.
My laptop with Intel UHD Look very good on 'buntu for graphic support…:sweat_smile::sweat_smile::sweat_smile:

1 Like

Did some more tests with other distros:

  • Fedora - has the same issue
  • Ubuntu - So much better! UI animations are probably not as smooth as with Wayland (but really close), so much better than what I get with other distros.
1 Like

Cool thing, thank you for this feedback!

1 Like

Well, I guess I accidentally found a solution :smile:

While testing other distros, specifically Ubuntu, I noticed that they already have support for Fractional Scaling so I did some research on how to add this to Arch since I’m using high-resolution displays. I found this page on arch documentation and after installing mutter-x11-scaling, I noticed that I had no lag anymore. The fractional scaling is not even working yet but the animations are really smooth :face_with_hand_over_mouth:

If some have this issue, try installing mutter-x11-scaling, maybe it will fix it for you as well.


Nice work. If you can mark your answer as the solution to this problem. So anyone else who has a similar problem can find it easily. (I think we can mark our own replies as solutions)


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.