Laggy performance issues with GNU/Linux

It doesn’t matter what distro I use (even GhostBSD), I seem to be getting the same laggy performance on my gaming PC, I have an nVidia GTX 260 graphics card (yes I know it is very old and outdated) and 8 GB of RAM. It doesn’t lag when you are using the DE but when you are using web browsers, it lags horribly. I have installed nVidia graphics card drivers and while it does improve the performance significantly it still laggier than Windows 7 without nVidia drivers.

I have changed downgraded and upgraded kernel version and that doesn’t seem to make a difference.

Only Devaun Linux seems to be the only distro that doesn’t lag (I was running in live mode and nVidia drivers were not installed), but I don’t really like it, I rather use Arch-based systems.is there something I can remove, or install or something, what does Devaun Linux have that makes it run fine but not any other distros? I know that Devaun Linux is systemd free but I have tried other distros that are systemd free as well and they still lag so systemd is definitely not the cause of the issue.

Are there any solutions to this?

Along the same lines, have you checked for upgrades of your bios?

So my PC uses legacy BIOS and not UEFI so to which partition do I add the boot flag to?

And out of curiosity how does this work exactly how does it change these problems on my PC?

My motherboard is this

GeForce GTX260 VGA BIOS
Version 62.00.4C.00.1D
Gigabyte motherboard

CPU is Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.4 GHz

Where do I access these logs, sorry I am a noob over here.

Yes it is turned on.

I am not too sure I think it is on default settings. I can have a look at it give me some time.

I have but the update for the motherboard seems useless as it is not a useful update that actually helps.

What model is the motherboard. I have the same Intel Q6600 quad core Cpu DDR2 800 memory 8GB with an SSD drive and Radeon HD 3870
Also inxi -Fxxc0

1 Like

Is this also valid in live boot mode?

As in like is it ok if I check in live boot session as well?

So it is a s-series motherboard

And here is my power management settings

Model number? of the motherboard will help greatly.

1 Like

Ok so the model number is GA-EP35-DS3P

What does HPET do exactly? I don’t know if it has 64-bit I can try and change it to 64 bit otherwise I will disable it.

I will give all of this a try.

You mentioned earlier that you had a similar issue with an older motherboard, what year was it manufactured in and was it a Gigabyte motherboard?

In which partition do I add the boot flag? Do I add the boot flag to the root partition (as I don’t have a boot partition)? And how did the boot flag fix the issue for you?

The latest Bios version is F6 dated 2009/06/18
If you want to solve your issue the first place to start is to check your Bios version first. Look at what the updates were for. It’s a users choice whether they update or not. Myself i have always updated. The next thing to do is set the Bios settings to default and start there. Read the manual and understand what the Bios settings are for and what they do. Most of the time there are only a few settings that you would be changing if at all. Minor things usually unless you are into overclocking and then it’s another story. I’m not… but i do tweak the settings that are tweak-able without causing instability. You should be using the 340 series Nvidia video drivers. This is where you can start. Check that your system isn’t overheating. Check your memory. These are places to start It’s easy to do a memory test. If you are playing with the power management settings other than the defaults this may cause your issue.

3 Likes

Thanks I will have a look into it but I first want to try to add a boot flag as suggested by @d5h2k5x0Cj65Fdy. Where do I add the boot flag, is it the root partition, I don’t have a boot partition so do I add it to the root partition?

Not sure what a boot flag has to do with power management? The purpose of a boot flag is to assign the active partition (bootable) You can do this when you manually create partitions.

1 Like

:scream::see_no_evil: What do you mean?

Did he remove his account? I can’t access his page?

The OP removed his account.

That’s a bit strange

1 Like

Right. This is a basis.

unix_lover, the output of dmidecode is very long, you could filter:

sudo dmidecode -s baseboard-manufacturer; sudo dmidecode -s baseboard-product-name; sudo dmidecode -s bios-version

Is the BIOS version older then F6, you should flash. The BIOS files of the GA-EP35-DS3P (rev. 2.1) are Windows self-extracting executables. On Linux you have to extract manually. The file EP35DS3P.F6 is the BIOS binary.

You use Q-Flash, embedded in the BIOS. Read the instructions
(motherboard_manual_ga-ep35-ds3p_e.pdf, page 68) and act right on it!

Nvidia (nVidia is the former company name). :wink:

As ricklinux said, nvidia-340 is the right version.

Which browsers have you tried? Under Linux they usually have no real hardware acceleration, especially if you don’t use nvidia, but nouveau. Then it can lag strongly.

Really? Don’t you mean a boot option? Whichever one.