Kwin and nvidia issues

Hi guys I recently installed endevour os endeavouros-2021.04.17-x86_64.iso using the online installer and with the KDE Desktop option. Upon install everything seems fine when using the breeze-dark. However I noticed a notification of kwin having a graphics reset everytime I wake up the system.

This issue is more prevelant if I use a theme that uses kwin’s blur effect in which the title bar and close, minimize, and maximize buttons will either become warped (very enlarged or significantly shrunk). Closing and repoening the affeced app windows seems to fix the issue but putting my computer to sleep and waking it brings back the issues. Another alternative I tried is running kwin_x11 --replace via kde shortcut (idk if there is a way to run this when waking up from sleep) which does resolve the issue.

As a more perminant resolution I did attempt to run nvidia-installer-check and got the following reply.

Your graphics card (id: 13c2) is supported by the nvidia-dkms driver.
To install a driver for this card, you can use nvidia-installer-dkms.

I then ran nvidia-installer-dkms and rebooted after the script finished. On the bright side updating the drivers did help graphics resets and title bar warping. Unfortunately I noticed the blur effect was disabled after the update. I when renabling it I noticed kwin’s cpu usage starting to spike. On ideal it would consume 10-30% of my cpus and if I move any windows it can use 50-70% of cpu. Windows move ment became choppy and if playing any videos say from youtube in fire fox or a mp4 in vlc I noticed a high degree of stutter. I tried forced compesisiton piple in nvidia settings (no dice), I tried the anti tear guide in the arch wiki (no dice). Only rolling back the update with time shift seemed to fix the cpu but brought back the graphics resets.

At this point I’m kind of at a loss, before Endavour OS I used to use Manjaro and had similar issues with kwin (the title bar and graphics resets). Not sure if this is even an endevour os bug or if I should post the bug in bugzilla for kwin. Please advice and sorry for the long post :slightly_frowning_face:

KDE versions:

KDE Plasma Version: 5.21.5

KDE Frameworks Version: 5.82.0

Qt Version: 5.15.2

Kernel Version: 5.12.8-arch1-1

OS Type 64-bit

Graphics Platform: X11

Hardware:

Intel Core i7-4790

GPU GTX 970 (proprietary drivers)

Hello @rihcus
Could you use post the output for the following command.

inxi -Ga

Graphics:  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics 
           vendor: Gigabyte driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:0412 
           class-ID: 0300 
           Device-2: NVIDIA GM204 [GeForce GTX 970] vendor: Micro-Star MSI driver: nvidia v: 465.31 
           alternate: nouveau,nvidia_drm bus-ID: 02:00.0 chip-ID: 10de:13c2 class-ID: 0300 
           Display: x11 server: X.org 1.20.11 compositor: kwin_x11 driver: loaded: intel,nvidia 
           unloaded: fbdev,modesetting,vesa alternate: nouveau,nv resolution: <missing: xdpyinfo> 
           Message: Unable to show advanced data. Required tool glxinfo missing.

Should I instal glxinfo?

You could install mesa-demos, xorg-xdpyinfo. This would just give you more info from the command. I usually always install these and also dmidecode. Your choice and when you run the command you will see more info.

It’s hybrid graphics running on Intel currently. It could be the Intel driver causing the issue maybe?
Maybe remove xf86-video-intel

The anti tear you are referring to is related to nvidia. It’s not running on nvidia. You would have to install optimus-manager in order to switch to nvidia. So most likely it’s an Intel issue.

Interesting running on a desktop and all displays are connected to my GPU (I don’t use the integrated graphics). I guess I could try nuking the intell graphics (I have time shift as a backup)

That’s great because it could cause an issue. Maybe? You have other external monitors?

Edit: It would be a good idea to try this before installing optimus-mamnger. I’m not sure what issues you may run into then.

I have two moniters one is outputtting to HDMI one outputing via DVI

Updated output with mesa-demos, xorg-xdpyinfo

Graphics:  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics 
           vendor: Gigabyte driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:0412 
           class-ID: 0300 
           Device-2: NVIDIA GM204 [GeForce GTX 970] vendor: Micro-Star MSI driver: nvidia v: 465.31 
           alternate: nouveau,nvidia_drm bus-ID: 02:00.0 chip-ID: 10de:13c2 class-ID: 0300 
           Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: intel,nvidia 
           unloaded: fbdev,modesetting,vesa alternate: nouveau,nv display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 3520x1080 s-dpi: 92 s-size: 972x301mm (38.3x11.9") 
           s-diag: 1018mm (40.1") 
           Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 92 size: 530x290mm (20.9x11.4") 
           diag: 604mm (23.8") 
           Monitor-2: DVI-D-0 res: 1600x900 hz: 60 dpi: 92 size: 443x249mm (17.4x9.8") 
           diag: 508mm (20") 
           OpenGL: renderer: NVIDIA GeForce GTX 970/PCIe/SSE2 v: 4.6.0 NVIDIA 465.31 
           direct render: Yes 

That gives you way more info as you see.
Edit:
So it may be running on the nvidia. Some hybrid graphics automatically output the dedicated graphics when hooked to another monitor via HDMI. I’m not an expert on this. I just try to help where i can. I do have Nvidia desktop card which is a GTX 1060.

Edit: I’m just looking at the display x11 server and it shows Intel as the driver. So i’m assuming you would need optimus-manager to switch.

window bar issue still there I tried uninstalling the intell graphics drivers

yay -R xf86-video-intel

output for inxi -Ga

Graphics:  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics 
           vendor: Gigabyte driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:0412 
           class-ID: 0300 
           Device-2: NVIDIA GM204 [GeForce GTX 970] vendor: Micro-Star MSI driver: nvidia v: 465.31 
           alternate: nouveau,nvidia_drm bus-ID: 02:00.0 chip-ID: 10de:13c2 class-ID: 0300 
           Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: 
           loaded: modesetting,nvidia unloaded: fbdev,vesa alternate: intel,nouveau,nv 
           display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 3520x1080 s-dpi: 92 s-size: 972x301mm (38.3x11.9") 
           s-diag: 1018mm (40.1") 
           Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 92 size: 530x290mm (20.9x11.4") 
           diag: 604mm (23.8") 
           Monitor-2: DVI-D-0 res: 1600x900 hz: 60 dpi: 92 size: 443x249mm (17.4x9.8") 
           diag: 508mm (20") 
           OpenGL: renderer: NVIDIA GeForce GTX 970/PCIe/SSE2 v: 4.6.0 NVIDIA 465.31 
           direct render: Yes 

I think you are fortunate to have the two monitors working. Many users have issues with that.

Out of curiosity do you use a high blur theme like ant-dark? I’m gonna try running the nvidia driver update and see if high cpu usage will reoccur.

Excellent. It’s now running modesetting kernel driver. So you can see if that makes any difference for your current issue.

how do you modesett the kernel driver?

No i don’t. I’m not sure what setting that is?


What do you mean? You uninstalled the intel driver so it is running now on modesetting kernel driver instead.

Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: 
           loaded: **modesetting**,nvidia unloaded: fbdev,vesa alternate: intel,nouveau,nv 

Where is blur?

Sry wasn’t sure of the term modesetting (bit new to arch).

Blur is a kde desktop effect:

Edit: Earlier this is what I meant by title bar bug:

Normally:

Oh okay. I see. Is it doing it now since removing the Intel driver?

Edit: This is my blur setting and output of konsole.


Edit: This is on my Ryzen with Amd Graphics though.

Edit2: My blur settings.

Screenshot_20210607_173753

Unfortunatly this happend before and after uninstalling the intel driver.

Edit: In the past running:

nvidia-installer-check

Your graphics card (id: 13c2) is supported by the nvidia-dkms driver.
To install a driver for this card, you can use nvidia-installer-dkms.

and

sudo nvidia-installer-dkms

fixed that issue but as a consiquence kwin started to hog cpu (when the intel gpu drivers where installed, I could try the same process again and see if the high cpu usage issue goes away`

Edit:
To clarify no high cpu usage now but have the title bar issue