Konsole Always Opens Maximized

Are other KDE Plasma users experiencing the same issue of Konsole opening full screen only. I have tried everything to make it open in a Window but nothing seems to work. Just wondered if this is something new?

Just the obvious but did you try the F11 key?

1 Like

Haven’t experienced this.

This doesn’t really help, what exactly have you tried and what settings have you checked?

Have you unchecked remember window size in Konsole settings?

Do you have a konsole window rule in Settings -> Window Mgmt?

Yes. Here as well. I just had left it as is for now. Now that yo bring it up…

I’m sorry i meant maximized. It only opens maximized and i guess full screen is different.

1 Like

Assuming you’re using the inherent Plasma panel (taskbar), right click on the Konsole tab, then More Actions, and see if Maximize is checked?

So every app that uses Konsole is opening maximized such as Terminal, Htop etc.

Even when i uncheck it still opens maximized.

1 Like

Did you try to create a window rule for it? Like remembering position and size?

1 Like

No … I was just wondering if this was something new that changed in kde?

What if you click on the top left icon inside the window -> more actions -> Special Window/Appl settings?

Are there any weird rules inside it?

1 Like

Are you resizing it before exiting or just using it maximized.

Either it is remembering its size or a window rule is maximizing it.

1 Like

Is this default settings?

Maybe just add the property size and position to it with the setting “remember”. Check if that works. That would at least be a workaround.

Just to be thorough in checking:

Konsole > Settings > Configure Konsole > General > Remember Window Size (uncheck)

I have done this already and doesn’t work.

1 Like

Hey I have to try to figure what my roommate did to always have Dolphin open maximized. If I figure it out and you still haven’t gotten your Konsole issue solved I’ll post that solution here. Maybe it can help you.

1 Like

You’ve resized the window, closed konsole, and it opens maximized again?

Maybe try checking remember window size, open konsole, then resize and close. See if it remembers the non maximized size. Then uncheck remember size.

I use a window rule for exact size and placement, but when the rule is not used konsole window is placed according to default new window placement in Settings - Window Mgmt - Window Behavior - Advanced - Window Placement … which is centered. Not maximized.

1 Like

Yes that is what i have. For some reason it just started opening maximized and won’t stop.

Try creating a window rule with a specific window size and position.

Alt F3 - More Actions - Configure special window settings - Add Postion and Size and set to Apply Initially.

1 Like