Keyboard and touchpad not working

Hey guys … I have this chuwi laptop that i had manjaro on , working fine. Then something broke . So i tried to install arch first. Everything went fine until i rebooted … and the keyboard and the touchpad were not working.
Then i downloaded Manjaro and the mouse and keyboard were not working (in the live enviroment)
Now i downloaded endeavour and it’s the same. No mouse and keyboard.

i did run evtest on the arch install and the keyboard and touchpad were registering events. So those are not dead.
Do you guys have any idea what could be the cause of this.
Thank you.

Does this help?

1 Like

Hmm … i missed that forum :smiley:

And it does WORK.

Now to see if i can install endeavour :smiley: with this quirk .

Thanks

Brill, let us know. Never heard of Chuwi, any good? Which one have you got?

I have the aerobook !
It’s nice … fanless , so it’s quiet . It worked great for me … never really tested the battery life but i would say it’s over 8 hrs.

Now back to my problem. I implemented the fix and everything seemed to work fine but now i can’t log in into my install :frowning: the keyboard and mouse do work though .

OK:

  • Which desktop environment?

  • Which language are you using?

Can you get into a VT (ctrl+alt+f2) to test the keyboard and see what it is typing?

It allowed me to log in as root so lets see if updates fix anything.
It’s xfce and US language

Well it is not my first thought.

Is the password complicated? Try resetting the user password from the root login.

Also try this:

Enable autologin.

But the password worked for root (same pass) and for the user it doesn’t say the passwd is wrong.
So i did reset the password with the passwd command but still wont let me log in :expressionless:

If you open the VT can you login as user there?

Yep it logs me in.

So found this:

What are .Xauthority’s permissions?

.rw-------    59 stevef 2020-10-03 20:26 .Xauthority

Are mine.

Am still looking…

Lets test if it is lightdm which is the problem…

#Install sddm
sudo pacman -S sddm
#set sddm as DM
sudo systemctl disable lightdm
sudo systemctl enable sddm -f
reboot

Mine looks like it’s owned by root .
And ssdm just hangs after i input everything and login.
And it also allows me to log in as root.

Definitely should be user.

Get to a VT reset to lightdm and:

sudo rm ~/.Xauthority
reboot

Almost guaranteed that is your problem.

God, I cannot spell today :smiley:

And just like that … it worked :smiley:

Thanks a billion tons :smiley:

really appreciate it.
I wonder why was .Xauthority owned by root in the first place.

Don’t know, but glad it is working :smiley:

Also just check your home folder, in case anything else is wrong:

ls -la | grep -i root
1 Like

I tried the fix from the Chuwi forum link shared but did not work for me… Although my touchpad is fine, the keyboard isn’t working. Even I ran this spacebar test but it did not detect any key presses.

I am a little too confused with this stuff… as you have already got it working on your side, do you mind sharing what exactly you did? TIA