Kernel / sound issue: HP ENVY x360

Hey everyone,

the installation of EndeavourOS worked fine and everything runs smoothly, except the sound, which does not work on the following notebook: HP ENVY x360 15-ey0157ng.

This was already a problem before migrating to EndeavourOS (with kernel 6.4.4 at that time), but it could be fixed with a patch. Unfortunately, it looks like this is still an issue with kernel 6.7.4 and 6.8:

Do you have any ideas on how to fix this, without having to wait for kernel 6.9?

Best regards

The last reply in that topic you linked to said,.

Thank you for those links. It seems that fixing the issue needed more patches that landed after RC 1 for the 6.8 kernel was issued. Those additional patches are lined up in the for-next branch, which implies that these will only be pulled in for the 6.9 kernel. So unfortunately, AFAIU you guys either have to compile your own kernels with the aforementioned patches, or wait one more kernel cycle for having it work out of the box (hopefully).

It looks like the linux-mainlin PKGBUILD from the AUR is already at 6.8rc4-1. So you could probably try just building that to see if it that kernel makes your sound work, since it’s at rc4 which came after rc1.

yay -S linux-mainline



Thank you. Installing linux-mainline via pamac should be fine as well, right? However, the installation has been running for 6-7 hours and is still not complete.

The penultimate reply in the linked said

EDIT 2: it’s actually fixed in linux-next-20240129 from today. Finally! Make sure to chose “Family 17h/19h HD Audio Controller” and “Play Hifi quality Music” under configuration of Pulseaudio.

What exactly is the difference between linux-next, which is now available in the version 20240206, and linux-mainline?

Thank you. That is really helpful. I will take a closer look at it as soon as the installation of linux-mainline is completed.

I have never used pamac, I’ve only used yay and currently use a different AUR helper but I would think so.

The difference between linux-mainline and linux-next are the sources.
linux-next PKGBUILD has this as source:

linux-mainline PKGBUILD has this as source:

I did just look it up on this Archwiki page.

Mainline — Kernels where all new features are introduced, released every 2-3 months.
Next — Bleeding edge kernels with features pending to be merged into next mainline release.

So I would think either mainline or next will probably get you what you need for your sound issue. If not what @ricklinux linked to seems like a good option as well.

Alright. Many hanks again.

By the way, the installation with pamac did not work and was cancelled after more than 7 hours because there was no more memory available. Lession learned.

According to the information on the Archwiki page, mainline should be the safer pick. If it doesn’t work with that, next would still be an alternative that can be tried.

The disadvantage of the patch that ricklinux has linked is that the microphone will not work with it, so let’s hope that one of the first two options works. Although I would miss the mic less than the speakers.

How much memory is in your system? I can try building the PKGBUILD for the mainline to see how long it will take me.

/ is almost 50 GB and /home is the rest, about 450 GB, probably 430 or so. The question is where all the files from the pamac installation are stored, because root is completely full (only 80 MB free).

I can make a new install of the OS or just change the partitioning, but a new, clean install probably won’t hurt.

You said before that your system had now more memory available so I was asking how much memory your system has. Now you are talking about disk space, I’m confused now. Which was it?

Sorry, that was a mistake and I meant disk space of course. I translated the error message to English and mixed up the two terms. It’s probably easier if I install the OS in English next time.

1 Like

No problem, English isn’t my first language either. You can configure your system’s locale even after installation.

I’m just trying to compile linux-mainline to see how long it will take me, once it’s done it should give you some indication of how long it might take for you on your hardware.

1 Like

That’s good to know, thanks. I’ll reinstall the OS in the meanwhile so that it’s a clean install before compiling linux-mainline.

From your other reply I’m getting the impression you are probably using ext4 or xfs as your filesystem for your partitions. Something to think about might be at using btrfs as your next filesystem, it gives you the option to make snapshots of your subvolumes, as well as not having to think about how big you want each partition to be because it’s all one big btrfs filesystem and the sub-volumes share the space available of that filesystem. Just thought I would mention it but do whatever you are comfortable with and want to use.

Thanks for the hint. I deliberately still use ext4 because I’m not sure whether BTRFS is mature enough to always be reliable: buzzword data corruption under BTRFS, which could have serious consequences, especially in the event of power failures. There are also said to be situations where inexplicable problems occur after a software update that are very difficult to fix, and I’m not tech-savvy enough for that. I also don’t have the luxury of having several HDs connected together in a raid configuration (in which case I would already be using BTRFS). However, the fact that the checksums are often incorrect in the event of a power failure, despite data integrity, or vice versa, makes me sceptical about BTRFS. But that, like so many other things, is of course a question of philosophy, and it’s only what I’ve heard so far.

After the restart, the normal grub menu does not appear, but an input field (see photo). It is also no longer possible to start a live USB stick. Do you have any idea why this might be or how to get to the normal start menu? Exit works as a command to get to the normal selection, but the USB stick still won’t start.

I’ve been using btrfs for several years now, even hard shutting off my system without it properly shutting down. I’ve never experience issues, do whatever you feel good with for your filesystem for your new installation :slight_smile:

Did you reboot your system after your root filesystem became full after trying to build that kernel from that PKBBUILD?

Soulds good. I’ll give it a try then :slight_smile:

It already looks like this since EndeavourOS is installed, but the problem is that booting from the live USB stick no longer works.

Do you mean when booting from the usb you get that grub prompt and that when you don’t boot from your live usb your system boots into your current installation?