Keeps booting into bios, grub-install did not help

Hi, after updating somwhere this week i am no longer able to boot into endeavour. after looking for a solution i saw, that my grub might need to be repaired or reinstalled.

after mounting my endeavour and EFI partitions and chrooting into it, i ran the grub-installer command, and rebooted. this seems to not have helped.

if my problem is not grub, how do i figure out what my issue is and solve it?

any help is appreciated

1 Like

When you did the arch-chroot and re-installed grub did you run the grub update command after that.

sudo grub-mkconfig -o /boot/grub/grub.cfg

i did not, i will try this

1 Like

Make sure you go through the steps again and arch-chroot after mounting the / and the efi partition.

so i went trough all the steps again
mounting to /mnt and /mnt/efi
arch-chroot ing into it and using the grub-install and then running your suggested command wicht resulted in no errors.
and then rebooting i still only got the boot into eufi firmware interface option, i tried booting into the partition but is just trew me back there with that, only option.

i did see i can enter a terminal in the menu should i be doing something in there?

What does it show

lsblk -l

Did you go into the bios setup and check the boot order and first boot device? It may have changed from the original.

It isn’t showing me which partitions are which. Sorry.

yes i did, i attempted to boot from the disk i would usually boot from

hope this one is better

lsblk -f result

i mounted endeavouros in /mnt and the other partition of that drive in /mnt/efi

So these ones?

├─nvme0n1p1 vfat     FAT32                           FA88-7C92                                           
└─nvme0n1p2 ext4     1.0              endeavouros    4e0cff52-5f5e-4ab7-8be7-0e3f44554480                

yes, i then arch-chrooted into /mnt and ran the grub-install

mounthing is also in fault for grub

sorry, i don’t understand what you mean

It should be

sudo mount /dev/nvme0n1p2 /mnt
sudo mount /dev/nvme0n1p1 /mnt/boot/efi


sudo arch-chroot /mnt

if you use systemd-boot you must mount first /mnt and /mnt/efi
grub is /mnt/grub/efi …

i dont know what you current using ?

OP said they are using grub. :thinking:

running the second line give me an error /mnt/boot/efi mount point does not exist

should it not be /mnt/efi ?

sorry… saw only some path confuses me :stuck_out_tongue: