Kde weirdly glitching out on latte dock top panel

Hello, can someone help me my kde plasma desktop has been weirly gliching out and failing to display fonts correcly on both wayland and xorg


Im using a lenovo x240 the linux zen kernel and with the default intel intergrated graphics

My first suggestion would be to switch for LTS Kernel and see how it goes, zen is not particularly stable one :slight_smile:

I tried using the lts one yet it still glitches but downgrading some plasma packages works fine

Have you been able to identify those packages?

Have you tried removing xf86-video-intel

Edit: sudo pacman -R xf86-video-intel

reboot

I’d advise sudo pacman -Rsn rather than pull the whole thing. Think about dependencies.

1 Like

[quote=“ricklinux, post:5, topic:15816”]
sudo pacman -R xf86-video-intel
[/quote]I just restored a previous snapshot taken before the upgrade

I did that but now it glitches on the settings when I’m on the sddm settings

You could try the following kernel parameter in the default grub command line.

sudo nano /etc/default/grub

add the following after “quiet”

i915.enable_psr=0

example: GRUB_CMDLINE_LINUX_DEFAULT=“quiet i915.enable_psr=0 splash
After adding the parameter to this line then

ctrl + o then enter to save
ctrl + x to exit

Then run
sudo grub-mkconfig -o /boot/grub/grub.cfg

reboot

1 Like

thanks it worked like a charm :partying_face:

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.