KDE Wallet

It seems that this kwallet keeps coming up if i try to connect to wifi, or try to run chrome and now shutting down virt-manager. I don’t know why this component is installed. There is nothing in system settings for kwallet. I don’t know how to deal with it or set it up or get gpg key for it. How can i uninstall it without ripping everything else it’s tied to apart.

[ricklinux@eos-kde ~]$ pacman -Qi kwallet
Name            : kwallet
Version         : 5.85.0-1
Description     : Secure and unified container for user passwords
Architecture    : x86_64
URL             : https://community.kde.org/Frameworks
Licenses        : LGPL
Groups          : kf5
Provides        : None
Depends On      : knotifications  kiconthemes  kservice  gpgme
Optional Deps   : kwalletmanager: Configuration GUI
Required By     : kio  libkgapi  signon-kwallet-extension
Optional For    : chromium  qtkeychain-qt5  vlc
Conflicts With  : None
Replaces        : None
Installed Size  : 2.15 MiB
Packager        : Antonio Rojas <arojas@archlinux.org>
Build Date      : Sat 07 Aug 2021 05:14:59 PM
Install Date    : Wed 01 Sep 2021 10:09:41 AM
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature

[ricklinux@eos-kde ~]$ 

Edit: Or how do i use it?

It is required by kio so you can’t easily remove it.

If you set your kwallet password the same as your account password it will unlock automatically and be totally transparent in plasma.

Install kwallet-manager and use that to change the password.

1 Like

Which account password do i use at first? My user password?

Edit: It doesn’t show any kwallet-manager? Is it another name?

You should change it to your user password. If it is asking you for a password, it is whatever password you set in the past.

You have to install it? The package is kwalletmanager

I don’t understand how this works. Where am i supposed to put a password?

Edit: I managed to stop it from coming up on the Wifi by putting an unecrytped password in my WiFi settings. It’s not coming up for chrome but now when i close virt-manger the box comes up.

image

Not the same and i have no wallet set up. This is what’s frustrating me. It just opens another box wanting to encrypt it. This box is new from kwalletmanager. It’s not the box that comes up.

Edit: This is the stupid box that comes up!

That means you haven’t created a wallet yet. It is a wizard. Go through the wizard and let it create a wallet

I can’t get it to come up now? It just randomly appears.

Edit: I try and i get this! I don’t know how to set it up.

I just turned the wallet system off in the kwalletmanager. Maybe that will work?

Edit: I don’t understand how to set it up and get a the key from where.

Edit2: Even turned off it still comes up.

This is what’s going to make me leave KDE! :angry:

You’re making it more complicated than it needs to be. Do not turn off KWallet, just create a wallet, make sure it has the same password as your user and forget about it. :roll_eyes:

Use a blowfish encrypted file, not GPG. That’s simpler.

1 Like

I don’t understand why this is coming up. It never has before in more than 2 years.

Edit: I made the wallet now what? It still comes up? Do i have to add every app that opens. I tried closing virt-manager.

It was there, but you had a properly setup wallet (as is the case on a clean install), so you haven’t noticed it.

2 Likes

This is another clean install. I’ve installed it again so many times trying to figure out how to get rid of this problem. I never ever had this problem with kwallet.

Edit: Seems to have gone away now. So i had to add another password?

So i created a wallet which requires a password. Then when i close virtmanger (kded5) was wanting a password so i added the same one.

To get rid of this FOR ME! unnecessary stuff without problems was the ulterior motive to install with the new ISO. It turns out that this idea was brilliant :innocent:

Edit: Maybe this is because I did not use kio during the installation.

If you don’t want to use KDE wallet, there’s a pretty simple solution:

Make sure kwalletmanager is installed; if it isn’t, install it.

Then you can go to System Settings > Personalization > KDE Wallet and de-select “Enable the KDE wallet subsystem.”

Done. You will never be bothered by KDE Wallet.

1 Like

I just want to point out the disabling the wallet will mean that many applications will start storing passwords and other secrets in plain text. Generally speaking, it isn’t a great idea.

2 Likes

True; not an issue for me, but I should have elaborated that. Thanks.

1 Like

I tried that but the boxes were still coming up.