KDE plasma has weird behavior after update and reboot

Hi everyone,

I had this problem in a previous install and reinstalled my OS after I didn’t find a solution. But after 1 day of usage of the OS I reinstalled. I got the error back.

I use EndeavourOS with kde preinstalled from the installer and no other desktop environment. I like it because I can edit its design as I want. So I installed multiple elements and changed its theme to Sweet Mars in the System settings.
Today. I updated my computer with yay and nothing happened in the first part. But a weirdness happenned has every icon from the task bar disappeared. I restarted my computer and they never went back.
Here is an image:
When I right click on the desktop it shows the tooltip like this:
I can’t switch to another desktop env (written in french sorry):
I have also no appbars when I don’t select default installed appbar themes:

Does anyone have an idea? I think this may come from plasmashell or kwin11. Because when I restart plasmashell by killing every task called plasmashell and restarting it in a CLI, everything comes back but I have still some weird display errors.

Try deleting the plasma cache.

Can I do this with that command : rm -rf .cache/plasmashell* ? Because it changed nothing.

You can start with rm ~/.cache/*.kcache

It changed nothing :cry:

I have all my theme that is broken. I tried changing it but nothing works yet.

Did you logout and log back in?

Try switching back to breeze temporarily.

I tried both solutions. It didn’t do the trick

I tried to remove all of this :

rm -rf .kde
rm -rf .cache/plasmashell*
rm -rf .cache/org.kde.dirmodel-qml.kcache
rm -rf .cache/kioexec/ .cache/krunner/ .cache/ksycoca5*
rm -rf .cache/krunnerbookmarkrunnerfirefoxdbfile.sqlite
rm -rf .config/plasma*
rm -rf .config/kde*

But I still have the same problem. But the theme is now breeze light.
It may come from the nvidia GPU I have. It’s a GTX 1070. But it it’s marked has supported by the environment.

I am also having the same issue on a fresh install. After installing, on reboot, logged in to see missing icon’s and menu items like OP posted in his screenshots. Haven’t been able to resolve the issue yet, but just wanted to make it aware that this is happening on fresh installs as well (at least for me).

1 Like

I have a workaround by now. It’s to run in cli those 2 commands:

killall plasmashell
plasmashell &

But It still shows display bugs and I can’t set themes has they break most of the design.

1 Like

That appears to be working for me as well. Thanks for the temp work around!

At work, but try resetting KDE back to defaults - you nearly got it right, but (something like as I said at work!!!):

mkdir ~/.config/plasma-bak
mv ~/.config/*rc plasma-bak/
mv ~/.config/kdeglobals plasma-bak/

Reboot - should get you back to “vanilla” Plasma. Problems like this are quite often caused by dodgy extensions, add back one at a time, reboot to see the effect.

1 Like

I tried this solution but I still have the same problem. What is your configuration @LucasZ? maybe it’s due to our hardware or some package we installed.
I installed:

  • Visual studio code
  • Gimp
  • Terminator
  • ZSH / oh my zsh
  • Sweet
  • devilspie (for blured backgrounds)
  • discord
  • Google chat
  • thunderbird
  • postman

kwin might not like that… I would try Kvantum.

My config is a Lenovo Legion 5, RTX3070 dGPU / AMD iGPU.

Completely fresh install, with nothing else installed when it happened (except for what the EndeavourOS installer installs by default for KDE).

I am running Endeavour on an 2021 Asus Zephyrus G14 with a Ryzen 5900HS and an NVIDIA RTX 3060.

I uninstalled devilspie and rebooted. It changed nothing ><

1 Like

This is weird, I am having no problems, last updated 9pm UK time last night. Any extensions?

I updated with yay 30 minutes ago

Will report back when I am at home and can update. I am using Latte and not normal panels though.

Also not seeing any reports on reddit -