KDE Connect

I’m having difficulty getting KDEConnect to work with my cellphone. I notice in Discover that there are two instances of KDEConnect installed. When I try to uninstall one (the 5 ratings one) I get error “dependency resolution failed”. Anyone know what is going on?

Discover is not a great tool for managing repo packages in EOS or any other Arch-based distro because packagekit doesn’t support manual intervention.

What does the output of the command pacman -Qs connect show?

2 Likes

Firewall can be a problem for Kdeconnect

1 Like

Firewall is activated. What would be the correct settings/ports to allow Kdeconnect?

$ pacman -Qs connect
local/kdeconnect 20.08.0-1 (kde-applications kde-network)
Adds communication between KDE and your smartphone
local/libieee1284 0.2.11-9
A library to query devices connected in parallel port
local/libnetfilter_conntrack 1.0.8-1
Library providing an API to the in-kernel connection tracking state table
local/networkmanager 1.26.0-1 (gnome)
Network connection manager and user applications
local/openconnect 1:8.10-1
Open client for Cisco AnyConnect VPN
local/openssh 8.3p1-3
Premier connectivity tool for remote login with the SSH protocol
local/perl-net-http 6.19-4
Low-level HTTP connection (client)
local/plasma-nm 5.19.4-1 (plasma)
Plasma applet written in QML for managing network connections
local/python-urllib3 1.25.10-1
HTTP library with thread-safe connection pooling and file post support
local/wvdial 1.61-8
A dialer program to connect to the Internet

I wonder what discover is showing as two copies of kde connect. Can we see screenshot of that?

Port 1714-1764 should be open both tcp and udp . If it’s Firewalld simply allow kdeconnect in services , both runtime and permanent

2 Likes

This is what I have opened in GUFW:
2020-08-18_12-10

Here goes firewalld

These four are also shown in pamac , no problem . There is only one package i.e. kdeconnect

If opening ports in firewall does not work make sure both mobile phone and computer are connected to same network (i.e. wifi on on pc ) and try to add device by ip address

Thank you. Still no success. I also have a vpn connection, although the problem seems to persist even with vpn disconnected.
I have tried uninstall/re-install android kdeconnect to my phone, still no result. Strange things is, it was working atwo weeks ago.

That’s exactly what happened to me few months before and ufw did not work for me .
I had to install firewalld and add my pc manually .

Try disabling firewall and connect by turning on Hotspot in mobile phone and connecting pc to it , this will help to understand any router related issues ; if any .

KDE connect was included in my Plasma install. Make sure your phone is open at the KDE connect app, it has to be on top.
Make sure you accept the device when prompted in the phone app.

Perhaps it’s a network issue. What kind of router are you using?

Hi everyone. My apologies for disappearing. We had an internet outage.
Well, I have now un-installed firewalld altogether, but still no success. As I said, it did work previously with the same router. When I try to pair mobile and laptop they just don’t see each other.
I have to say I appreciate everyone who has shown interest in this issue so far. Thank you.

I’m not KDE Connect user, but…

  • What’s your phone model?

As I said, it did work previously with the same router

Well…Then it’s even weirder

Huawei P20

1 Like

https://userbase.kde.org/KDEConnect#Troubleshooting

Seems that we’ve excluded common problems like firewall…

Try this:

KDE Connect crashes or restarts when trying to pair with another device

Sometimes, a corrupt config file may cause KDE Connect to crash when trying to pair with a device. In that case, deleting the config ~/.config/kdeconnect might help.

If it fails - then i’m afraid filing a bug could probably be fastest way to get some help:
https://bugs.kde.org/enter_bug.cgi?product=kdeconnect

I have been in the same boat a while back. Couldn’t connect and spend hours to look for troubleshooting help.
Here’s what I came up with:

  1. Obvious but important, both devices need to be on the same network

  2. Is the kdeconnect process running:
    ps -ef | grep kdeconnect

Example output:
user 3399 1 0 08:26 ? 00:00:02 /usr/lib/x86_64-linux-gnu/libexec/kdeconnectd

  1. Is the process listening?
    sudo netstat -tunelp | grep -i kdeconnect

Example output
tcp6 0 0 :::1716 :::* LISTEN 1000 36999 3399/kdeconnectd
udp6 39936 0 :::1716 :::* 1000 36998 3399/kdeconnectd

  1. Maybe your firewall gets in the way?
    Is the firewall running?
    sudo ufw status
    If yes, turn it off for the test
    sudo ufw disable

  2. Are the ports open/blocked?
    netcat -z -v 1714-1764 # Try phone and laptop, use port which netstat shows

Example output:
Connection to <your -phones-ip> 1716 port [tcp/*] succeeded!

  • lots of Connection refused, but you need 1 “succeeded”
  1. Check the kdeconnect home dir
    ls -al /home//.config/kdeconnect/

  2. Check CLI interface
    kdeconnect-cli