Kde Connect won't find phone

It just refuses to find my phone. In KDE it works, I’m trying it on Cinnamon now as @Elloquin said it would work. What else can I try?

Upon further investigation, bluetooth doesn’t work on this laptop, so obviously that’s the reason Kde connect doesn’t work. Can someone help?

1 Like

Although I don’t use KDEConnect right now, I never used it with bluetooth. It always worked fine over WI-FI. Is your remote device connected on the same wireless network as your kde machine?

Also, are you sure you have all the required dependencies installed?

(Admittedly, this is low hanging fruit, but maybe it’ll give you a start.) :slight_smile:

2 Likes

It doesn’t need Bluetooth it uses WIFI…

Have you enabled a firewall?

1 Like

Yes, they’re both on the same wi-fi. I installed blueman as well, but so far no luck.

No firewall.

Reboot phone, sometimes that helps.

Are you using indicator-kdeconnect?

1 Like

I have been in the same boat a while back. Couldn’t connect and spent hours looking for troubleshooting help.
Here’s what I came up with:

1. Obvious but important, both devices need to be on the same network

2. Is the kdeconnect process running:
ps -ef | grep kdeconnect

Example output:
user 3399 1 0 08:26 ? 00:00:02 /usr/lib/x86_64-linux-gnu/libexec/kdeconnectd

3. Is the process listening?
sudo ss -turelp | grep kdeconnect

Example output
udp   UNCONN 0      0                             *:xmsg             *:*    users:(("kdeconnectd",pid=972,fd=11)) uid:1000 ino:25723 sk:2 cgroup:/user.slice/user-1000.slice/session-1.scope v6only:0 <->                                                          
tcp   LISTEN 0      50                            *:xmsg             *:*    users:(("kdeconnectd",pid=972,fd=12))

4. Maybe your firewall gets in the way?
Is the firewall running?
sudo ufw status

If yes, turn it off for the test
sudo ufw disable

5. Are the ports open/blocked?
netcat -z -v <your-phones-ip> 1714-1764 # Try phone and laptop, use port which netstat shows

Example output:
Connection to <your -phones-ip> 1716 port [tcp/*] succeeded!
+ lots of Connection refused, but you need 1 "succeeded"

6. Check the kdeconnect home dir
ls -al /home/youruser/.config/kdeconnect/

7. Check CLI interface
kdeconnect-cli
6 Likes

Man, that was a long one but it did finally connect. Thanks @TomZ

1 Like

Firewall disabled by default -> “Why this distro so insecure!!!”

Firewall enabled by default -> “Why this distro software no work!!!”

6 Likes

Bad :iphone:

What was the problem in the end?

I went down your list and found the phone and connected it in the terminal.

2 Likes

I’ve installed KDE connect and am able to connect just fine on xfce.
But, when I send a file to the phone I can’t find it anywhere and files bigger than 1MB won’t leave my laptop.
Vice versa is doing ok.

And another thing, do I need Dolphin?

Thunar doesn’t show an extra folder.

Just tested with an 18MB file from laptop to phone on KDE-Plasma, works as expected.
In the plugin-settings under Share and receive, you can set where the files is
saved

Thanks, that worked, and somehow now bigger files can be transferred. :thinking:

I used KDE Connect with my new phone 2 days ago, or even yesterday and it worked flawlessly. But today couldn’t find device neither on the computer or the phone. My solution, if anyone else wants to try something else, was this:

  • I deleted the whole “kdeconnect” folder inside .config folder. (TomZ put the path, but to see it you need to show hidden files on your file browser - Mine is Dolphin).
  • Didn’t delete the app folder on the phone, since I couldn’t find it (need to make My Files or your file browsing app able to show hidden files and folders as well - but I didn’t do this step).
  • Remove KDE Connect package from PC.
  • Remove KDE Connect from the phone.
  • Restart both devices.
  • Turn off and on the router (I was trying to easily “reset” as many devices involved as I could).
  • Reinstall the package on the computer and the phone.

Hope it helps :smiley:

Edit: Make sure your firewall, if on, is disabled. Tested it and that causes this issue. Disabled it and still worked fine.

1 Like