KDE Connect Android app removed by Google Play Protect

I just turned on my Pixel 4a and I got this:

Did anybody else have this? I don’t have an explanation atm. KDE Connect was installed via F-Droid and I used it since at least 2 years without any issues. I hope this is just a f*** up by Google and not indeed a malicious app that somehow made it to the F-Droid store.

May or may not be related to your issue but I saw this posted on another platform:

Is Google going berserk on certain apps? I wonder If Signal would also be removed if it has been installed previously.

:innocent: moral of the story: De-Google! Get GrapheneOS, install sandboxed Play Store/services as user and not system app.

I’m pretty sure it’s deliberately done by Goolag.
Use F-Droid and ignore their controlled store.

KDE Connect installed from the Play Store here on my Pixel 6a, and no problem. Signal working fine too.

I doubt it. Why would they care? I guess the amount of Android users who have another store installed is below 0.1%.
F-Droid itself didn’t make a good impression also. I recently got a new phone and before installing F-Droid I tried to validate the APK. F-Droid itself links to a site with signing keys and checksums but none of those checksums matches the APK they offer on their site. And while the PGP validation itself works, it’s a bit strange that they tell you “The warning about the key not being certified with a trusted signature can be ignored.”

Anyway, I’m curious if I get the same warning on the new phone on the next Play Protect scan.

Doubt what?

My argument chain:

  1. Google Play Store / protect is a walled garden by corporation know for it’s censorship and manipulations.

  2. It can be used as a DRM, including based on user demographic and region (removing programs they don’t like for whatever reason)

  3. Can you trust it therefore?

My conclusion:
Absolutely not. If they can do that - they will do that, it doesn’t matter why.

F-Droid or some other store + Independent verification is another question…

That’s a bit weird.

the warning about the key not being certified with a trusted signature can be ignored. The important part is the indication of a good signature and that it is signed by the F-Droid release key.

I meant that I doubt that Google would do this on purpose because they don’t want ppl to use an alternative app store. The app itself can’t be the problem because it’s also available on the PlayStore.

1 Like

Most people don’t know anything about technology or alternative app stores though :upside_down_face:

1 Like

And if you really need something in the Google store, you can always get it from Aurora store.

No need for play store ever.

1 Like

Yes, they definitely would do that.

They’ve done that plenty of times, and worse. Look up NewPipe, for an example.

Quick update here: No issues on Pixel 7! Still no idea why this was happening on the 4a.

@Kresimir What’s up with New Pipe? Using it for years, no issues. Yeah, sometimes YouTube updates break functionality but there’s usually an update for New Pipe within a few days.

Not true for certain banking apps - however you can set up Goolag Play in a separate profile for this.

Edit: looks like this may be an unfortunate byproduct of a welll-intentioned effort by Google to root out open-source apps with malicious code inserted in the Google Play store: https://arstechnica.com/security/2023/08/google-removes-fake-signal-and-telegram-apps-hosted-on-play/

Another quick update: I just fired up my old OnePlus 6 and guess what? Yeah, app removed!
My best guess right now is that the apos in the Pixel 4a and the OP6 were just outdated. F-Droid update notifications never worked for me on any phone.

Still in Aurora app. It should still be in Google play.

Yeah, it’s also still available on F-Droid. I installed it from F-Droid on my Pixel 7 a few days ago and Google Play Protect has no complaints here. That’s why I think that the app was just out of date on the other two phones.

edit Still strange that it explicitly says “fake”.