KDE Bismuth tiling doesn't work

I installed bismuth particulary from AUR. Installation was successful.

How do I activate this thing? I tried various hotkeys from github page, nothing is happening.

My goal is to have Window A to occupy like 70% while Window B occupy 30% of screen. And to be able toggle window A from 70% to 100% easily. Something like shown in this video

Did you enable windows tilling? And you do have KDE Plasma DE installed right?

You can configure Bismuth in the System Settings > Window Management > Window Tiling.

Ohh shit, yes it wasn’t enabled. :expressionless: I assumed it gets enabled by default. My mistake.

Anyways, I still, probably, will need some help to achieve my goal. Zero experience with tiling stuff. The fact I don’t see any documentation also don’t help.

Do you know how to achieve what I asked? Or maybe know some good documentation or manual? :thinking:

You might be able to change stuff under the layout tab. But I’m no expert there might be better KDE guys who might help you out.

It says Tile Layout 3 but why only 2 windows are tiled? I have 3 windows in taskbar opened.
Also how to switch so windows are left and right?

Right now I have fully maximazed chrome window when I press Meta + T it shows Tile Layout 3 but the chrome is still only window I see, how this works?


I can switch 1 with 2 I can increase or decrease height but I cannot figure out how to make them side by side (horizontal) ?

All of your key bindings (in krohnkite, bismuth is forked from it,) should be in your kwin settings. From there you can change to whatever you want then to be.

Can someone explain how this tiling works?
It says 3 - what it means? For example, pressing any Focus hotkey doesn’t bring different window in focus. But same Focus hotkeys work when I switch to Monocle layout

How to add 2nd windows on right?

It will look like this

To ad second window, or 3rd window . … just open the program. . .

From what i can see on the project git, they are implementing a gui applet to easily switch layouts but from the rate they are doing it, it will take one or two weeks. Using a tiling manager is all about mastering the hotkeys, im just waiting for the applet to start using it since i am going to only use the auto tiling feature & cant seem to master the hotkeys.

I use it and setup float (to float one window with meta+f) and to float the all windows with super+shift+spacebar. Those are the only two I really use all that much.

Yup it doesn’t go like that.

I am trying to understand how it works. So far I don’t know if there is a bug, or I just don’t know how this tiling stuff works.

Did you turn it on in kwin scripts?

It take time . you will. In time you will no like or use applet :wink: give time you will see

Bismuth is activated.

Is there a convenient way to see what window is in focus mode? Maybe make active or focused windows have some green border?

The titlebar shows up white for me. The out of focus windows are grey. Konsole is in focus.

You can also setup KDE to always have focus follow the mouse pointer. . .

I on mobile atm… you can dim no focus windows or have border ( if it follow kronhkite) :pray:forgive spell

There is nothing like that for me. So its very hard to track which window is active (focus) mode.


In above screenshot I can only make active window 1, why is that?

Pressing Meta + L doesn’t make active Window 2 or 3. ??

Edit1: Alright, I found something interesting seems like Meta + H works no problem, but Meta + L doesn’t work. (tested by making active window just with mouse and then Meta + H goes left, but Meta + L doesn’t go right) :thinking:

Just go through the shortcuts. Change them to whatever you want.

I would like to keep defaults for now. I don’t know what is blocking Meta + L

Edit 1: Nothing was. That hotkey was removed somehow. Very weird.