Just updated to 5.7.2 and problem

haven’t posted for a long time cos my system has been running great!
Just did an update to the new 5.7.2
Rebooted and grey screen, you can wiggle the mouse and see about 3 pixels worth of it at the top of the screen
Can login then the screen goes black
Rebooted and managed to log in with ‘Fallback initramfs’ option
then rebooted using standard ‘boot’, same problems
Rebooted, select ‘Fallback initramfs’ and grey screen again!
Rebooted again using ‘Fallback initramfs’ and I’m logged in again…
I’m using Radeon Vega! had problems with this in the past…
Troubleshooting help please!

disabled compositor, didn’t help
It’s temperamental, sometimes it boots ok, other times grey screen grrrrr

Install a different kernel for now and see if that helps. You may even wish to try two:

1.This is the zen kernel and headers. It is supposed to be tweaked for performance. They also tend to hold back a little while on a new release to test it.

In terminal do:

sudo pacman -S linux-zen linux-zen-headers

2.This is the LTS kernel. It is considered the most stable kernel as it is always a few versions back from current (at 5.4x at the moment.)

In terminal do:

sudo pacman -S linux-lts linux-lts-headers

sudo grub-mkconfig -o /boot/grub/grub.cfg


systemctl reboot


hi elloquin
thanks for the post
My system is normally very up to date…like I update it when I first log on and then through the day if I get a message…
I was running 5.6.15…I looked in /var/cache/pacman/pkg/ and found a .zst file
so will this command downgrade it?
pacman -U linux-5.6.15.arch1-1-x86_64.pkg.tar.zst
I think I need the headers too but they aren’t in there, I had a clean up yesterday and cleared the cache (ssd running low on space)…just my luck

I am unsure I don’t downgrade very often and only if I have no other options.

EndeavourOS just added a fantastic new feature where you can with the ease of clicking a button in the welcome app set your cache to automatically clean itself up and also pick how many copies you want to keep. Thanks @manuel!

Lastly it is always a good idea to keep more than one kernel installed because this situation happens from time to time. This way you can just leave the stock kernel alone and switch to an alternate kernel until the stock kernel updates again and the problems go away in a couple of days.

If you just want to install the latest linux-headers package:

sudo pacman -S linux-headers

P.S i’ll be right back haven’t upgraded yet today. Let me run a timeshift and then update BRB :grinning:

1 Like

So my hardware boots 5.7 just fine (zen is at the same version as linux.) Let me try and boot the linux kernel…brb I will edit this post…

OK that boots fine as well so it’s probably a hardware bug upstream. Last time I had a problem like this was when the LTS kernel was on version 4.19.5x or so couldn’t boot that kernel until 5.4 became the new LTS.

1 Like

it looks like a ‘display manager’ problem
I changed it to gdm rebooted and it worked but I had this yucky gnome like environment :laughing:
then I switched it back to lightdm and the problem reappeared
I’m tempted to try lxdm but worried it might look as crazy as gnome

Not surprised that is GNOME DISPLAY MANAGER lol.

Can you return in terminal: copy paste the output with three ``` before and after the ouput it is easier to read.

journalctl -p 3 -xb


right I just changed it to lxdm and it boots fine, mind you the logon screen looks a bit ‘toy town’ :rofl: :joy:

1 Like

journalctl -p 3 -xb

1 Like

wow it gets even more weird
I remembered donkies ago when I used to use manjaro something got corrupt so I went for the ‘clear saved session’ option, tried it AND I changed it back to gdm
Reboot, the logon screen I get is the gnome one!!!
Once logged in it’s my old xcfe setup :upside_down_face:

GDM is gnome’s display manager so ya it does that :wink:

Can you return the output I asked for?

1 Like
juin 11 20:25:10 amd kernel: pci 0000:00:00.2: AMD-Vi: Unable to read/write to IOMMU perf counter.
juin 11 20:25:10 amd kernel: ata5.00: failed to set xfermode (err_mask=0x40)
juin 11 20:25:10 amd kernel: sp5100-tco sp5100-tco: Watchdog hardware is disabled
juin 11 20:25:10 amd systemd-udevd[309]: /etc/udev/rules.d/99-ds3-controllers.rules:1 Invalid key/value pair, ignoring.
juin 11 20:25:11 amd kernel: kvm: disabled by bios
juin 11 20:25:11 amd kernel: kvm: disabled by bios
juin 11 20:25:11 amd kernel: kvm: disabled by bios
juin 11 20:25:11 amd kernel: kvm: disabled by bios
juin 11 20:25:38 amd gdm-password][985]: PAM unable to dlopen(/usr/lib/security/pam_gnome_keyring.so): /usr/lib/security/pam_gnome_keyring.so: cannot open >
juin 11 20:25:38 amd gdm-password][985]: PAM adding faulty module: /usr/lib/security/pam_gnome_keyring.so```

My advice is still the same. :hugs:

please use whatever DM your installation calls for…gdm for gnome, light dm for xfce (and several others)

1 Like

yeah I thought I had changed it back to lightdm, I have now…
So I’m back to getting a logon screen when I select the (fallback initramfs) boot option but the ‘normal boot’ just gives me a grey screen…weird :thinking:

Here’s mine…ignore the errors it’s my external USB drive. If I unplug it they go away :sweat_smile:

[elloquin@elloquin-elloquin ~]$ journalctl -p 3 -xb
-- Logs begin at Sun 2020-05-24 14:58:53 EDT, end at Thu 2020-06-11 14:32:27 EDT. --
Jun 11 14:17:20 elloquin-elloquin kernel: sd 9:0:0:0: [sde] No Caching mode page found
Jun 11 14:17:20 elloquin-elloquin kernel: sd 9:0:0:0: [sde] Assuming drive cache: write through
Jun 11 14:17:20 elloquin-elloquin kernel: scsi 9:0:0:1: Wrong diagnostic page; asked for 1 got 8
Jun 11 14:17:20 elloquin-elloquin kernel: scsi 9:0:0:1: Failed to get diagnostic page 0x1
Jun 11 14:17:20 elloquin-elloquin kernel: scsi 9:0:0:1: Failed to bind enclosure -19
[elloquin@elloquin-elloquin ~]$ 
1 Like

Again if that worked the LTS will definitely work. I think you are confusing keeping packages updated with kernels. The latest greatest kernel usually has fixes for the newest hardware.
If zen or LTS work fine just use one of those until the problem goes away. Although the output of the journalctl -p 3 -xb using lightdm may be useful. Run it after a reboot.

1 Like

OK thanks for the heads up on the journalctl usage…not bothered about KVM stuff
I did install qemu at one stage but only cos I was bored I seem to recall :crazy_face:
I’m happy with 5.6 even this ‘hot off the press’ 5.7 kernel (now I have a way to get logged on)…no way I’m going back to a LTS kernel cos I remember having problems with Radeon Vega with those older ones…
Thanks for your help! I can get back to watching the stock markets doing strange things after yesterdays Fed meeting :grimacing: :cowboy_hat_face:

1 Like

So did I. It works now :joy:


right I ungraded my other SSD and no problems whatsoever
Now after further reboots I see what is happening…
boot 1 - grey screen, so I do ctrl-alt-f1 then ctrl-alt-del to reboot
boot 2 - fine!
boot 3 - goes back to the grey screen!
boot 4 - fine
Soooo why it is giving me the run around every other boot??? PITA :face_with_symbols_over_mouth: