Jagged font rendering switching from Nvidia to AMD

So Ive switched my 1080ti to a 5700xt and now all my font rendering is jagged and terrible looking. I also cant seem to create 20-amdgpu.conf without the system refusing to start the Xserver.

Is there anyone with experience switching nvidia to amd that might be able to help? I would rather not completely reinstall but im at a loss as to what is going on. I removed everything nvidia to my knowledge and have mesa installed but things just dont seem to work right.

I have wayland disabled in GDM so im using Xorg

Not much experience with nVidia, but for what it’s worth…
in /etc/X11/xorg.conf.d put the following as 20-amd.conf

Section "Device"
	Identifier  "AMD"
	Driver "amdgpu"
    Option "TearFree" "on"
EndSection

along with whatever else you need. Not sure if the name you tried caused a problem. Also - check in Appearance app that your fonts are only getting ‘slight’ hinting…

Beyond that, you’re beyond what I’m familiar with!

1 Like

I think the AMD 5700 XT should be working on integrated amd kernel modules. Are you wanting proprietary drivers? You said you removed all Nvidia including the 20-nvidia.conf xorg file?

Did you install any of these?

mesa lib32-mesa xf86-video-amdgpu vulkan-radeon lib32-vulkan-radeon libva-mesa-driver lib32-libva-mesa-driver mesa-vdpau lib32-mesa-vdpau

Yeah I have all the mesa bits installed, the GPU plays games and such fine but font rendering is borked

You have all of those packages installed? vulkan?

Are the fonts cut off? It may require adding an environmental variable. Not sure where it needs to go but i picked this up reading on another site. So you may want to dig around some other sites as there are others who have these cards.

set env var RADV_DEBUG=nongg

I think this a variable set in mesa. Here is some info.

https://www.mesa3d.org/envvars.html

I have vulkan and everything installed, the fonts are jagged with heavy aliasing even when I enabled antialiasing for text and slight hinting. I tried making an 20-amdgpu.conf thinking it could be xorg configuration file issue but when I make one xorg won’t start.

I’m at work right now so can’t test things ATM

1 Like

Im at an absolute loss, the fonts look terrible even after a reinstall and they have a white halo around. Its incredibly difficult on my eyes and i cant figure out what the problem is or what sort of combo of words to search for to find a solution

Ive tried different freetype, mesa, and fontconfig versions

Ive tried making font.conf and local.conf files with antialiasing enabled, ive tried setting it through gnome terminal, gnome tweaks, etc but still nothing changes

https://wiki.archlinux.org/index.php/font_configuration#Incorrect_hinting_in_GTK_applications_on_non-Gnome_systems

1 Like

I’m using GNOME and even still I tried everything in that wiki.

I’ve managed to work around the issue. I recalibrated my monitor and put it from default to 0 sharpness. I’m not sure what’s going on but the output on the 5700xt has substantially higher sharpness than the 1080ti to the point I can’t use the setting’s I’ve had for a year on my Dell U2713H.

Ok i have a AMD question, during my Arch install on this pc i just installed the xf86-video-amdgpu thats it. Should i install the rest of this as well?

mesa lib32-mesa vulkan-radeon lib32-vulkan-radeon libva-mesa-driver lib32-libva-mesa-driver mesa-vdpau lib32-mesa-vdpau

Before I built this pc, i was always a Intel/Nvidia guy lol. I do a little gaming, not to much.

If you want 3D acceleration video acceleration yeah I would

1 Like

Can anyone better explain what vulcan-mesa-layer is/does, i see its optional?

This is from the AMD site.

Any AMD APU or Radeon™ GPU based on the Graphics Core Next (GCN) architecture is already Vulkan™-compliant. Because of this, form factors of all shapes and sizes can benefit from what Vulkan™ has to offer.

Compared to OpenGL, Vulkan™ substantially reduces “API overhead” – the background work a CPU does to interpret what a game asks of the hardware – to deliver meaningful features, performance, and image quality and expose GPU hardware features that wouldn’t ordinarily be accessible through OpenGL.

Edit: I have just installed it all on mine as i also only had the xf86-video-amdgpu and mesa installed. So i have installed the vulkan and the rest of the files on mine. Reboot is fine so i’ll try it out and see but i’m not gaming so i don’t know what difference i’ll notice.

1 Like

I don’t know if you are running the higher refresh rates on this monitor with Display Port and higher resolution? Or are you using HDMI? Also since you are using Gnome i think there are more issue with fonts? But anyway i’m not an expert on it and i don’t know of anyone on EndeavourOS here using an AMD 5700XT that i know of. There are a lot of settings you can get into with regards to the Monitor and your Video card such as DPI and refresh rates and resolution. So you going to have to peruse the forum and other forums such as Arch/Manjaro/Arco Linux and see if you can pick up on some info or someone else who has come across the same issues with that hardware. You can also email the mesa people on github or AMD possibly for more answers?

I installed it and no issues. It’s all good on my AMD RX590. Like i say probably really won’t notice anything unless i get into some gaming.

1 Like

I have a RX570 4gig, thinking of getting the XFX RX590 8gig. Thanks!

Edit:Forgot to mention im using a 32" Samsung via HDMI cable.

I have the Gigabyte RX590 8 GB

1 Like

I found something that managed to somewhat solve it for me. I went through a lot of forums and stuff trying to figure it out previously though.

My dell U2713h is being run over HDMI but it being an editing display has only 60 hz so no high refresh rate.

I might try contacting AMD or asking Mesa folks why the output is so sharp on default though.