Issues with Wine : fail to intialize DirectX audio

Hello Everyone.

Recently I was trying to open a game via Wine, but I am consistently getting the following error :

The sad part is that I had played this game 2-3 times last year but I am not able to open it now.

I tried the method which suggested using Winetricks, but it didn’t executed and some weird error came, which was like " your Wine version 8.XX is not supported, please update to version 5"

Then I thought to go via winecfg, but I don't know what to do there :


inxi -Faz :

  Kernel: 6.2.2.arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-linux-endeavouros
    root=UUID=744334ac-e235-4d3d-845e-3ffe3a52edc9 rw quiet loglevel=3
  Desktop: KDE Plasma v: 5.27.2 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: EndeavourOS base: Arch Linux
  Type: Desktop System: LENOVO product: Lenovo H320 10044 v: Lenovo
    serial: <superuser required>
  Mobo: LENOVO model: N/A v: INVALID serial: <superuser required>
    BIOS: LENOVO v: D6KT11A date: 05/20/2010
  Info: model: Intel Core i3 540 bits: 64 type: MT MCP arch: Westmere
    gen: core 1 level: v2 built: 2010-11 process: Intel 32nm family: 6
    model-id: 0x25 (37) stepping: 2 microcode: 0x11
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 1197 high: 1198 min/max: 1200/3067 scaling:
    driver: acpi-cpufreq governor: performance cores: 1: 1197 2: 1198 3: 1198
    4: 1198 bogomips: 24469
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode;
    SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Core Processor Integrated Graphics vendor: Lenovo
    driver: i915 v: kernel arch: Gen-5.75 process: Intel 45nm built: 2010 ports:
    active: VGA-1 empty: DP-1,HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:0042
    class-ID: 0300
  Device-2: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 1-1.4:4 chip-ID: 046d:0825 class-ID: 0102 serial: <filter>
  Display: x11 server: X.Org v: 21.1.7 with: Xwayland v: 22.1.8
    compositor: kwin_x11 driver: X: loaded: intel unloaded: modesetting
    alternate: fbdev,vesa dri: i965 gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: VGA-1 mapped: VGA1 model: Lenovo D185wA serial: <filter>
    built: 2010 res: 1366x768 hz: 60 dpi: 85 gamma: 1.2
    size: 410x230mm (16.14x9.06") diag: 475mm (18.7") ratio: 16:9 modes:
    max: 1366x768 min: 720x400
  API: OpenGL v: 2.1 Mesa 22.3.6 renderer: Mesa Intel HD Graphics (ILK)
    direct-render: Yes
  Device-1: Intel 5 Series/3400 Series High Definition Audio vendor: Lenovo
    driver: snd_hda_intel bus-ID: 1-1.4:4 v: kernel bus-ID: 00:1b.0
    chip-ID: 046d:0825 chip-ID: 8086:3b56 class-ID: 0102 class-ID: 0403
    serial: <filter>
  Device-2: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
  Sound API: ALSA v: k6.2.2.arch1-1  running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.66 running: yes
  Device-1: Intel 82578DC Gigabit Network vendor: Lenovo driver: e1000e
    v: kernel port: e880 bus-ID: 00:19.0 chip-ID: 8086:10f0 class-ID: 0200
  IF: enp0s25 state: down mac: <filter>
  Local Storage: total: 577.55 GiB used: 16.06 GiB (2.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD5000AZRX-00L4HB0 size: 465.76 GiB block-size: physical: 4096 B
    logical: 512 B speed: 3.0 Gb/s type: HDD rpm: 5400 serial: <filter>
    rev: 1A01 scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: OSC model: SSD 120GB size: 111.79 GiB
    block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s type: SSD
    serial: <filter> rev: 0A0 scheme: MBR
  ID-1: / raw-size: 111.79 GiB size: 109.47 GiB (97.93%)
    used: 16.06 GiB (14.7%) fs: ext4 dev: /dev/sdb1 maj-min: 8:17
  Kernel: swappiness: 30 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 710 MiB used: 352 MiB (49.6%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 38.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 165 Uptime: 12m wakeups: 0 Memory: 2.77 GiB
  used: 1.32 GiB (47.5%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: pm: pacman
  pkgs: 1063 libs: 287 tools: yay Shell: fish v: 3.6.0
  running-in: konsole inxi: 3.3.25

How should I proceed ?

1 Like

Nothing weird about it, make sure to use latest winetricks

This is important point, that’s why i always advice to use not latest wine from repo, but portable wine with portable prefix which works for your specific game.


I used that winetricks that we get via yay winetricks

I have slight doubt.

Last time as well, I used the wine that was available in multilib, and this time as well.

The difference is that I decided to try GNOME, but came to KDE after bad experience in 3 days :rofl:

What might have went wrong?

Also, why I faced the need to go via winetricks, because this is the first time when I went by this route. Earlier everything worked just fine.

1 Like

I see you’re not a fan of reading :laughing:

Using system wine on rolling distro (well any distro really) is generally a bad idea because:

  1. Wine is EXTREMELY complex software, it tends to break certain games on version updates because of regressions (meaning you fix something and it breaks something else).

  2. It might work for a while, but eventually it will break for almost any game.

So what you should do?

  1. Use specific version of wine in a portable fashion (independent from your system wine version), so it will not change unless you want it to.

  2. Use independent wineprefix for each game.

Just find a wine version that worked good for your game, follow my instruction with simple scripts (you can do it however you like, it’s just a stupid little example while i was in a hurry so people would understand concept) to create prefix and install game, then transfer your game saves from usual ~/.wine prefix and play it as you was before.

Gnome has different compositor (mutter), but i really doubt it have influenced anything.

How do i know? :laughing:
Using winetricks is very normal practice to install and make problematic games work.
Most likely your issue is caused because by wine update regressions for your game.

1 Like

Currently I am having my lunch :sweat_smile:

So might be mistake from my side. I will report to you back later.


I did read few points few days ago, and had tried the other branches like glorious-eggroll. And also I had tried Bottles.

I went to Lutris Website and searched for “Pokemon” , and there are few games like :

Both of these have same base of :

RPG Maker XP
Pokemon Essentials v17

And the game I am presently using is also based on the aforementioned tools. Almost all Pokemon games which have executable are based on these 2 tools.

How I can do it ? The archive contains the following items :

The game here do not get installed on the system, rather we have to run it from its extracted folder and from that location only. If I move out that Game.exe from the parent folder, then game will not run.

You should probably read all of it and not follow some torn out pieces from different guides, for instance i’ve never ever mentioned Bottles…

Obviously in this case - just copy it to your wineprefix, let’s say C:\Games\GameTitle and use Game.exe as launcher.

1 Like

Means I need to go via step 0 to step 4 ?

Okay then. I will go by that route. It is looking slightly exhaustive at first look, but since you had provided the entire scripts, hence I need to copy-paste-move only. Thanks, I try it.

Did you end up getting it running? I’ve been playing it for the last couple of days on wine-staging. The only issue I have is no music, however other sounds play.

1 Like

Just no. Don’t waste your time.

“winetricks” is being a PITA lately, it just doesn’t work on Debian. Take my word for it. I only need it for the “corefonts”, imagine if I would need it for one miserable game? I have gone as far as backing up the “dot-reg” files and a few other things of the fake C: drive, then copying the same stuff from another installation, because the thing wouldn’t register the “corefonts”. This is not what I had to do for any Arch-based distro LOL. However, when “winetricks” is installed via “pacman” and it’s run, it complains the “upstream” version is newer. This is only FYI.

There are some 32-bit Windows apps like OpenMPT that might need a few libraries installed such as “lib32-portaudio”, separately from Wine. Also you might want to install “wine-gecko” and “wine-mono” because it’s not done for you. Might want to look into all that.

Almost forgot to mention that Debian and Ubuntu make it near impossible to get “wine-gecko” in particular, and when they feel like it “wine-mono” is available. That’s why I would never recommend anything based on them for games, and barely for anything related to music production except 32-bit freeware.

I actually didn’t played the game the the due to schedule and also the little cousin deleted that game folder back then as the folder was named as misc_timepass :sweat_smile: , for which I begged pardon from Keybreak.

I will go over it in next few days, so then I will be in better position for explaining it.

For future readers of this topic.

The possible problem might be the missing libs if you are using pulse audio.
So before trying any other solutions, make sure you have the necessary libs.

Yay -S lib32-alsa-plugins lib32-libpulse lib32-openal
1 Like

TYSM you are a true hero