Issues with installing AttractMode from the AUR

It’s a long story, and I am back on EndevourOS again.

I’ll keep the story short. I know how to transfer files from one system to another and all that stuff. I’m a NewB when it comes to fixing installation problems that have errors.

FIrst issue and it seems to NOT matter what distro I am using, I played around with ArcoLinux for a while and still get the same issue regardless of whatever I did.

I am assuming first and foremost that the issue has to do with updated libraries and or files.

I am trying to install the latest AttractMode, Something has changed. And I keep getting this build issue with it that says something like towards the end this

src/media.cpp:1223:37: error: ‘AVCodecContext’ {aka ‘struct AVCodecContext’} has no member named ‘refcounted_frames’
1223 | m_audio->codec_ctx->refcounted_frames = 1;
| ^~~~~~~~~~~~~~~~~
src/media.cpp:1232:27: error: ‘avcodec_decode_audio4’ was not declared in this scope; did you mean ‘avcodec_decode_subtitle2’?
1232 | int len = avcodec_decode_audio4( m_audio->codec_ctx, frame, &got_frame, packet );
| ^~~~~~~~~~~~~~~~~~~~~
| avcodec_decode_subtitle2
Compiling obj/squirrel/sqdebug.o…
make: *** [Makefile:459: obj/media.o] Error 1
make: *** Waiting for unfinished jobs…
make: *** [Makefile:459: obj/swf.o] Error 1
==> ERROR: A failure occurred in build().
Aborting…
rm -rf /tmp/bauh@USER/arch/build_1645472922

My first thought was ffmpeg, needs to be older or some flash thing. But the problem is right now I am on a new install of EndeavourOS and not really sure how to continue.

What I am doing is changing over from ArcoLinux to Endeavour, Because Arcolinux seems to be so buggy and Endeavour does not seem to be that way.

I also have a problem simular with trying to install Bomi and a couple more. I’m thinking there has been a package update, but I don’t know how to downgrade since I am on a fresh install.

Anyway, I really need to get attractmode and bomi installed for my uses but can’t seem to do so.

Sorry, I have another build issues with Audacium. I have tried every single fix mentioned on the internet after searching, and I also recently decided to stop using Pamac because it seems to fail after a while, but I believe that issue has to do with using bleachbit to clean my PC. So now I switched to “Bauh” which I recently found out about and I think it’s better in my opinion.

Anyway, anyone know how to fix this? Any help would be greatly appreciated and I can post more logs on the issues?

THank you for you time.

I think maybe you just need more knowledge on package build when trying to install a package from the AUR. It may be that you don’t understand what to do each time a question is asked in the build process. I’m not an expert in this matter but I rarely have any issues. Then again i don’'t normally install some of these packages you are referring to.

I don’t see this package AttractMode?

Edit: Is it just attract?

1 Like

The thing is I have done this probably 100 times easily with no issues, and sorry I should have said the package name is called “attract”, it’s a game frontend.

Okay i see attract. Are you using attract or attract-git version?

1 Like

attract 2.6.1-2
Last Packager: FredBezies
Last Updated: 2020-01-29 10:14 (UTC)

Latest comment:

won’t compile now ffmpeg5 is out, must depend on ffmpeg4.4
https://aur.archlinux.org/packages/attract#comment-852625

4 Likes

I’ve tried both versions. It would install fine a couple weeks ago. Now I get that error regardless using any arch distro or plain vanilla arch or trying to install with pamac or bauh or using pacman. So I keep thinking a library file has been updated and the build is pointing to an earlier version although I am not sure how to change all that stuff. I could install pamac-all and go into the build files and change the number version for ffmpeg, but I tried that. But right now I am on a fresh install of EndeavourOS and decided to go with “Bauh” which I recently found out about, I like it much bettter.

Anyway regardless of trying to install it with anything I still get that build error. I’ts probably because I think the AUR package hasn’t been maintained since 2018, so I am just wondering how I can downgrade or install the packages I need to make it work.
Anyway, thank you for your time. This is a maintainer issue which I guess happens to be the developer also, so I guess I just need to figure out how to downgrade a few packages to install it? I really don 't know.

I just looked and ffmpeg 4.4.1-4 is installed. Thank you.

1 Like

What specific package are you trying to install?

This package is abandoned and hasn’t been updated in over 2 years, which may explain why it won’t build.

Fred has picked it up.

https://aur.archlinux.org/packages/attract

Have you tried the git version?

https://aur.archlinux.org/packages/attract-git

Have you checked upstream too?

http://www.attractmode.org/

1 Like

Wish i could be of some help but i really don’t know what the issue is with it.

1 Like

This is the install instructions for Linux:

Compiling Attract-Mode
----------------------

Build instructions are set out by operating system below:

Linux, FreeBSD:
---------------

These instructions assume that you have the GNU C/C++ compilers and basic
build utilities (make, pkg-config, ar) on your system.  This means the
"build-essential" and "pkg-config" packages on Debian or Ubuntu-based
distributions.  Other distributions should have similar packages available.

1. Install the following *development* libraries on your system:

   * Required:
      - SFML SDK version 2.x (<http://sfml-dev.org>)
      - OpenAL
      - Zlib
      - FreeType 2
      - The following FFmpeg libraries (required for videos):
          * avformat,
          * avcodec,
          * swscale,
          * avutil,
          * swresample or avresample.
      - OpenGL and GLU (or OpenGLES for GLES version)
      - JPEG library
      - Make and Package Config
      - Xrandr

   * Optional:
      - Fontconfig (to assist with finding fonts).
      - Xinerama (for multiple monitor support).
      - libarchive (for .7z, .rar, .tar.gz and .tar.bz2 archive support).
      - Libcurl (for network info/artwork scraping).

2. Extract the Attract-Mode source to your system.

3. From the directory you extracted the source into, run:

           make

   or, if you are building on a Raspberry Pi, O-Droid or another embedded
   system, you can build the OpenGL ES version with the following:

           make USE_GLES=1

   This step will create the "attract" executable file.

4. The final step is to actually copy the Attract-Mode executable and data
   to a location where they can be used.  To install on a system-wide basis
   you should run:

           sudo make install

   This will copy the "attract" executable to `/usr/local/bin/` and default
   data to `/usr/local/share/attract/`.  Note: if you are building the OpenGL
   ES version you need to include the `USE_GLES=1` parameter here as well.

   For a single user install on Linux or FreeBSD, you can complete this step
   by copying the contents of the "config" directory from the Attract-Mode
   source directory to the location that you will use as your Attract-Mode
   config directory.  By default, this config directory is located in
   `$HOME/.attract` on Linux/FreeBSD systems.

   NOTE: The Attract-Mode makefile tries to follow the GNU standards for
   specifying installation directories: <https://www.gnu.org/prep/standards/html_node/Directory-Variables.html>.
   If you want to change the location where Attract-Mode looks for its default
   data from `/usr/local/share/attract` you should change these values
   appropriately before running the `make` and `make install` commands.

Someone more experienced might be able to walk you through it. Good luck!

1 Like

@Bobcat
Maybe try this one as it is easier to follow. Not sure it works either.

Edit: Thanks to @pebcak

2 Likes

Unfortunately it doesn’t work either. :man_shrugging:

1 Like

https://github.com/mickelson/attract/issues

1 Like

Generally most computer geeks that use Linux are more suited to a career in radio rather than TV. IMO installing AttractMode on your Linux box is not likely to instantly turn you into a regular Casanova with the ladies. Perhaps spending more time at the gym would be a more worthwhile investment of your time.

OK people, I admit that was completely off topic, but only a joke. :rofl:

My apologies, but I couldn’t resist.

4 Likes

Tried the git-version with yay from AUR and looks like it´s working.

My system is fully updated. ffmpeg 4.4.1 and ffmpeg 5.0 both installed.

1 Like

It wasn’t working for me. I tried both. What version is ffmpeg? I read somewhere it needed ffmpeg 4.2
I didn’t want to downgrade as there are other things that need to be downgraded at the same time.

1 Like

Sorry @ricklinux , just edited my post.

1 Like

I think it is working now. I’m installing it. It didn’t before so somebody has fixed it.

1 Like

Hopefully @Bobcat is around as it is working now as you say.

2 Likes

He can’t see this if he’s too busy playing :joy:

2 Likes