Issues with display scaling

Hello to you all,

after a recent update I have the problem, that I cannot change the display resolution of the internal display (4k) of my laptop anymore.
In my set-up I am using the built-in display (4k) and two external displays (full-HD).
I’m on Cinnamon and the system is up-to-date.

Until recently I could change the resolution of the built-in display to 1920x1080 (same as the external displays) to have the same “experience” on each displays. I had no issues with it so far.

After a recent update I encountered very unusual issues with the scaling of several programs and reduced performance overall (everythings seems laggy, and the screen resolution is bad).
I checked the display settings and, as mentioned above, I cannot change the screen resoltion of the build-in display anymore (it’s greyed-out, I still can change the resolution of the external displays).

When I (de-)activate the built-in display I encounter some weird behavior of the screen resolution as shown below.

I hope that you can help me with my issue.

Let me know, if you need anymore information from me.


First some infos from inxi:
$ inxi -G

  Device-1: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
    driver: amdgpu v: kernel
  Device-2: Chicony Integrated Camera driver: uvcvideo type: USB
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2 driver: X:
    loaded: amdgpu unloaded: modesetting dri: radeonsi gpu: amdgpu resolution:
    1: 1920x1080~60Hz 2: 1920x1080~60Hz 3: N/A
  API: OpenGL v: 4.6 Mesa 23.1.3 renderer: AMD Radeon Graphics (renoir LLVM
    15.0.7 DRM 3.52 6.3.9-arch1-1)

The resolution according to neofetch with deactivated built-in display (two external 1920x1080 displays):
Resolution: 1920x1080, 1920x1080
→ Here everything works just fine

The resolution when I activate the built-in display:
Resolution: 3840x2160, 3840x2160, 3840x2160
(still 4k built-in and two full-HD external)

You could try downgrading mesa as there was a newer version recently.

Hello ricklinux,

thank you for your fast reply.

I tried downgrading mesa and lib32-mesa to version 23.0.3 as shown in this article:

But the issues weren’t resolved by downgrading it to 20.0.3 (and I didn’t want to downgrade it to any arbitrary version lest I break my system).

Might there be any version I should/could try?


It was just a thought but it may not be the problem so i would just update it again for now.

Edit: Did you use xrandr to set up all your monitors? Or just doing it from settings within Cinnamon?

1 Like

hey just had the same problem and i solved downgrading kernel to 6.3.8 from 6.3.9

(asus g14 2022) ryzen cpu integrated graphics, possibly kernel igpu driver problem introduced

1 Like

it seems that with the last kernel update, the amd drivers are not working properly.

will be patched soon according to the link

Hello to you all,

many thanks for your feedback.

I haven’t tried to use xrandr, but downgrading the kernel from 6.3.9 to 6.3.8 solved the problem.
I’ll just wait until the bug is fixed before updating the kernel.

Thank you again and have a nice day!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.