ISO-Next installation problem

I downloaded the new ISO. When i boot into the live usb there is no welcome or install window appearing also it doesnt detect my sound, wifi anything. Anyone experienced this? When i go to install system from the menu also nothing happens.

More information required. It would be helpful to know where you are, and what you are trying to install on. Even the live system has quite a few diagnostic tools available, assuming you can at least find a terminal on the live system.

Extensive testing (hundreds of different installs, in different continents and on different hardware) has taken place - but no-one can cover ALL possibilities - so please help to narrow it down some.

  1. Country and location - within 500km anyway
  2. Posted between triple ` marks before and after, the pasted output of inxi -Faz

Maybe more is needed, but that’s a good start!

1 Like

Also let’s make sure you have created the USB installer properly:

Our wiki articles will give lots of information as well.

One important is this:


@abrasmelin first of all welcome to the purple side of Linux…

And i would bet you create the installer medium (ISO) on USB stick with a tool like rufus or similar? As anything that changes the ISO boot files will lead to a non-working installer …
As we use archiso what provides a ready-to-use bootable system image (hybrid working on USB and DVD/cd) It must be written as it is to the medium.

First of all this is not my first time installing Endeavour or Arch. I used EO xfce,gnome,kde in the past.

I tried usbwriter,rufus.etcher. All giving me same result. I tried 3 different usb sticks. Very weird.

Sounds like you likely have a corrupt download then.

I would delete whatever you have and try again.

I’m my experience popsicle and etcher are the most reliable. If both fail use dd and then you’ll know 100%.

I second popsicle, fast and reliable…

Protip keep all of your good/fun/helpful distros on hand and ready to roll with ventoy

Mine has: Arch, Mint, EOS, openSUSE, Fedora, Solus and Pop! On it.

I’m also not a pro, so this is actually. . .

Just the tip.


Interestingly this popped up in my youtube feed lol(He posted it today).


Try plugging your pc into a wired connection.

there are some weird stuff I see when booting up which i never seen before.

pulseaudio,wireless even firefox doesnt work.

What part of that looks out of place specifically.

TL:DR te entire thing. It looked ok though??

Edit: did you lose connection to the USB? It looks like it started and the USB got knocked out. If it’s wired, maybe the cable is on it’s way out??

Never i would use ventoy.

No, whys that?

Because i don’t like it!

1 Like

No but tried different port. Still same result.

It’s a bad download or a bad live usb.

I am creating the usb in windows like I always did in the past. Using rufus. choosing GPT and UEFI partition scheme and using DD.

Sorry for the off-topic, but has anyone tested this new image with Ventoy? Some images work with it fine, some have problems.

1 Like

Don’t use Rufus! That’s the problem. If doing it from Windows i would use Etcher.

1 Like