Is my Reflector broken?

Everytime I run Reflector-simple I get a message with regard to missing reflector-simple.conf and then if I click okay I get an error stating no mirrors found. I’m assuming this isn’t what’s supposed to happen, so how can I fix it?

reflector simple error

Probably when not connected to internet?

Nope, I’m always connected.

Did you try to reinstall reflector-simple?

yes, but to be fair I didn’t try a de-install first. Let me try that…

EDIT: Removed reflector-simple/geoip/geoip-database and re-installed. No difference…

Here is another comparable issue.

What does command

reflector --list-countries

show?

1 Like

yeah I saw that post. I don’t have a reflector-simple.conf that I can find. Is there a default one I can get from somewhere?

[zero66@x230 ~]$ reflector --list-countries
/usr/bin/python3: No module named Reflector
[zero66@x230 ~]$ 

Do you have reflector itself installed? @manuel is this missing here?

1 Like

That’s what was missing! Many thanks!

Glad it was solved, although the main credit goes to @manuel!

1 Like

Reflector is a dependency of reflector-simple, so it should have been installed by default.

sudo pacman -R reflector                                                             1 ↵
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing reflector breaks dependency 'reflector' required by reflector-auto
:: removing reflector breaks dependency 'reflector' required by reflector-simple
sudo pacman -S reflector-simple
resolving dependencies...
looking for conflicting packages...

Packages (2) reflector-2020.9-1  reflector-simple-1.7-1

Total Installed Size:  0,09 MiB

:: Proceed with installation? [Y/n]

1 Like