Is my BIOS screwed up? [SOLVED]

I suspect this is not really EOS related, though my most recent install attempt was with an EOS USB. This laptop was wiped of Windows. It’s since had a total of 3 Linux distros installed (Fedora 39, CachyOS, and LMDE). It currently has LMDE installed. I was going to install EOS Gnome. Each time I set boot priority in BIOS to the PNY USB drive, it boots into LMDE. Even stranger, this laptop ony has one USB drive, but shows 2 PNY USB drives in BIOS boot priority. Ideas?

I also tried with the previous Fedora and CachyOS USB’s to be sure it wasn’t a USB thumbdrive issue as those 2 are already proven to work.

In your 1st picture, you show USB off.

If it has a boot menu use that to select your EOS usb thumb drive

Otherwise set it as first boot option in bios but your thumb drive has to be inserted before boot

@sammiev I noticed the USB off as well upon first attempt. That was corrected last night, uploaded wrong image.

@fred666 USB is inserted and set as first option.

Strange that 2 instances of the drive show. I connected my USB-C Ethernet and it shows twice as well.

Still booting straight into LMDE.

does it have a boot menu?

That usb option has to do with usb lan option rom loaded or not, this is used for a usb to lan adapter and has nothing to do with this problem

1 Like

how did you write the EOS image to the thumb drive?

use dd or disk image writer from gnome disks utility

All 3 of my USB Thumbdrives were written via balenaEtcher. All three are accessible on my PC.

Not sure if it matters, but I installed LMDE on the laptop using the erase disk/automatic partitioning…

By boot menu i meant the bios boot menu (to select a boot medium) not the grub or dracut bootmenu from your pictures

BalenaEtcher is not the right tool as there are issues with it. So re write with my suggestion

Pictured above in the bios images. Boot priority/boot order

I’ll try that after work this evening.

Getting ready to leave for work. Post back quickly to say I had time to re-write the ISO to USB using KDE ISO Image Writer. Same issue persists. My BIOS may just be screwed up. The only options I have in BIOS are what is shown in the various BIOS images I’ve posted.

I’ll attempt some tinkering when I get home this evening. Appreciate the assistance thus far.

As much as everyone say’s etcher is not the right tool or otherwise that is nonsense i use it all the time and have never had an issue with it but what ever! In your Bios menu if you are giving it the option to boot debian and for what ever reason it isn’t booting on the live ISO it’s going to go to the next item in the list which is the debian installation. You need to disable boot option 3,4 and 5 and see whether it picks up on Boot option 1 or 2. In that case you may have an issue with the creation of the live ISO but i have no way of knowing that. You’ll have to try creating another live ISO and try booting it again. You don’t need to have a boot option in all of them if you are only trying to boot on the live ISO. Afterwards you can set that when it’s installed. You also don’t need what they call pixie boot unless booting from a network.

@ricklinux I’ve never had issues with Etcher either. As I said earlier, those USBs work fine on my PC, and I’ve since tried on my old HP laptop. I can get to the live environment of all the USBs those other machines. So it’s not the ISOs.

As for the boot priority in BIOS, there is no disable option, nor can I leave an option blank.

Once I get home from work tonight, I’ll see if I can dig deeper. But that BIOS set up is sparse.

Post a link to the laptop user manual.

As for the topic original question, it may be a bad firmware, or designed in a bad way, although it comes from AMI with a custom frontend.

I believe THIS is the manual link.

Your Bios up to date with the latest ‘BIOS’ software? You can reset your bios to default factory settings also, But after it boots up you’ve got to reset your time and some of the parameters you want to keep as to what the system boots off of.

There is no info about advanced settings. You have to find them yourself.

Suggested method (with laptop powered down):

  • Plug the USB installer on the laptop
  • Boot to BIOS (pressing F2, or Esc)
  • Check SysInfo page if the USB drive is recognized, and how (UEFI/BIOS tag)
  • Check the Advanced and Security pages for a UEFI setting (for USB, or storage) and set to UEFI
  • Save and reboot
  • Use the shortcut for Quick Boot menu (printed on the Boot Logo intro) to get a menu with available boot devices
  • Select a (suspected) USB entry that would contain “UEFI” in the name
  • Wish for luck :smile:
1 Like

I don’t see a setting in the images posted that shows if it’s set to boot UEFI or whether CSM is disabled?

Exactly what I mean by sparse. I don’t even know if there’s a CSM option available, I sure didn’t see it. Unless it’s some Samsung terminology. No problem booting into the installed LMDE, though. It recognized the USB at time of LMDE install. I’ll just do some investigating when I get home tonight.