Internet disconnecting constantly

I’ve had this issue since my first installation in September, and it’s followed me through a new installation. My internet is occasionally disconnecting for 10-30 seconds before coming back. It’s completely inconsistent when it’ll happen, sometimes it’ll go hours without doing it and sometimes it’ll do it three times within a 10 minute span.

These lines show up in the NetworkManager logs as it happens:

Jan 20 20:26:03 EndeavourOS NetworkManager[1024]: <info>  [1705807563.1549] device (enp42s0): state change: activated -> unavailable (reason 'carrier-changed', sys-iface-state: 'managed')
Jan 20 20:26:03 EndeavourOS NetworkManager[1024]: <info>  [1705807563.1550] dhcp4 (enp42s0): canceled DHCP transaction
Jan 20 20:26:03 EndeavourOS NetworkManager[1024]: <info>  [1705807563.1550] dhcp4 (enp42s0): activation: beginning transaction (timeout in 45 seconds)
Jan 20 20:26:03 EndeavourOS NetworkManager[1024]: <info>  [1705807563.1550] dhcp4 (enp42s0): state changed no lease
Jan 20 20:26:03 EndeavourOS NetworkManager[1024]: <info>  [1705807563.1668] manager: NetworkManager state is now CONNECTED_LOCAL

These are in the dmesg logs:

[Sat Jan 20 20:25:54 2024] r8169 0000:2a:00.0 enp42s0: Link is Down
[Sat Jan 20 20:25:55 2024] userif-3: sent link up event.
[Sat Jan 20 20:25:55 2024] userif-6: sent link up event.
[Sat Jan 20 20:26:01 2024] userif-6: sent link up event.
[Sat Jan 20 20:26:01 2024] userif-3: sent link up event.
[Sat Jan 20 20:26:10 2024] Generic FE-GE Realtek PHY r8169-0-2a00:00: Downshift occurred from negotiated speed 1Gbps to actual speed 100Mbps, check cabling!
[Sat Jan 20 20:26:10 2024] r8169 0000:2a:00.0 enp42s0: Link is Up - 100Mbps/Full (downshifted) - flow control rx/tx

Only thing understandable by myself is to check the cabling, but I doubt that’s it because I’ve tried multiple cables with the same result, and my connection never drops when I’m booted into Windows.

This happens on both wifi and ethernet, and I’ve tried both ethernet drivers with the same result.

Your using r8169 driver what happens if you use the r8168 driver instead?

Sorry I should have been more clear in my closing sentence, I tried both r8169 and r8168 with the same result

For the record, can you show the output of

inxi -Nza

Sure, forgot to include that in my post.

Network:
  Device-1: MEDIATEK MT7921K Wi-Fi 6E 80MHz driver: mt7921e v: kernel pcie:
    gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 29:00.0 chip-ID: 14c3:0608
    class-ID: 0280
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 2a:00.0 chip-ID: 10ec:8168 class-ID: 0200

Hi Noelle,

I was going through your older post to get to get your system information:

Looks like that system is different from the system your troubleshooting today(this one looks like it has newer Network card). Can you run:

inxi -Faz | eos-sendlog

It sounds like you are dual booting your system with Windows (which has no network outages)? Have you applied all the updated firmware to your desktop?

Do you also have the the Arch and LTS Kernels installed? If yes, and you boot the LTS kernel, is Ethernet and Wifi cards still operational. Or do we need to install additional drivers ( like you did in the testing you mentioned at the beginning of the post?

The reason I ask, I have a Realtek wifi (usb) devices in some of my home machines. In some cases the regular kernel built in driver was unstable for connections. The solution was switch to lts kernel. Then i install the recommended driver in the Arch wiki.

Yeah this is a completely different system from that old one, here’s the inxi link. I use primarily the Zen kernel, but I’ve tried both the regular and LTS ones with no change.

I’ve updated the BIOS if that’s what you mean, not sure what other firmware needs to be installed. The ethernet port I’ve been using is just the one integrated into the motherboard which I did all the firmware installation for when I built the machine.

From when I worked at IBM and with Lenovo usually there were also firmware for devices (e.g. cameras, harddrives, network cards). But based on the below link I am only seeing Bioses for your Motherboard (B550M-PRO-VDH-WIFI).

https://www.msi.com/Motherboard/B550M-PRO-VDH-WIFI/support#bios

I also noticed no notes on compatibility issues.

I have been digging around the internet and have some suggestions:

  • If anything is plugged in beside the ethernet (the 2 usb ports) please disconnect these.
  • go into the Motherboard bios and change in the advanced settings of the network adapter “speed and duplex” from automatic to 100 full duplex.

When your in Windows there is a chance it can override settings based on its driver settings. Lets make this small change to see if it helps.

Source:

Sorry this response is a billion years late, kept procrastinating on doing some actual testing.

The motherboard option didn’t seem to affect anything. Keeping the two ports free seemed to help somewhat? It still happens often but seems to be much less frequent than it is when I have things plugged into them.