Numerous Kwin issues

I switched over to Endeavour from Manjaro about a week ago and I’m having a lot of graphical issues weren’t present on Manjaro. My screen spazzing out whenever I close certain fullscreen games (Quaver and osu! both did it), and the main issue of my monitor’s refresh rate not working at all. I have a 165hz monitor and a 60hz one, and nothing was working in 165hz despite my settings being right, mangohud saying games were running at 165fps, xrandr showing it was 165hz, and so on.
The reason I say it’s a Kwin issue is that every issue immediately stopped when I disabled Kwin. Everything is much less pretty now but everything is SO much smoother than it looked before and it seems I don’t have the weird issues that the rhythm games were causing before.
I don’t mind keeping my pc this way but I did like the effects that Kwin had, made my pc feel a lot more personalised and stuff. Has anyone had an issue like this? I’d like to be able to reenable it but I can’t live with the issues I was having with it.

Welcome to :enos: forums @Noelle!!
It would be great to have your system information and logs as per this article:

Are you running x11 or wayland. What kernel are you running? What about your Graphics hardware/driver situation. These are the things that effect the things you’ve mentioned.

Welcome to the forum @Noelle :enos: :enos_flag: :partying_face:

Welcome @Noelle
As @sradjoker has suggested please provide some logs such as your hardware. All of the information on how to do this is provided in the Wiki.

Here is one you can use to upload your hardware info and post the link.

inxi -Faz | eos-sendlog

I am sure you probably mean the Compositor, since you can’t have a desktop without its Window Manager :wink: .
You may try altering the Render engine setting (or similar name…) in Compositor settings, instead of disabling (e.g. use Xrender).

Thank you for all the welcomes!
System info:

System:
  Kernel: 5.18.3-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    Desktop: KDE Plasma v: 5.24.90 tk: Qt v: 5.15.4 wm: kwin_x11 dm: SDDM
    Distro: EndeavourOS base: Arch Linux
Machine:
  Type: Desktop System: Dell product: OptiPlex 7010 v: 01
    serial: <superuser required> Chassis: type: 15 serial: <superuser required>
  Mobo: Dell model: 0GXM1W v: A02 serial: <superuser required> UEFI: Dell
    v: A29 date: 06/28/2018
CPU:
  Info: quad core model: Intel Core i5-3470 bits: 64 type: MCP
    arch: Ivy Bridge rev: 9 cache: L1: 256 KiB L2: 1024 KiB L3: 6 MiB
  Speed (MHz): avg: 1977 high: 2049 min/max: 1600/3600 cores: 1: 2007
    2: 2000 3: 1855 4: 2049 bogomips: 25554
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: NVIDIA GP108 [GeForce GT 1030] vendor: Micro-Star MSI
    driver: nvidia v: 515.48.07 arch: Pascal pcie: speed: 8 GT/s lanes: 4
    ports: active: none off: DP-1,HDMI-A-1 empty: none bus-ID: 01:00.0
    chip-ID: 10de:1d01
  Device-2: WaveRider USB 2.0 Camera type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-1.5:7 chip-ID: 0c46:636b
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
    compositor: kwin_x11 driver: X: loaded: nvidia gpu: nvidia,nvidia-nvswitch
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x1325 s-dpi: 91
  Monitor-1: DP-1 mapped: DP-0 note: disabled pos: primary,top-left
    model: VG248 res: 1920x1080 dpi: 92 diag: 609mm (24")
  Monitor-2: HDMI-A-1 mapped: HDMI-0 note: disabled pos: bottom-r
    model: Samsung SMBX2450L res: 1920x1080 dpi: 94 diag: 598mm (23.5")
  OpenGL: renderer: NVIDIA GeForce GT 1030/PCIe/SSE2
    v: 4.6.0 NVIDIA 515.48.07 direct render: Yes
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Dell
    driver: snd_hda_intel bus-ID: 1-1.2:4 v: kernel chip-ID: 0d8c:0005
    bus-ID: 00:1b.0 chip-ID: 8086:1e20
  Device-2: NVIDIA GP108 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s lanes: 4
    bus-ID: 01:00.1 chip-ID: 10de:0fb8
  Device-3: C-Media Blue Snowball type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Device-4: Logitech G433 Gaming Headset type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-1.4:6 chip-ID: 046d:0a6d
  Device-5: WaveRider USB 2.0 Camera type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-1.5:7 chip-ID: 0c46:636b
  Sound Server-1: ALSA v: k5.18.3-arch1-1 running: yes
  Sound Server-2: PulseAudio v: 16.0 running: no
  Sound Server-3: PipeWire v: 0.3.52 running: yes
Network:
  Device-1: Intel 82579LM Gigabit Network vendor: Dell driver: e1000e
    v: kernel port: f040 bus-ID: 00:19.0 chip-ID: 8086:1502
  IF: eno1 state: down mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: TP-LINK TG-3468 driver: r8169 v: kernel pcie: speed: 2.5 GT/s
    lanes: 1 port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: Dynex Bluetooth 4.0 Adapter [Broadcom 1.12 BCM20702A0] type: USB
    driver: btusb v: 0.8 bus-ID: 3-4:4 chip-ID: 19ff:0239
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
Drives:
  Local Storage: total: 2.28 TiB used: 1.77 TiB (77.5%)
  ID-1: /dev/sda vendor: Western Digital model: WDBNCE5000PNC
    size: 465.76 GiB speed: 6.0 Gb/s serial: <filter>
  ID-2: /dev/sdb vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB
    speed: 6.0 Gb/s serial: <filter>
  ID-3: /dev/sdc type: USB vendor: Generic model: Flash Disk size: 3.92 GiB
    serial: <filter>
  ID-4: /dev/sdd type: USB vendor: Seagate model: ST31000528AS
    size: 931.51 GiB serial: <filter>
Partition:
  ID-1: / size: 399.59 GiB used: 243.08 GiB (60.8%) fs: ext4 dev: /dev/sda5
  ID-2: /boot/efi size: 96 MiB used: 27.3 MiB (28.4%) fs: vfat
    dev: /dev/sda1
Swap:
  ID-1: swap-1 type: file size: 3 GiB used: 1.92 GiB (64.0%) priority: -2
    file: /swapfile
Sensors:
  System Temperatures: cpu: 55.0 C mobo: 27.8 C gpu: nvidia temp: 46 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 100%
Info:
  Processes: 256 Uptime: 18h 26m Memory: 7.72 GiB used: 4.36 GiB (56.5%)
  Init: systemd v: 251 default: graphical Compilers: gcc: 12.1.0
  Packages: 1305 pacman: 1296 flatpak: 9 Shell: Zsh v: 5.9
  running-in: konsole inxi: 3.3.17

What I did was disable the “enable on startup” option in the Compositor settings. and I don’t seem to be able to find any other options like what you mentioned.
image

Some logs would be great. Can you provide a boot log with compositor on? We might find something that’s wrong

journalctl -b -0 | eos-sendlog

It seems they have removed this setting. You may try altering the other settings and test for better results.
Use “Only when cheap” for Tearing Prevention.
Also try “Balanced” in Latency.
Try other settings until you find your HW/SW good combination.

Didn’t change any options but enabled it on startup and then rebooted. Here’s the log.

1 Like

Just some extra information I thought might be useful.
I made sure to set the RefreshRate and MaxFPS in kwinrc, no difference.
I used testufo.com to make sure I wasn’t just seeing things and sure enough, as I enable and disable the compositor it’s night and day. Looks like the only part of my refresh rate that’s actually working is my mouse cursor, since I mainly test refresh rate by circling my cursor and there doesn’t seem to be any difference. Apart from that though, looks like pretty much every program seems to be displaying in 60fps.

1 Like

These logs do not contain any significant display/kwin error (although there are several issues that would need corrective actions).

What was the behavior, in relation to your issues?

Do you have some reason you don’t try, as suggested, to alter compositor settings?
We need something to compare, when reviewing lengthy logs. We are neither kde nor nvidia, nor Xorg developers, if you thought so :person_shrugging: .

Help us help you :wink:

1 Like

@Noelle
I don’t see where you ever did answer @sradjoker whether you were using Wayland? Also you haven’t provided any boot logs as he requested

journalctl -b -0 | eos-sendlog

And as @petsam has said.

I think these are the logs

1 Like

To be fair those were provided, but did not try anything else.

Sorry @Noelle
I apologize i didn’t see see this right away. :astonished:

1 Like

Sorry I’m honestly not quite sure what I’m being asked right now lol. I tried modifying the settings that @petsam suggested (tearing and latency) but those didn’t seem to change anything at all.
All I know is that when I startup EOS with the compositor enabled then I get full screen glitches upon closing certain games, and that the compositor seems to lock my framerate despite everything saying it’s unlocked. I realize I have no way to prove that the framerate is off but I swear it’s extremely noticable. Disabling it fixes all the problems I get. I went back and forth with qdbus org.kde.KWin /Compositor suspend and qdbus org.kde.KWin /Compositor resume and it’s very clear.

Games are interfering with the system in a bad uncontrollable way.
If your system behaves properly in all other system activity, the issue does not exist (at least for myself).
Maybe others might be able to help.

I personally don’t want to waste my time to help Linux users play games, no offense.
1stW issues…

Looks like switching to Wayland is the only thing that would solve the fps issue at least, it’s immediately noticable and the kwin fps actually goes above 60 to my refresh rate. Unfortunately it’s Wayland so it’s really unstable and glitchy for me and I’d rather just have the compositor off completely.
I feel like I should probably just do a reinstall at this point. It’s gotta be something specific to my system since nobody was able to say they had the same problems. We’ll see how things pan out, either it fixes, or I at least get a nice fresh system. Thanks for all the help guys :slight_smile:

1 Like