Internal drive issue

I agree, I usually have to combine the wiki with another source of information

most of what i learned is probably like most others selftaught through trial and error, tho even with that i barely scratched the surface level.

god damn, I’m sorry!
Did you manage to get into your system to fix it?

I’m not being rude - I’m trying to provide an analogy for avoiding learning something.

This is why you need to understand what you’re doing before doing copying and pasting something from a web page.

1 Like

It takes time and the thing is to not give up. Linux (Arch) is like a universe and once you reach one destination there are many more. There are a lot of people with way more experience than myself and a lot have a grasp of the Linux command line that i don’t so i get it. I just try to learn something new everyday and i do! Some days.

i always keep a liveusb ready so i was able to get in and delete the entry, was right back.

i probably just did something terribly wrong.

could it be that the drive having a space in its name it also causing an issue? i have noticed that when i tried to set some path in wine.

when it was to what i entered it was all step by step, the uuid, the path, the format, defaults but no atime noticed that to late

I have to ask: is there something wrong in my fstab entry, because it works just fine here,

the fact i am here should be proof enough i am willing to learn no?
otherwise i would just use any other distro that wont give me this problem

i dont just copy paste whatever i see, another assumption that has been made, i adjusted the suggestion to my needs is all

1 Like

that’s possibly the culprit :slight_smile:

So - what did you add to your /etc/fstab ?

On what did you base the included information?

To help you with the entry you have to add to fstab we’ll need some information.

Please run the following commands in a terminal and post the results:

cat /etc/fstab | grep -v "#"

sudo blkid

UUID=C83C-D4DC /boot/efi vfat umask=0077 0 2
UUID=7ceb18dc-8232-4529-bc7c-1d228df1fc35 / ext4 defaults,noatime 0 1
tmpfs /tmp tmpfs defaults,noatime,mode=1777 0 0

/dev/sda1: UUID=“C83C-D4DC” BLOCK_SIZE=“512” TYPE=“vfat” PARTUUID=“8fe62bdb-4ba8-a545-b842-32494cdd1cd8”
/dev/sda2: UUID=“7ceb18dc-8232-4529-bc7c-1d228df1fc35” BLOCK_SIZE=“4096” TYPE=“ext4” PARTUUID=“5c31e520-6d92-aa4f-b87a-f7ee6dc49401”
/dev/sdb1: LABEL=“int drive” BLOCK_SIZE=“512” UUID=“B2DEC265DEC22209” TYPE=“ntfs” PARTLABEL=“intdrive” PARTUUID=“d9f514fd-8ab7-48e3-8476-7f17b9607fef”
/dev/sr1: BLOCK_SIZE=“2048” UUID=“2014-02-27-17-23-21-00” LABEL=“3InternetManager” TYPE=“iso9660” PTTYPE=“mac”

the one im trying to mount here is /dev/sdb1

NTFS changes some things :wink: .

I’ll need the terminal output of …

id

1 Like

uid=1000(honnoji) gid=1001(honnoji) groups=1001(honnoji),3(sys),19(log),90(network),94(floppy),96(scanner),98(power),983(rfkill),985(users),986(video),988(storage),990(optical),991(lp),995(audio),998(wheel),999(adm),1000(autologin)

i also changed the label of the drive which at least solved one problem i had specific to wine, the space in its name indeed caused a problem

however there is still he problem of it not being seen as a drive or empty when anything wine related runs

  1. Create a mountpoint
    sudo mkdir /mnt/myntfsdrive

  2. Open /etc/fstab in editor
    sudo leafpad /etc/fstab

  3. Add the following line …
    UUID=B2DEC265DEC22209 /mnt/myntfsdrive ntfs-3g user,exec,windows_names,uid=1000,gid=1001,dmask=022,fmask=133,umask=0022 0 0

  4. Save the file & reboot


You can read about the ntfs-options added to the fstab in the ArchWiki :smile: .

6 Likes

thank you, it seems like i was on the right track with my version of the command but had just left out a lot.

Solved the only other problem i had left here, tho i will try to read on the archwiki again if i find myself knowledgeable enough to understand it.

2 Likes

I have found myself relying on mount units - they provide a nice easy to understand implementation for the sometimes :stuck_out_tongue_closed_eyes: approach of editing fstab.

They are reusable as in - I store them with my dotfiles - and when I have reinstalled - which I do fairly often - copy them to the /etc/systemd/system - and enable them - with a second script to map my folders into my new home. It takes a couple of minutes after the install - to be fully up and running.

1 Like

Great that you got the problem solved! :smile:

And please, do not hesitate to ask if you find anything too hard on the Arch wiki pages.
We all have been and still are newbies, learning new stuff every day. :sweat_smile:

5 Likes

What OS are you using ?

why templeOS of course

5 Likes