Intel AX210 Bluetooth Won't Enable In KDE Plasma

I just bought and installed an Asus ProArt x570-CREATOR motherboard with the Intel AX210 WiFi6e/Bluetoop adapter on-board. The usb live environment of EOS works perfectly fine with my bluetooth headset, as did the fresh install of the system boot. However, a reboot of the PC took away the little tick box in the bluetooth system tray menu:

The System Preferences menu for bluetooth has an enable button but will not enable. I’ve tried the following:

rfkill list
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
Agent registered
[bluetooth]# info
Missing device address argument
[bluetooth]# power on
No default controller available
lsmod | grep blue
bluetooth             749568  12 btrtl,btintel,btbcm,bnep,btusb
ecdh_generic           16384  1 bluetooth
rfkill                 32768  10 asus_wmi,bluetooth,cfg80211
crc16                  16384  2 bluetooth,ext4
rfkill list
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
sudo dmesg | sudo grep -i 'blue'
[    3.412880] Bluetooth: Core ver 2.22
[    3.412893] NET: Registered PF_BLUETOOTH protocol family
[    3.412894] Bluetooth: HCI device and connection manager initialized
[    3.412897] Bluetooth: HCI socket layer initialized
[    3.412898] Bluetooth: L2CAP socket layer initialized
[    3.412900] Bluetooth: SCO socket layer initialized
[    3.534708] Bluetooth: hci0: Firmware timestamp 2021.39 buildtype 1 build 31878
[    3.538692] Bluetooth: hci0: No device address configured
[    3.539761] Bluetooth: hci0: Found device firmware: intel/ibt-0041-0041.sfi
[    3.539775] Bluetooth: hci0: Boot Address: 0x100800
[    3.539776] Bluetooth: hci0: Firmware Version: 134-39.21
[    3.539777] Bluetooth: hci0: Firmware already loaded
[    3.544239] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    3.544240] Bluetooth: BNEP filters: protocol multicast
[    3.544242] Bluetooth: BNEP socket layer initialized

All to no avail. Kernel, mirrors, and system are all fully updated and current versions. Any help would be greatly appreciated.

It’s not installed by default in Endeavour but does work on the live iso.

Read this and you’ll be all set.

1 Like

What does inxi -Na show?

Edit: It should be running on iwlwifi and you said WiFi is working.
I think you need to try with bluetoothctl commands to actually have it search, pair, connect, trust etc.

Edit2: Check out this post. I thought it was the same one?

It’s not installed by default in Endeavour but
does work on the live iso.

Read this and you’ll be all set.

Discovery – 11 Mar 21

Enable and setup Bluetooth devices

Enable and setup Bluetooth devices We do not enable Bluetooth by default, because of several security risks. To get Bluetooth working you need to enter this in the terminal: sudo pacman -S –n…

Thank you for the suggestion but I had already read and taken those steps before trying the ones in my original post. As mentioned, it worked in the initial boot of the system, too, but as soon as I rebooted the enable tick box disappeared and enable button stopped functioning in the Bluetooth section of the System Settings menu.

I haven’t run inxi, but I will and will update the op as soon as I get home from work.

It’s not a huge deal. I’m sure it’s just going to show iwlwifi which is the module running your WiFi and bluetooth is on that chip.

Replying since I had this issue on the framework laptop with the same wifi card as the OP. Based on what I know, this patch to linux-next fixes the issue. It didn’t make it into kernel 5.16.rc-1 so I don’t know when it will actually be merged into the mainline. However, you can try it out earlier if you install the kernel and the headers via the AUR package, run grub-mkconfig -o /boot/grub/grub.cfg and then select linux-next from the Endeavour OS boot menu.

Unfortunately this seems to cause some weird bugs with KDE so I’m just gonna deal with sporadically working BT for now.

Thanks. I take it this is a customized kernel?

It’s linux-next:

Oh okay …i see It’s almost like the RC kernel versions that are used in Ubuntu.

Yeah, I may just follow suit and wait for the next kernel to patch the issue if there’s no other feasible way to patch it without bugging out KDE. It takes hours of tweaking and customizing to get my KDE the way I want it and I don’t want to risk throwing a wrench into that. I have a custom script that automatically installs all of the packages, software, and BT stuff which I run on every fresh install and it hasn’t ever let me down until this damn AX210 chip came into play. I’ll probably deal until the kernel catches up with the hardware. Hopefully that’s not too far away. Congrats on the Framework laptop, btw! I’ve been tempted to buy one since I saw Linus take it apart in a video. Modularity, upgradability, and right to repair are the reasons I got into custom PC building in the first place.

Wow…i run KDE also but i don’t make too many changes and i have no issues. I have wobbly windows and magic lamp. I install apps i want but not much other than that. I don’t make a lot of changes. Everything works well.

I heavily customize mine with a labyrinthine array of widgets, theming, Latte, Kvantum, icons, a sensor panel screen inside my PC case made from System Monitor sensor applets (CPU temp, GPU temp, etc.), live video wallpapers and lock screen, and a bunch of other stuff. Every fresh install of Linux prompts hours of this customizing, and this is all after my custom script has already installed all the software I want via pacman and yay as well as setting default browser and installing/enabling bluetooth.

Ya i find too many people have problems when they customize everything. I don’t have Widgets although i have tried some stuff. I just install about 20 packages and have a few settings changes. Maybe background and icons or theme. Nothing major.

From what @ativ said, it sounds like the bluetooth problem is related to a patch that didn’t make it into the latest kernel. I don’t think it has anything to do with the customizations I make. Everything I customize is visual, other than changing the default terminal shell to fish. Applets, menus, docks, and panels shouldn’t affect whether or not the system is able to initialize the bluetooth controller. But we all have our own way and reasons we like Linux. That’s what’s so great about it, it kind of caters to everyone willing to give it the chance.

No I’m not saying anything about your Bluetooth issue being related. What I’m saying is people make all kinds of changes and their computer goes south and then they think we can just have a solution. The problem is i have no idea what they have done and what is causing the issue. I’m just saying i don’t have those issues that people have because i don’t make those kinds of changes.

Ah, gotcha. Yeah, that’s why I don’t make any system level changes to mine, either. I don’t know enough to go rooting around in the kernel or drivers. The most I do is change the package manager to pamac-all and the terminal shell to fish. The rest is just cosmetic desktop environment stuff.

Thanks! I almost regretted it since I could now buy a 14 inch M1 macbook for a few hundred more $ and that laptop is a beast but so far I’m enjoying the framework since it’s easier to play around with Linux.

I had just purchased the 14" MacBook Air weeks before Linus posted the Framework video. I love the MacBook, especially its fanless design, so no regrets, but Framework is just such an amazing concept. But, yes, having a Linux Framework would probably be way more useful seeing as I do the bulk of my desktop productivity on Linux already. Especially since it took quite a bit of terminal work to get a few things to be cross-platform from Linux on the MacBook. Luckily, Linux prepared me for working in the Mac terminal, which is also bash. Still, downsides of Linux are moments like this where the bluetooth just forgets it exists after reboot.

What about blacklisting the bluetooth chip and buying an USB bluetooth stick? They are not expensive at all and will work most likely without problems.