Bluetooth controller unavailable

Hi there! I’m having some trouble with my bluetooth. I’m using a framework laptop, and it seems that multiple people are having issues with it on Arch based systems:

The short of it is, it was on and working the first time I tried to pair a device, but the right after I paired a device it no longer works. The internal bluetooth hardware is being recognized, but doesn’t appear to be picked up properly by btmgmt or bluetoothctl.

Also, EndeavourOS is my first dive into an Arch system, so let me know if this is more appropriate for the Arch forums instead of here.

Would appreciate any help troubleshooting!

Some outputs:

uname -r


[bluetooth]# info
Missing device address argument

[bluetooth]# power on
No default controller available

[mgmt]# power on
Set Powered for hci0 failed with status 0x11 (Invalid Index)
lsmod | grep blue

bluetooth             729088  12 btrtl,btintel,btbcm,bnep,btusb
ecdh_generic           16384  1 bluetooth
rfkill                 32768  9 bluetooth,cfg80211
crc16                  16384  2 bluetooth,ext4

Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 004: ID 27c6:609c Shenzhen Goodix Technology Co.,Ltd. Goodix USB2.0 MISC
Bus 003 Device 003: ID 0bda:5634 Realtek Semiconductor Corp. Laptop Camera
Bus 003 Device 002: ID 32ac:0002 Framework HDMI Expansion Card
Bus 003 Device 005: ID 8087:0032 Intel Corp. AX210 Bluetooth
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
rfkill list

0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
dmesg | egrep -i 'blue'

[    3.880644] Bluetooth: Core ver 2.22
[    3.880661] NET: Registered PF_BLUETOOTH protocol family
[    3.880662] Bluetooth: HCI device and connection manager initialized
[    3.880664] Bluetooth: HCI socket layer initialized
[    3.880666] Bluetooth: L2CAP socket layer initialized
[    3.880668] Bluetooth: SCO socket layer initialized
[    3.946287] Bluetooth: hci0: Firmware timestamp 2021.38 buildtype 1 build 31586
[    3.948266] Bluetooth: hci0: No device address configured
[    3.949937] Bluetooth: hci0: Found device firmware: intel/ibt-0041-0041.sfi
[    3.950006] Bluetooth: hci0: Boot Address: 0x100800
[    3.950008] Bluetooth: hci0: Firmware Version: 98-38.21
[    3.950010] Bluetooth: hci0: Firmware already loaded
[    4.025445] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    4.025451] Bluetooth: BNEP filters: protocol multicast
[    4.025457] Bluetooth: BNEP socket layer initialized
systemctl status bluetooth

● bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
     Active: active (running) since Wed 2021-11-03 09:26:26 MDT; 18min ago
       Docs: man:bluetoothd(8)
   Main PID: 789 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 38247)
     Memory: 2.0M
        CPU: 16ms
     CGroup: /system.slice/bluetooth.service
             └─789 /usr/lib/bluetooth/bluetoothd

Nov 03 09:26:26 v-laptop systemd[1]: Starting Bluetooth service...
Nov 03 09:26:26 v-laptop bluetoothd[789]: Bluetooth daemon 5.62
Nov 03 09:26:26 v-laptop systemd[1]: Started Bluetooth service.
Nov 03 09:26:26 v-laptop bluetoothd[789]: Starting SDP server
Nov 03 09:26:26 v-laptop bluetoothd[789]: Bluetooth management interface 1.21 initialized

I’m having similar issues with bluetooth connectivity. It’s not happening via bluetoothctl CLI or blueman-manager GUI.
Found this thread when I searched using the error message I was getting.
Listed as RESOLVED, but the OP is apparantly still having the problem.

I only just installed EOS a few days ago and was dreading this. In the past I’ve had so much trouble connecting to bluetooth that I was pulled back into Windoze like Michael Corleone, “Just when I thought I was out!”

I’ll just use a 3.5mm cable and keep hacking. Cleverer people than myself are bound to find a fix to this endemic issue. I hope your Platform laptop has a mic jack. That is an awesome company making those; good for you!

I recently tried an Arch-based ISO from Chris Titus Tech, and the bluetooth functionality was good right from the start. As I recall, my previous attempts with other Arch-based distros ( I guess Chris doesn’t consider his release a distro…who am I to say? ) didn’t hold up too well in regards to bluetooth either.
May be a wicked problem?

Sometimes bluetooth can have issues pairing, registering and so on. It’s best to use blutoothctl and go through the process of clearing it and starting from scratch to see it scan, connect, pair, register, trust etc…

Give it a try maybe.


Yea I’ve gone through a bunch of similar links but none have helped. I get no default controller available running pretty much any bluetoothctl command so I can’t even use that utility.

Did you go through the wiki? What desktop are you running?

Have you tried the following commands?

systemctl enable bluetooth.service  
systemctl start bluetooth.service

It seems some users have issues with the AX210

I read this from another forum. Not sure if you are experiencing the same issue?

The AX 210 Bluetooth controller does not get initialized after a warm boot.
It gets initialized after a cold boot had been performed (going to the BIOS menu, doing nothing and leaving it, afterwards starting Linux).

In both cases the bluetooth USB

Did you go through the wiki?

Yup, all those packages are installed

What desktop are you running?

I use KDE, I’ve tried installing bluedevil which is the KDE bluetooth manager, but it adds a bluetooth menu to system settings with an Enable button that does nothing.

Have you tried the following commands?

Yup, output of systemctl status bluetooth.service is in the OP and it’s running.

It gets initialized after a cold boot had been performed

Tried a cold boot, it didn’t work. Some users on the framework forum said bluetooth gets enabled 1/10 of every cold boot or so, but not consistently in any way.

Edit: Some people are talking about the issue here: One user said compiling the kernel with gcc 11.2.0 seems to fix this issue, but he is using Gentoo Linux. Might give it a shot later.

Bluetooth can be somewhat difficult. It also depends on what device you are trying to connect to. Some connect like magnets others quite the opposite. I think the Intel AX210 WiFi 6 has Bluetooth on the same chip? So there is a kernel parameter for bluetooth coexist and also some power managemnt settings. for the module. I’m not sure if you have bluez installed & bluez-utils?

Anyway the Bluetooth info is near the bottom of the page here if it has any relevance.

Edit: I have also read another user with Framework laptop having 5.13 kernel working with Bluetooth somewhere.

So after today’s system update, the bluetooth controller is now working as expected. Seems to be still working after both warm and cold boots. Not sure if any of the updated packages actually fixed the issue since none of them appear to be bluetooth related. I have a feeling the issue will come back but for now it’s working.

Thanks for taking the time to help out y’all!

It’s probably kernel related maybe? Did you just get the 5.14.16 kernel?

I believe I’ve been on 5.14.16 for a few days, but not positive

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.