Installer broke ... again, package manager error

Today I tried unsuccessfully to install EndeavourOS on my ThinkPad.
I get the same error as in the following post:

The workaround described therin did not work in my case.

broke again … sure… :artificial_satellite: —> Plasma 6 (KDE) just reaching the repositories - #75 by pebcak

there is a huge kde plasma 6 update… packages changed.
You can simply remove the culprit not existing package anymore form the list on packages screen…

it is:

but by now… the hotfix should already should get applied in case you are not in a country that banning you from access github/gitlab


Thanks for the quick reply.
Then it was probably just the wrong time when I tried to install EndeavourOS. :slight_smile:

As I understand it, it only affects the Plasma DE and all other DEs should work?

I didn’t know about the hotfix page on Github. Thanks for the hint.

Would you rather suggest to wait until Plasma 6 is fully implemented and the next ISO is released or install it with the hotfix? I’m afraid I’ll have to fix some things afterwards if I install it with the hotfix now.

if hotfix is used it should not make a difference online installs are complete fresh installs from scratch they do not use any stuff from ISO itself.
The hotfix exchange the packages installed to reflect changes for plasma 6.

Could you please tell me how to apply the fix?
Do I download the .bash file and execute it somehow in the live system or do I just extract the relevant commands and execute them in the bash?

it is hotfixing when you start the installer without manual intervention needed.

Only if your country is blocking GitHub and GitLab access it will not get applied.
To make sure you can check after starting installer:

the package list should not have khotkeys

in the log it should show it is patching packagechooser.conf

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.