Installed new ISO, still asking for password to mount storage partition

I just installed the new ISO, and I can’t access the ntfs Storage partition w/o entering password. I remember this was an issue with my original install, but I thought it was supposed to be fixed on this release.

So, how can I change the permissions so I don’t have to enter a password every time?

Thanks for any help.

Keith

hi,

i got not clue basicly i got no ntfs in the system… :slight_smile:
but this make pretty much sense you need ntfs-39 from repo , this wiki :
https://wiki.archlinux.org/index.php/NTFS-3G#Configuring

i think you have to add in your fstab, probably that drive is in your computer, then you can configure permissions on it.

btw typing ‘‘groups’’ make te list some simpler to read :slight_smile:

Just be cautious that adding the ntfs partition to fstab may break your boot process!

I have the same issue and tried adding the partition in fstab first. Unfortunately this led to the OS booting into rescue mode. I guess one somehow needs to make sure that the ntfs driver is available during boot time, change the grub loader command? Haven’t had time to look into this yet though.

1 Like

i dont know if udisks2 can handle ntfs if ntfs-3g is installed?

Please ignore my post above, was an error on my side, typo in my UUID :hot_face:

I can confirm this works:

  • ntfs-39 installed
  • modified fstab (UUID=0F5A1C8622709006 /media/Win10 ntfs-3g defaults 0 0

Sorry for confusing things…

1 Like

generally Linux will not mount external storage without asking you for admin rights.
This is a good security level and nothing we will change.

As already suggested you can add any partition/drive to default mounted inside fstab if you need them mounted by default.

But it is not a good idea to mount a windows ntfs system partition into linux by default. i never would do this.
A sit can cause hang on boot for both OS, and can cause issues on Windows updates too.

2 Likes

How to automount windows ntfs partition with linux compatible permissions, i.e. 755 for directories (dmask=022) and 644 for files (fmask=133):

Make a (permanent) mount point: e. g.

sudo mkdir -p /media/ntfs01

Get users UID and GID:

id -u youruser
id -g youruser

Get UUID of your ntfs drive/partition:

sudo blkid

Now edit your fstab:

sudo gedit /etc/fstab

add the following line; make sur to use your UUID, UID, GID and mount point

UUID=5678DE8222DE589E /media/ntfs01 ntfs-3g user,exec,windows_names,uid=1000,gid=1001,dmask=022,fmask=133,umask=0022 0 0

Now either restart or mount without restarting with

sudo mount -a


If your NTFS drive/partition contains Windows hibernation data the mount can sometimes fail. In this case you can remove this data with

sudo mount -t ntfs-3g -o remove_hiberfile /dev/sda1 /media/ntfs01

Be sure to use the correct partition (e. g. /dev/sda1) and your mount point.

3 Likes

I agree, main reason for me to mount the partition was to get rid of the message showing up after every boot which @keith mentioned in his opening thread.
I would much rather avoid getting that popup instead of auto-mounting if that’s possible.

That popup is the way system ask for the password… you can change this to another one but it will pop up also…

  • lxqt-policykit, which provides /usr/bin/lxqt-policykit-agent
  • lxsession, which provides /usr/bin/lxpolkit
  • mate-polkit, which provides /usr/lib/mate-polkit/polkit-mate-authentication-agent-1
  • polkit-efl-gitAUR, which provides /usr/bin/polkit-efl-authentication-agent-1
  • polkit-gnome, which provides /usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1
  • polkit-kde-agent, which provides /usr/lib/polkit-kde-authentication-agent-1
  • ts-polkitagentAUR, which provides /usr/lib/ts-polkitagent
  • xfce-polkit-gitAUR, which provides /usr/lib/xfce-polkit/xfce-polkit

xfce4-polkit

Hm, I don’t want to hijack this thread but I realize my response was misleading. Really all I want is for the OS to not bother mounting this partition.
It’s dormant, a backup just in case, and I haven’t booted Win10 in months,.

So it’s not the popup itself which is annoying, a different popup wouldn’t help, but rather the fact that I keep on getting asked to unlock this partition.
And right now the only way I figured out to get rid of this question was to give the OS what it wants by auto mounting followed by hiding the drive in Dolphin.
Maybe removing the ntrfs-3g driver would quiet things, but every now and then I need to work with ntfs formated USB drives, so not an option either.

If you use the noauto option in fstab you will not be asked for a password and your partition/drive will also not be mounted.
It can then be accessed in Thunar or other file managers simply by clicking on it. Until then your ntfs-drive will not be actually mounted!

UUID=5678DE8222DE589E /media/ntfs01 ntfs-3g noauto,user,exec,windows_names,uid=1000,gid=1001,dmask=022,fmask=133,umask=0022 0 0

1 Like

then what @2000 is giving will be the solution for you ?

Unfortunately no, this was one of the things I tried fairly early on and just tried again. The moment I add noauto to the fstab entry, the “authentication required” popup shows up after the system is up and running.

  • No entry in fstab -> authentication request shows up
  • fstab entry with noauto -> authentication request shows up
  • fstab entry without noauto -> All quiet, partition is mounted

My initial suspicion was that maybe Plasma or Dolphin somehow remember drives which were open at some stage and keep on trying to reopen upon launch, but I couldn’t figure out where such a thing may be captured.

But like I said, I don’t want to hijack this thread, I have a solution, albeit not ideal because what’s not used should not be mounted, but it’s sufficient for me.

Thanks guys for helping out!

never used dolphin on my regular systems…

For me using nautilus or thunar it only ask for a password when i try open this location, so it might be dolphin settings, i remember to see this question before somehow…

Hmm; if you are not actively accessing the drive this is exactly what noauto should help with (https://wiki.archlinux.org/index.php/NTFS-3G#Basic_NTFS-3G_options)

Some other things you may or may not have tried, so here goes:

  • chown the (empty!) mount point to your user (e. g. sudo chown -R yourname /media/xyz)
  • use the user or users option to allow your or all non-root users to mount/unmount
  • As a LAST RESORT you could make a ntfs-3g binary setuid-root with: sudo chmod +s /bin/ntfs-3g (https://www.tuxera.com/community/ntfs-3g-faq/#useroption discourages its use)

At your leisure, if you happen to have some time, I’d be really interested in you testing the following (and not just adding noauto to your existing fstab entry) if you haven’t already done so …

UUID=5678DE8222DE589E /media/ntfs01 ntfs-3g users,noauto ,windows_names,uid=1000,gid=1001,dmask=022,fmask=133,umask=0022 0 0

(of course you’d have to adjust the mount point, uuid, uid and gid for your user)

If this doesn’t work then there is definitely something off about your system. All my systems (different Arch, Debian, Gentoo distros) all honor noauto if ntfs partitions could potentially be accessed. I have actually never encountered and therefore thought about the problem you’re having; it just works.


(Edit: Wrote the above before doing a quick search!)

Your suspicion about some process (KDE/Dolphin?) trying to (re)open the drive may be correct.

A quick search …

suggests it is a KDE problem and a workaround could be editing
/usr/share/polkit-1/actions/...
But those solutions are quite old, so (?).

I don’t run KDE/Dolphin on any of my machines, so … I guess that is why I luckily have never encountered your problem. XFCE, Cinnamon, Gnome or MATE should work :wink: just as Joe and I have experienced.

2 Likes

That one I had set already.

Made the change, but still get the “Authentication required”!
It seems that the “user” option is not supported out of the box because when I try to mount as user manually I get the below:

mount /media/Win10
Unprivileged user can not mount NTFS block devices using the external FUSE
library. Either mount the volume as root, or rebuild NTFS-3G with integrated
FUSE support and make it setuid root. Please see more information at
http://tuxera.com/community/ntfs-3g-faq/#unprivileged

I had a look at /usr/share/polkit1/actions but not sure what to do with the list. I’ll read up some more on this subject but in the meantime I will just mount as as root in fstab (default 0 0) and be done with it.

Thanks for helping me along with this!

ntfs-3g-fuse AUR package description: Stable read and write NTFS driver and ntfsprogs. This package will allow normal users to mount NTFS Volumes.

#1 You could try to nstall ntfs-3g-fuse from AUR and maybe also make it setuid root with
sudo chmod +s /bin/ntfs-3g
(I think it will still be ‘ntfs-3g’ even after installing ntfs-3g-fuse, but I could be wrong.)

– Or –

#2 this post propagates the following:

Edit
/usr/share/polkit-1/actions/org.freedesktop.udisks.policy

Search for this portion
<action id="org.freedesktop.udisks.filesystem-mount-system-internal">

and change
<allow_active>auth_admin_keep</allow_active>
to
<allow_active>yes</allow_active>

1 Like

#bestcommunityever

2 Likes