Installation stuck at 13%

Just guessing, but in the AUR there is r8125-dkms package, maybe that could help (instead of the r8169 kernel module)?

Unblacklist that you mean? As currently I have no DNS resolution, so no connection. I might try and swap the Ethernet cable to the intel card, see if that makes a difference. If that works then I can look at possibly downloading the AUR package you mentioned. But this doesn’t make sense as I had a connection prior to reinstall and during re-install unless maybe a package update should have been done before re-install…

TL;DR
Could you explain exactly

  1. When was it working? Did you already have EndevaourOS when it worked, or some other OS?
  2. What did you do?
  3. On re-install, did you choose something different than before?
  4. Why did you re-install?

Thanks for coming back to me. So I downloaded Iso recently and add it to a USB stick which has Ventoy configured on it.

  1. booted from live img, and tried to install online however install was getting stuck at 13% due to potential script not importing key asper prior post, so ran offline installer and that installed successfully.

  2. Proceeded to update the distro and install another DE (initially Deepin but that cause issue with display composition) so decided to install Plasma and that worked fine.

  3. So I thought to myself, stupidly possibly, lets look at the posts and try and follow the advice given by editing the script in Calamares. This would potentially save space by not having multiple DE’s installed (although I am aware that DE’s can be removed as needed, but I wanted to attempt an online install which completed successfully. The option selected during online install were: KDE DE, lts option, printing support and accessibility options. Nothing else. Online install completed successfully.

  4. Post install, I rebooted and not gui login screen, no internet and just a tty terminal. I can successfully login to the terminal and run cmd line arguments but unable to access the internet due to Dns resolution failure following enabling the NetworkManager and it’s service and no GUI to login despite enabling sddm.
    Following a further reboot now I have to press CTRL+ALT+F2 in order to login on tty2 as tty1 seems to just remain at checking files and blocks with flashing cursor below that.

Hope this helps :slight_smile:

Use the command nmtui(The terminal front-end for network manager) to take a look at your network settings and see what it missing. Enabling network manager may not be enough to get you a fully functional network connection.

That sounds like an issue with your graphics drivers. Can you share the output of

pacman -Q | grep -i nvidia

Results show:

nvidia-dkms 510.54-1
nvidia-installer-db 2.5.7-1
nvidia-installer-dkms 3.3.15-1
nvidia-utils 510.54-1

nmtui shows all network adapters.

Entered the wireless password and when trying to ping www.bbc.co.uk I am getting:

Temporary failure in name resolution.

Will try and add the gateway manually although this was set to automatic

For the network, what does ip a show? Are you getting an IP address?

So it seems that the wifi is connected :confused:

It looks the wifi is connected but so is enp4so. Are you connecting your wireless and your wired adapters to the same network?

What does ip route and cat /etc/resolv.conf show?

Ok done ip r and seeing this…

So both the wireless and wired connections are getting an Ip address from the looks of it

What about the other command?

No such file or directory…

Go into nmtui, and look at the DNS settings for your wired connection on enp4so

IPv4 settings are on automatic but should this not resolve automatically the dns servers? I can add them manually and see what happens. But this is what I see currently

The ipcomfig cmd though seems to show the dns server which should be the router as one of them. Will try entering the google dns servers IP addresses.

Same issue even by entering google dns servers. Does a daemon or service need to be restarted at all for these changes to take effect? Booting back in to windows i don’t have an issue in connecting to the net…

It shouldn’t.

It is strange that NetworkManager isn’t writing an /etc/resolv.conf

I would use nmtui to disable your wireless connection.

What does this mean?

Sorry, ipconfig is a windows cmd line tool like ip. Must have been predictive text :crazy_face:

Also prior to accessing nmtui the wireless was not configured with the wireless password, therefore the only connection that was present was the ethernet one and still having the same issue but will try.

Just a thought… could it be a hosts issue?