Installation stuck at 13%

Thanks to everyone for your help today. EOS now updating quite happily from the looks of it.

Spoke too soon… Pacman now stuck once again from the looks of it at importing the following key:
:: Import PGP key C132293954BBE4AD, “Sergej Pupykin”? [Y/n] Y

Any ideas?

Yes… These were all posted in the forum previously, you can use the search button on top right of the site… Many of the answers can be found there.

Just wondering if the iso should get a hot fix, if both of these issue still appear for new users installing and updating eos the first time…

1 Like

yay -Sy archlinux-keyring

Then try updating.

Thanks again… i did find the cmd scouting through the forums.

Ran sudo pacman -Syy archlinux-keyring in terminal and the sudo pacman - Syu

That worked a treat.

Had to reboot into windows to do some work stuff in preparation for tomorrow.

Weekend goes so fast, 2 days off don’t seem enough haha.

I can now look at changing DE :smiley:

It is possible to have interchangeable DE in EOS, right?

Any advice in package management gui for EOS?

This is caused by mirror problems. The first thing is to have good mirrors. The second is to make sure they are synced after.

Update the mirrors making sure you are selecting countries that have good mirrors. Then run sudo pacman -Syy Then run the update command.

1 Like


I’d highly recommend Octopi using yay as AUR backend, in case you need AUR.

1 Like

Thanks, but are these not updated during the install? Or is this not the case despite updating the mirror list prior to running the live installer. As I am in the UK I also selected alternate country mirrors for redundancy (France, Germany, etc)

Will look into that. Thanks for the heads up :smiley:

Nothing wrong with Octopi. I just didn’t particularly like it when i tried it which was a long time ago. I use pamac-aur-git and rarely have issues with it but, you can and sometimes it does happen to users. It’s all about choice so you can use what ever you feel comfortable with. I would recommend trying Octopi. You don’t know until you use it. I may even try it again myself. :wink:

The mirrors do get updated on the install but i still find when you have issues this procedure works well only if needed. Updates from Arch are constant so some mirrors may not always have updates yet or the mirror has a problem and you can’t seem to fetch it.

I am not sure I understand why that would be a mirror problem. It looks to me like this is an offline install which has packages that are now a couple months old including the arch keyring. Maybe I am missing something you are seeing.

1 Like

No i think i was assuming it was an online install. My bad! You are right … again as always. :laughing:

Edit: I guess i should have said this could be caused by a mirror issue.

1 Like

[quote=“dalto, post:30, topic:24322”]
this is an offline install which has packages that are now a couple months old including the arch keyring. … [/quote]

So people installing Neo now may be affected? Is it possible to inform them of this on the download page?

affected by using arch and the need to solve package changes … this will happen on rolling releases from time to time :wink:
And there are already a bunch of posts about what to do to solve it.

1 Like

I have just edited the script you mentioned/etc/calamares/scripts/create-pacman-keyring and that has fixed the online installer. Currently at 36%. Tried to install a different DE following the offline install and desktop composition what displaying strange behavior when switching between them at logon, so decided to re-attempt online install. When I first read your comment, I must have misinterpreted what you were saying. Hopefully the online install will now complete.

1 Like

when I had that problem
I just used
sudo pacman -Syyu archlinux-keyring
and I update mirror list
and then it worked
it works every time
even with endeavouros-2021.08.27-x86_64.iso
i like endeavouros-2021.08.27-x86_64.iso better than the new version

Thanks for that :slight_smile: . Online install successfull although I am a bit puzzled as to why I am getting a tty terminal session, when I did actually choose a DE. I have read other posts and connection was present at the time of the install and I did not choose a community edition :confused:.
Will try and enable either sddm or lightdm in the morning and see what happens.

cat /var/log/endeavour-install.log | eos-sendlog

That is interesting. For some reason ot seems that the machine where eos is installed has no access to the internet.

Getting: could not resolve host:

Ping also returns error in name resolution yet I have connection to the internet on wifi to my mobile and other devices. Will look at enabling network card via cmd line. Maybe that has not been configured mid or post install. :unamused:

So, ransystemctl status NetworkManager and that showed that Network Manager was disabled then ran systemctl enable NetworkManager and that created symlinks however not yet rebooted but when I tried to ping i got once again could not resolve host. The PC where eos is installed is hard wired, but also does have the ability to run wireless too if needed, but not gone down the route of entering SSID and password for the Wlan.

Will try a reboot and see what happens.

Post reboot update…
Still no joy with connection despite enabling NetworkManager and NetworkManager.service.
lspci identifies 2 network cards, one intel and one realtek (however this is not the r8169 as mentioned in prior articles as being blacklisted).

Also as I am not seeing a login greeter screen I have also tried to enable sddm, as lightdm does not seem to be present, and reboot but to no avail. Still presented with tty terminal, which is no issue as at least I get to learn a bit more on how Arch works. :smiley:.

I am not sure if you can tell how determined I am in moving away from Windows, although I am a Microsoft Certified Professional haha…