Installation on Lenovo Ideapad L340 Gaming - Blackscreen

Hello everyone,

I am currently trying to get EOS going on my laptop, since I do like arch on my desktop and EOS promises to give arch without all the installation hazzle. I am still on manjaro on the laptop at the moment, since I’ve run into issues.

At first I ran into an error PXE-E61: Media test failure, check cable., to which I tried changing the mirror for the .iso. Since that didn’t work, I then changed the usb device. That did solve the PXE issue, but left me with another problem:

Upon selected the usb drive to boot, the screen stays black with a white underscore flashing. Something odd I’ve noticed is that the screen seems to be at 1080p initially to then change resolution.

The screen with the flashing underscore is completly unresponsive. I have tried E to be able to add no modeset to grub, as some other forums have suggested. Since that didn’t work, I tried to create the stick on another machine. Same thing upon booting.

I have created all my sticks with dd, first with just the bs parameter, upon failure I added the suggested oflag and conv parameters. That did not do the trick. I verified both the german and the github mirror iso with the given sha512 test. I did also try the iso in both qemu and VirtualBox, which both worked just fine. So the .iso doesn’t seem to be the issue.

I think the problem might be due to my GPU, which is a GTX1650. The gpu itself has the weird habit of only turning on when the power cord is plugged in, though. This is one of the main reasons that I wanted to switch from manjaro, since I couldn’t get prime nor anything alike running. Does anyone have an idea of what to try next?

1 Like

PXE-E61 error is that it is trying to boot using network boot and cannot read the media. Change the boot setting in the Bios so that PXE boot is disabled. Hopefully you are also booting from nvidia on the live usb.

The PXE error did occur with another usb storage, no matter the setting in the bios.

As for the booting from nvidia, I don’t really know what you are trying to say.

You might be hardware-limited here. The best option, if it’s available, is to disable switchable graphics in the BIOS/UEFI.

Posting a full set of hardware information may be helpful, e.g. the output of inxi -Faz .

That should be nomodeset .

If you provide the actual command you used it will mean people don’t have to guess.

Therefore you might want to try a different USB flash drive.

1 Like

I do not have an option to do anything like that in my bios, been looking at all settings a couple of times by now.

Here you go:

My apologies. I don’t even get the option to input anything alike, so that is not something that has gone wrong so far.

I didn’t think there’d be something to guess, since dd has a minimum of two parameters and bs=4M seems to be pretty standard for creating bootable drives. But here you go: sudo dd bs=4M if=/path/to/endeavouros-x86_64.iso of=/dev/sdX conv=fsync oflag=direct status=progress, taken straight from

I did, I currently have two different flash drives plugged into the system, both created on different machines with different isos, still the same error.

1 Like

Did you try nomodeset again as you misspelled it?

As I already said, I did not get a chance to set nomodeset anywhere. I can boot to manjaro just fine, but booting to the flash drive will result in a completely unresponsive black screen with a flashing white underscore. I can do nothing but turning the device off.

Can you try using popsicle to create the live usb on Manjaro.

Edit: You’ll have to install popsicle first.

1 Like

So, for whatever reason that worked. I was able to boot into EOS live, selected Nvidia graphics and installed just fine. Upon reboot the machine threw an error, most likely unrelated to this topic. It now mentiones /boot/grub/x86_64-efi/mnormal.mod not found. No biggie, I thought, since I have the flash drive very much at hand.

Upon on trying to boot again into the flash drive, that had just worked fine and installed EOS, I am again facing a flashing underscore on a black screen. This is utterly confusing. I don’t know wether to mark this as solved, since the problem still kind of exists. Even though I will most likely be able to fix the grub issue otherwise.

Just a few questions? You have secure boot disabled, CSM turned off and set to UEFI. You installed in UEFI mode i assume? Running EOS try.


Edit: Since you got the grub error message for some reason. It might not hurt to reinstall grub and update it. Then try a reboot and see if all is good.

sudo pacman -Syu
sudo pacman -S grub-tools
sudo pacman -S grub os-prober
sudo grub-mkconfig -o /boot/grub/grub.cfg
1 Like

The grub issue somehow solved itself after playing around with the boot order. I am now in EOS and already did a pacman -Syu. Secure Boot and everything is disabled. Had no Issues until today, to be honest.

I did also use a kubuntu flash drive, just to be able to look if the filesystem had somehow gone corrupt, and that booted all normal. Another arch drive I quickly set up also threw up a grub error, which seems to be confusing. Nonetheless, the EOS drive worked just once and I have no idea why it did not work before or why it stopped after one go. I might open a github issue, just for completeness’ sake.

/e: After the laptop went to sleep right now due to inactivity, it again showed that damned black screen again after waking up. This is really, really confusing.

When you say playing around with boot order tends to make me wonder what else you have installed? Posssibly that may be the issue with the boot error?

There is only an additional windows partition on the machine, but the boot menu still recognizes manjaro. If I manuall check the ssd instead of the preselected “manjaro”, it works. I don’t think this is related to the usb drive not working as I expect it would.

So you are dual booting Windows and EOS? Does the grub menu only have EOS & Windows? Post the output of efibootmgr.


Edit: I’m not sure what you mean by this? If manjaro is no longer installed it shouldn’t have any entry for manjaro in order to boot manjaro.

"If I manuall check the ssd instead of the preselected “manjaro”, it works"

Edit2: It is possible to still have an entry for manjaro in efibootmgr but that can be removed easily that’s why i want to see the output.

Sorry, if my description was ambiguous, not grub is showing several entries, the bios is. Upon reaching grub, it only shows Endeavour.

So, to clear things out:
When booting without any further action, the system boots to grub rescue. Upon inspection of each of the shown drives, I always get a filesystem unknown error.

When going into the BIOS boot menu and selecting the drive on which EOS is sitting, I can boot just fine. In the BIOS boot menu on first place there is still “manjaro” as option, stating the same drive on which EOS is now. Afterwards, Grub loads with the selection of EOS. No mention of the windows partition, though. I can boot normally.

I tried manually creating another boot partition, since… Well. I just felt that might help. That left me with no actual improvement. The procedure is the same, only that now the system freezes after a few minutes of using it, no matter if I already logged into an x session or not. I had the mouse and system freeze on the login screen to. Funnily, when using TTY the system does not freeze.

I will mark the topic as solved anyways, since none if this is related to the stick not working. I honestly don’t know what held me back there. I feel like the current problem belongs in a seperate topic with proper title.

Blockquote So you are dual booting Windows and EOS? Does the grub menu only have EOS & Windows? Post the output of efibootmgr.

That leaves me with EFI variables are not supported on this system. I don’t know why this is happening. I have been booting with NVIDIA uefi in the live iso and haven’t really changed anything. This has also happened before creating a seperate boot partition.

Notes: The Grub rescue message is, as mentioned above:

You can see the result of fdisk -l, lsblk -ft, ls /boot, ls /boot/grub and cat /etc/fstab in this pastebin:

Are you able to boot into endeavour?


Did you try updating grub?

sudo grub-mkconfig -o /boot/grub/grub.cfg

I did.

Did you reinstall grub first and then update it?